Results 1 to 5 of 5

Thread: mysql drivers for metasploit are not load after update (bt5)

  1. #1
    Just burned his ISO
    Join Date
    Nov 2011
    Posts
    3

    Unhappy mysql drivers for metasploit are not load after update (bt5)

    I would like to help with the following problem
    After an upgrade to BT5, mysql drivers for metasploit are not loaded (connected).
    I have installed mysql gem :
    HTML Code:
    root@bt:~# gem list mysql
    *** LOCAL GEMS ***
    mysql (2.8.1)
    
    root@bt:~# gem which mysql
    /usr/local/rvm/gems/ruby-1.9.2-p290/gems/mysql-2.8.1/lib/mysql.rb
    
    root@bt:~# update-alternatives --config ruby
    There are 2 choices for the alternative ruby (providing /usr/bin/ruby).
    
    Selection    Path                Priority   Status
    ------------------------------------------------------------
     0            /usr/bin/ruby1.8     500       auto mode
     1            /usr/bin/ruby1.8     500       manual mode
    * 2            /usr/bin/ruby1.9.2   400       manual mode
    the current version of metasploit metasploit v4.2.0-dev:
    I have reviewed many forums on the topic but to no avail
    http://www.backtrack-linux.org/forum....html?langid=4
    http://www.backtrack-linux.org/wiki/...ramework_MySQL
    http://www.youtube.com/watch?v=N4SYavFeJgA

    My backtrack version is BT5 gnome 32-bits
    I know I have the postgres driver active but prefer to work with mysql.

    be eternally grateful if you could help me with this issue.

    Sorry for my English

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: mysql drivers for metasploit are not load after update (bt5)

    From what I remember metasploit does not support anything else except postgresql which comes with the msf package and it automatically started at boot.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  3. #3
    Just burned his ISO
    Join Date
    Nov 2011
    Posts
    3

    Default Respuesta: mysql drivers for metasploit are not load after update (bt5)

    Hi sickness thanks for your answer,
    well actually it seems both Databases are supported from the original ISO, unfortunately I could not correct this issue. I can only get used a bit pssql.

  4. #4
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: Respuesta: mysql drivers for metasploit are not load after update (bt5)

    The original ISO has both because that version of metasploit supported both, later it was decided that they were not working good so metasploit sticked to postgresql.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  5. #5
    Just burned his ISO
    Join Date
    Nov 2011
    Posts
    3

    Default Respuesta: Re: Respuesta: mysql drivers for metasploit are not load after update (bt5

    ok now I understand, thanks for your reply.

Similar Threads

  1. mysql in metasploit 4.2.0-dev
    By zimmaro in forum BackTrack 5 General Topics
    Replies: 3
    Last Post: 12-05-2011, 09:42 PM
  2. Metasploit V3.8.0 & MySQL
    By Si2006 in forum BackTrack 5 Bugs
    Replies: 4
    Last Post: 08-08-2011, 07:22 PM
  3. Mysql / metasploit error
    By zimsabre in forum Beginners Forum
    Replies: 3
    Last Post: 08-05-2010, 11:37 AM
  4. anybody try to customise BT4?update mysql error, help
    By secowu in forum Beginners Forum
    Replies: 0
    Last Post: 04-02-2010, 11:29 PM
  5. Metasploit = mysql pen test
    By edges in forum OLD Newbie Area
    Replies: 5
    Last Post: 06-10-2008, 10:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •