Results 1 to 4 of 4

Thread: Can't bind rfcomm0

  1. #1
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    1

    Default Can't bind rfcomm0

    Hi erverybody

    I want to connect via bluetooth to my handy.
    my /etc/bluetooth/rfcomm.conf is configured:
    Code:
    #
    # RFCOMM configuration file.
    #
    
    rfcomm0 {
    #	# Automatically bind the device at startup
    	bind yes;
    #
    #	# Bluetooth address of the device
    	device 00:18:13:4C:4A:0E;
    #
    #	# RFCOMM channel for the connection
    	channel	2;
    
    #	# Description of the connection
    	comment "w810i";
    }
    now i try to bind:
    Code:
    root@bt:~# rfcomm bind /dev/rfcomm0
    syntax error line 1
    Can't find a config entry for rfcomm0
    root@bt:~#
    What is wrong?

  2. #2
    Just burned his ISO BeNeDeLuX's Avatar
    Join Date
    Jan 2010
    Posts
    17

    Default Re: Can't bind rfcomm0

    Have more or less the same problem. Bluetooth itself looks fine but i cant bind my BT-GPS.

    USB-Bluetooth stick is there and usable:
    Code:
    # hciconfig -a
    hci0:   Type: BR/EDR  Bus: USB
            BD Address: 00:19:C1:EC:82:F9  ACL MTU: 310:10  SCO MTU: 64:8
            UP RUNNING PSCAN
            RX bytes:3514 acl:0 sco:0 events:103 errors:0
            TX bytes:621 acl:0 sco:0 commands:67 errors:0
            Features: 0xff 0xff 0x8f 0xfe 0x9b 0xf9 0x00 0x80
            Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
            Link policy: RSWITCH HOLD SNIFF PARK
            Link mode: SLAVE ACCEPT
            Name: 'root-0'
            Class: 0x100100
            Service Classes: Object Transfer
            Device Class: Computer, Uncategorized
            HCI Version: 2.0 (0x3)  Revision: 0xc5c
            LMP Version: 2.0 (0x3)  Subversion: 0xc5c
            Manufacturer: Cambridge Silicon Radio (10)
    #
    Is correct setup and i can find my BT-GPS...
    Code:
    # hciconfig hci0 up
    # hcitool scan
    Scanning ...
            00:08:1B:89:98:2C       BT GPS
    root@root:/# hcitool info 00:08:1B:89:98:2C
    Requesting information ...
            BD Address:  00:08:1B:89:98:2C
            Device Name: BT GPS
            LMP Version: 1.1 (0x1) LMP Subversion: 0x2c2
            Manufacturer: Cambridge Silicon Radio (10)
            Features: 0xff 0xff 0x0f 0x00 0x00 0x00 0x00 0x00
                    <3-slot packets> <5-slot packets> <encryption> <slot offset>
                    <timing accuracy> <role switch> <hold mode> <sniff mode>
                    <park state> <RSSI> <channel quality> <SCO link> <HV2 packets>
                    <HV3 packets> <u-law log> <A-law log> <CVSD> <paging scheme>
                    <power control> <transparent SCO>
    So i created the rfcomm.conf:
    Code:
    # cat /etc/bluetooth/rfcomm.conf
    #
    # RFCOMM configuration file.
    #
    
    rfcomm0 {
    #       # Automatically bind the device at startup
            bind yes;
    #
    #       # Bluetooth address of the device
            device 00:08:1B:89:98:2C;
    #
    #       # RFCOMM channel for the connection
            channel 1;
    #
    #       # Description of the connection
            comment "GPS Device";
    #}
    But i´m unable to bind!
    Code:
    #rfcomm bind rfcomm0
    Can't open RFCOMM control socket: Protocol not supported
    Also a modprobe false.
    Code:
    # modprobe rfcomm
    FATAL: Module rfcomm not found.
    Bluetooth Manager under GNOME ends also in a "Input/output error".

    I use BT5 R1. BT5 Final was ok for me with bluetooth.
    Or is there another way now in the R1 version ? Searched around the forum and have seen other threads with bluetooth problems. But they are not solved.
    Thanks for any help.

    Greez
    ASUS UL30A / BT5 x64 with KDE on HDD of course!

  3. #3
    Just burned his ISO BeNeDeLuX's Avatar
    Join Date
    Jan 2010
    Posts
    17

    Default Re: Can't bind rfcomm0

    Seems to me that the rfcomm modules are not compiled with(in) that kernel ?
    Code:
    # lsmod | grep blue
    bluetooth              78085  5 btusb
    rfkill                 14987  6 bluetooth,cfg80211,eeepc_laptop
    #
    Also the /dev/rfcomm* are missing.
    Code:
    # ls /dev/rf*
    /dev/rfkill
    #
    Of course i can add them with mknod but this would help in that case...


    // EDIT
    Ok there is already a Bug Ticket open --> http://redmine.backtrack-linux.org:8080/issues/269
    Sorry. May i have to look at it first...
    Last edited by BeNeDeLuX; 01-12-2012 at 06:05 AM.
    ASUS UL30A / BT5 x64 with KDE on HDD of course!

  4. #4
    Just burned his ISO
    Join Date
    Feb 2011
    Posts
    5

    Default Re: Can't bind rfcomm0

    I am having the same exact problem. It doesn't look like any progress has been made on the ticket... has anyone found a solution?

Similar Threads

  1. Bluetooth - /dev/rfcomm0 Error !!
    By Deejay in forum Beginners Forum
    Replies: 0
    Last Post: 07-24-2010, 09:22 PM
  2. ms06_025_rras Will Not Bind - help
    By mikeody in forum OLD Newbie Area
    Replies: 3
    Last Post: 03-07-2010, 03:07 AM
  3. Bluebugger - /dev/rfcomm0 error
    By imported_NjoyAP in forum OLD Newbie Area
    Replies: 6
    Last Post: 01-31-2009, 07:15 AM
  4. Bind Aircrack-ng 0.9.1 into iso
    By hankwank in forum OLD Newbie Area
    Replies: 1
    Last Post: 07-07-2007, 07:13 PM
  5. Replies: 0
    Last Post: 06-02-2007, 10:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •