Upon popular request, (and SEVERAL PM's) by my fans here at remote-exploit.org...heres another super E-Z tutorial on "How to connect to your WPA Personal with AES".

This is very similar to my other tutorials about other WI-FI WPA/WPA2 encryptions. Once again, I'll keep it simple.


In airodump-ng my network shows up as......

BSSID ........................PWR.........RXQ......Beaco ns...#Data,........#/s...CH..MB...ENC...... CIPHER...AUTH..............ESSID
00:18:F8:B5:F2: D6....68.............100.........766...........39. ........0......6....48. WPA....... CCMP......PSK.........Xploitz Network


First off....copy and paste the following, in blue, to your wpa_supplicant.conf located in your /etc directory. The actual wpa_supplicant.conf text will be at the bottom of the /etc directory.

ctrl_interface=/var/run/wpa_supplicant
network={
ssid="Xploitz Network"
key_mgmt=WPA-PSK
proto=WPA
pairwise=CCMP TKIP
group=CCMP TKIP
psk="-=Xploitz=-"
priority=3
}



Now, replace my ssid="Xploitz Network" with the name of your network....and replace my psk="-=Xploitz=-" with your Passphrase. (There is no reason to put -=Xploitz=- in hexadecimal because wpa supplicant parses it for you. So just put your passphrase in ASCII and all will be well.)

Now save this.

And in the same directory there is a folder called dhcpc. Go to it located in /etc/dhcpc folder and DELETE EVERYTHING!


***EDIT***
ALSO PLEASE NOTE THAT WHEN YOU CHANGE ENCRYPTIONS OR CONNECT TO A NEW NETWORK, YOU WILL NEED TO DELETE EVERYTHING INSIDE THE /ETC/DHCPC FOLDER AGAIN TO BE ABLE TO CONNECT TO YOUR NEW NETWORK OR NEW NETWORKS NEW ENCRYPTION ***END EDIT***

Next, open a new shell window and type in....

bt ~ # chmod 755 /etc/wpa_supplicant.conf

Next, type in....

bt ~ # wpa_supplicant -w -Dwext -iath0 -c/etc/wpa_supplicant.conf

(Please note in the above command my device is -iath0, yours may be wlan0, eth0, eth1..etc. Please change it to match your device; (example>>> -ieth0, or -iwlan0) Now you will see something similar to....

bt ~ # wpa_supplicant -w -Dwext -iath0 -c/etc/wpa_supplicant.conf
Trying to associate with 00:18:f8:b5:f2:d6 (SSID='Xploitz Network' freq=2437 MHz)
Associated with 00:18:f8:b5:f2:d6
WPA: Key negotiation completed with 00:18:f8:b5:f2:d6 [PTK=CCMP GTK=CCMP]
CTRL-EVENT-CONNECTED - Connection to 00:18:f8:b5:f2:d6 completed (auth) [id=0 id_str=]


And it will "Hang" here and stay. Why?? Simple. The command above will allow you to see all the "behind the scenes" action of connecting to your network, so you can troubleshoot it if need be. Now, our next command to execute....

Open a new shell and type....

dhcpcd ath0 (or whatever your device is)

Now you should see a "pop-up" somewhere on your screen saying "KDE Network Monitoring...Connection Established!"

Bingo! There ya go.

Also please note that once you get comfortable with my method..you may change....

bt ~ # wpa_supplicant -w -Dwext -iath0 -c/etc/wpa_supplicant.conf

to.....


bt ~ # wpa_supplicant -w -Dwext -iath0 -B -c/etc/wpa_supplicant.conf

This added -B option will run the program in the background for the deamon mode, and you'll IMMEDIATELY get an "return command line" ....

bt ~ #


so that you can put in dhcpcd ath0 (or whatever device you use like eth0, eth1, wlan0, etc...)

I hope this helps out a lot of people, because I have had SEVERAL PMs requesting how to accomplish this.

Please post your success / failures in this thread, and I will help you if you have any problems.

A special "Thanks" to all of my fans here for their support and eagerness to learn. Just my way of giving back to my love on the internet......remote-=Xploitz=-.org