Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Solution to sqlite Compile problems to allow use of Aircrack-ng 1 Dev r540 or above

  1. #1
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default Solution to sqlite Compile problems to allow use of Aircrack-ng 1 Dev r540 or above

    I HAVE NOW SOLVED THIS AND THE THREE SOLUTIONS ARE IN POSTS 5 AND 14



    This was posted in response to the news that as of r540 Aircrack-ng 1 Devel needs libsqlite >= 3.3.17 to compile.

    http://forums.remote-exploit.org/showthread.php?t=7291

    Quote Originally Posted by PrairieFire View Post
    r534
    WARNING: 1.0-dev needs libsqlite-dev >= 3.3.17 as of now, or it won't compile.
    http://sqlite.org/sqlite-3.4.0.tar.gz
    BT2:
    sqlite3 -version
    3.3.7

    Possible update procedure?
    curl -O http://www.sqlite.org/sqlite-3.4.0.tar.gz
    tar xvzf sqlite-3.4.0.tar.gz
    cd sqlite-3.4.0
    ./configure --prefix=/usr/local
    make && make install

    I have been trying to get this working for two days without any luck.
    Research on the SQLite website has not helped at all.
    Research on the Aircrack-ng website has only shown up that there is at least one other person getting the same results as me.

    So this is what I have tried so far

    Code:
     
     curl -O http://www.sqlite.org/sqlite-3.4.0.tar.gz
     tar xvzf sqlite-3.4.0.tar.gz
     cd sqlite-3.4.0
     ./configure --prefix=/usr/local
     make && make install
    AND

    Code:
     
     curl -O http://www.sqlite.org/sqlite-3.4.0.tar.gz
      tar xvzf sqlite-3.4.0.tar.gz
      cd sqlite-3.4.0
      ./configure
      make && make install
    AND

    Code:
     
     curl -O http://www.sqlite.org/sqlite-3.4.0.tar.gz
      tar xvzf sqlite-3.4.0.tar.gz
      cd sqlite-3.4.0
      ./configure --prefix=/usr/local
      make
     make install
    AND

    Code:
     
     curl -O http://www.sqlite.org/sqlite-3.4.0.tar.gz
      tar xvzf sqlite-3.4.0.tar.gz
      cd sqlite-3.4.0
      ./configure
      make
     make install
    And I tried these just in case it was a problem with sqlite-3.4.0.tar.gz

    Code:
     cvs -d :pserver:anonymous@www.sqlite.org:/sqlite login
     anonymous
     cvs -d :pserver:anonymous@www.sqlite.org:/sqlite checkout sqlite 
    ./configure --prefix=/usr/local
      make && make install
    AND

    Code:
     cvs -d :pserver:anonymous@www.sqlite.org:/sqlite login
     anonymous
     cvs -d :pserver:anonymous@www.sqlite.org:/sqlite checkout sqlite 
    ./configure
       make && make install
    AND

    Code:
     cvs -d :pserver:anonymous@www.sqlite.org:/sqlite login
     anonymous
     cvs -d :pserver:anonymous@www.sqlite.org:/sqlite checkout sqlite 
    ./configure --prefix=/usr/local
       make
     make install
    AND

    Code:
      cvs -d :pserver:anonymous@www.sqlite.org:/sqlite login
      anonymous
      cvs -d :pserver:anonymous@www.sqlite.org:/sqlite checkout sqlite 
    ./configure
        make
     make install
    All of the above have also been tried with

    Code:
    make clean
    as a substitute for the make command

    And EVERY time I am getting the same problem at the
    Code:
    make install
    Code:
     make: Nothing to be done for `all'.
     tclsh ./tclinstaller.tcl 3.4
     make: tclsh: Command not found
     make: *** [tcl_install] Error 127
    All of this has been done on BT2 Final, CD Boot so as there are no other modules to confuse the diagnosis of the problem.
    I have also used checkinstall too so as I can create a module for everyone who like me needs to be able to use aircrack-ng dev 1 r540 or above.

    Ok so HELP !!! Please

    I am not totally happy about where I have put this thread, but as it applies to development releases of programs covering specialist topics I finally decided after much debate, to put it here.
    If an Admin or Mod think it should be elsewhere then please move it and accept my apologies.

  2. #2
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    idem no way to update my version

    if i find a solution ill posted here...
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  3. #3
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Thank you for confirming its not just me and for your help. I was beginning to think it was something I was doing wrong

    I THINK I have got it fixed

    just got to test and if it works I will write up a small TUT and with a bit of luck post a module for everyone.

    Here goes nothing

    Fingers Crossed

  4. #4
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    IT WORKS !! 2 1/2 days of banging my head and pulling out even more feathers and IT WORKS !!

    just created a sqlite-3.4.0.lzm module rebooted and updated to aircrack-ng 1.0 r547

    Just got to do a little testing to make sure, sort out writing a TUT and upload the file somewhere for everyone.

    So just a little more patience... please

  5. #5
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Ok so here it is........

    I have no intention of writing a long explanation to what turns out to be a simple problem.

    The problem is that the makefile for sqlite references a needed file, but it gets the reference wrong.

    So the procedure to fix this is thus:

    Code:
    curl -O http://www.sqlite.org/sqlite-3.4.0.tar.gz
    tar xvzf sqlite-3.4.0.tar.gz
    cd sqlite-3.4.0
    ./configure --prefix=/usr/local
    make
    and at this point we need to edit the makefile

    At the bottom of the original makefile you will find this:

    Code:
        $(INSTALL) -m 0644 sqlite3.pc $(DESTDIR)$(libdir)/pkgconfig; 
    
    tcl_install:    libtclsqlite3.la
        tclsh $(TOP)/tclinstaller.tcl $(VERSION)
    
    clean:    
        rm -f *.lo *.la *.o sqlite3$(TEXE) libsqlite3.la
    Which you need to edit to this:

    Code:
        $(INSTALL) -m 0644 sqlite3.pc $(DESTDIR)$(libdir)/pkgconfig; 
    
    tcl_install:    libtclsqlite3.la
        tclsh8.4 $(TOP)/tclinstaller.tcl $(VERSION)
    
    clean:    
        rm -f *.lo *.la *.o sqlite3$(TEXE) libsqlite3.la
    and thats it, you can continue as normal

    Code:
    make install
    Your done, finished and now you can continue to use aircrack-ng 1.0 r540 or above.

    Here is a partial screenshot of an update I did a couple of hours ago.



    And there you are, thats it, the sum total of 2 1/2 days of banging my head and pulling out most of the feathers I have left.


    So now to the ones who want to be lazy and would like a module of this...

    sqlite-3.4.0.lzm

    There you go now you can update to aircrack-ng 1.0 r540 or greater. That is until they decide to add some new requirement.

    Hope this helps someone.

    Good Luck

    Have phun.

  6. #6
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    your update application looks really slick ..... lol....

    yes thx again i may automated the install process and patched for the makefile into the update application itself.......

    well done..........
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  7. #7
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Quote Originally Posted by shamanvirtuel View Post
    your update application looks really slick ..... lol....

    yes thx again i may automated the install process and patched for the makefile into the update application itself.......

    well done..........
    Yes I thought the my application looked pretty slick too
    Hope you didn't mind, I thought it was the best way to show it worked.

    Thank you ....... It was quite a slog to work it out, but a fantastic feeling once it finally worked, that made it worth all the time and effort.

  8. #8
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    No pb with screenshots......i post some too......

    thx again for hard work
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  9. #9
    Senior Member PrairieFire's Avatar
    Join Date
    Apr 2007
    Posts
    705

    Default

    Thanks balding_parrot, I knew it had something to do with tch and even noticed while looking around bt2 folders kept calling it differently just did not know what exactly to change.
    Μολὼν λαβέ - Great spirits encounter heavy opposition from mediocre minds.

  10. #10
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    now im revision 550 nice job again..........

    i will add an option to update libsql with your lzm in AIR if you give me rights to do it......
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •