Results 1 to 5 of 5

Thread: Disabling switchable graphics

  1. #1
    Just burned his ISO
    Join Date
    Oct 2011
    Posts
    2

    Default Disabling switchable graphics

    hello all, im fairly new to the backtrack community (long friends with backtrack ) and i seem to have stumbled upon a problem lately.

    I received a laptop recently and it has switchable graphics.

    The laptop is: HP Pavilion dm4-1273ca

    and the gpus are: ATI Radeon HD 6370m, and an integrated Intel gpu (part of the core i5).


    My current build is a dual-boot system consisting of:

    - Windows 7 SP1 x64
    - Backtrack Linux 5 x64

    Now the problem is i don't want to enbale the ATI card, i want to use the integrated intel gpu. It saves more battery, and i could
    care less on how my desktop looks. I need it for pentesting and developing, not gaming lol!

    I tried disabling it using the KMS: vgaswitcheroo, but when i did the fans would go crazy and gnome would get snail-syndrome..
    Without vgaswitcheroo it wouldn't even startx, it would give me a black screen and it would just stall (I tried almost every keyboard shortcut to kill X or switch tty's, nothing worked. I had to manually hold the power button, so much for conserving ur HDD's life). I even had problems just booting BT5 (edited the grub boot menu, acpi=off, and it worked)!

    I didnt install any closed-source drivers for the ATI or intel graphics.. This all happened on a fresh install!

    I really need to get this working very soon for school and work. Im also fed up of reinstalling Linux (for the 1000th time) after testing and trying various "solutions" lol...

    Thanks for your time and any help would be appreciated,

  2. #2
    Just burned his ISO
    Join Date
    Oct 2011
    Location
    Maryland, USA
    Posts
    6

    Default Re: Disabling switchable graphics

    Quote Originally Posted by binaryphr3k View Post
    hello all, im fairly new to the backtrack community (long friends with backtrack ) and i seem to have stumbled upon a problem lately.

    I received a laptop recently and it has switchable graphics.

    The laptop is: HP Pavilion dm4-1273ca

    and the gpus are: ATI Radeon HD 6370m, and an integrated Intel gpu (part of the core i5).


    My current build is a dual-boot system consisting of:

    - Windows 7 SP1 x64
    - Backtrack Linux 5 x64

    Now the problem is i don't want to enbale the ATI card, i want to use the integrated intel gpu. It saves more battery, and i could
    care less on how my desktop looks. I need it for pentesting and developing, not gaming lol!

    I tried disabling it using the KMS: vgaswitcheroo, but when i did the fans would go crazy and gnome would get snail-syndrome..
    Without vgaswitcheroo it wouldn't even startx, it would give me a black screen and it would just stall (I tried almost every keyboard shortcut to kill X or switch tty's, nothing worked. I had to manually hold the power button, so much for conserving ur HDD's life). I even had problems just booting BT5 (edited the grub boot menu, acpi=off, and it worked)!

    I didnt install any closed-source drivers for the ATI or intel graphics.. This all happened on a fresh install!

    I really need to get this working very soon for school and work. Im also fed up of reinstalling Linux (for the 1000th time) after testing and trying various "solutions" lol...

    Thanks for your time and any help would be appreciated,

    Try disabling the ATI card in your bios.

  3. #3
    Just burned his ISO
    Join Date
    Oct 2011
    Posts
    2

    Default Re: Disabling switchable graphics

    Quote Originally Posted by panic View Post
    Try disabling the ATI card in your bios.
    Unfortunately i don't have A feature in the Bios that enables me to switch my card off, i already looked..

  4. #4
    Just burned his ISO
    Join Date
    Oct 2011
    Location
    Maryland, USA
    Posts
    6

    Default Re: Disabling switchable graphics

    hmmm.. that is strange a you would think you would be able to. have you tried updating your bios? maybe they added the feature in.

  5. #5
    Just burned his ISO
    Join Date
    Apr 2010
    Posts
    7

    Default Re: Disabling switchable graphics

    You have to update your BIOS! Thats simple. Download a Bios updater exe for windows at HP website for your HP laptop model And the option will appear in BIOS. You have to set graphics card mode to FIXED. I did it several days ago.

Similar Threads

  1. Replies: 12
    Last Post: 03-19-2013, 05:48 PM
  2. Ati switchable graphics help please
    By Opperkip in forum Beginners Forum
    Replies: 0
    Last Post: 11-25-2010, 02:51 PM
  3. Disabling Safebrowsing
    By purehate in forum OLD Misc Tools
    Replies: 0
    Last Post: 10-01-2009, 01:31 PM
  4. ATi / Radeon Graphics (newer chipsets - fixed my X1250 graphics)
    By jalind in forum OLD BT3beta Bugs and Fixes
    Replies: 23
    Last Post: 11-26-2008, 04:17 AM
  5. Error: disabling IRQ 7
    By BigMac in forum OLD Newbie Area
    Replies: 1
    Last Post: 06-30-2008, 02:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •