Results 1 to 3 of 3

Thread: Aptitude error when i try to install = ?

  1. #1
    Just burned his ISO
    Join Date
    Sep 2011
    Posts
    6

    Question Aptitude error when i try to install = ?

    Hello, I am relatively new at backtrack and Linux.
    Now I am having a problem, When I try to install something with aptitude, the shell show me this problem:
    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    The following partially installed packages will be configured:
      nvidia-current nvidia-glx-185 
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Writing extended state information... Done
    Setting up nvidia-current (195.36.24-0ubuntu1~10.04) ...
    Removing old nvidia-current-195.36.24 DKMS files...
    
    ------------------------------
    Deleting module version: 195.36.24
    completely from the DKMS tree.
    ------------------------------
    Done.
    Loading new nvidia-current-195.36.24 DKMS files...
    First Installation: checking all kernels...
    Building only for 2.6.39.4
    Building for architecture x86_64
    Building initial module for 2.6.39.4
    
    Error! Bad return status for module build on kernel: 2.6.39.4 (x86_64)
    Consult the make.log in the build directory
    /var/lib/dkms/nvidia-current/195.36.24/build/ for more information.
    dpkg: error processing nvidia-current (--configure):
     subprocess installed post-installation script returned error exit status 10
    dpkg: dependency problems prevent configuration of nvidia-glx-185:
     nvidia-glx-185 depends on nvidia-current; however:
      Package nvidia-current is not configured yet.
    dpkg: error processing nvidia-glx-185 (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
                              Processing triggers for python-gmenu ...
    Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
    Processing triggers for python-support ...
    Errors were encountered while processing:
     nvidia-current
     nvidia-glx-185
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install.  Trying to recover:
    Setting up nvidia-current (195.36.24-0ubuntu1~10.04) ...
    Removing old nvidia-current-195.36.24 DKMS files...
    
    ------------------------------
    Deleting module version: 195.36.24
    completely from the DKMS tree.
    ------------------------------
    Done.
    Loading new nvidia-current-195.36.24 DKMS files...
    First Installation: checking all kernels...
    Building only for 2.6.39.4
    Building for architecture x86_64
    Building initial module for 2.6.39.4
    
    Error! Bad return status for module build on kernel: 2.6.39.4 (x86_64)
    Consult the make.log in the build directory
    /var/lib/dkms/nvidia-current/195.36.24/build/ for more information.
    dpkg: error processing nvidia-current (--configure):
     subprocess installed post-installation script returned error exit status 10
    dpkg: dependency problems prevent configuration of nvidia-glx-185:
     nvidia-glx-185 depends on nvidia-current; however:
      Package nvidia-current is not configured yet.
    dpkg: error processing nvidia-glx-185 (--configure):
     dependency problems - leaving unconfigured
    Processing triggers for python-gmenu ...
    Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
    Processing triggers for python-support ...
    Errors were encountered while processing:
     nvidia-current
     nvidia-glx-185
    Reading package lists... Done             
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    I don't know how to fix this problem.
    Any idea?
    Sorry if I have any misspelling , I am from Argentina.
    Thanks to all the community!

  2. #2
    Just burned his ISO sasanet's Avatar
    Join Date
    Jun 2011
    Location
    EU
    Posts
    25

    Default Re: Aptitude error when i try to install = ?

    hi,
    why do you use aptitude?
    I've read somewhere it's better to use apt-get install instead since aptitude sometimes doesn't work with backtrack.(I don't know why)
    apt-get install work's fine on my copy of backtrack, had no problems so far!
    cheers!

  3. #3
    Just burned his ISO
    Join Date
    Sep 2011
    Posts
    6

    Default Respuesta: Re: Aptitude error when i try to install = ?

    Quote Originally Posted by sasanet View Post
    hi,
    why do you use aptitude?
    I've read somewhere it's better to use apt-get install instead since aptitude sometimes doesn't work with backtrack.(I don't know why)
    apt-get install work's fine on my copy of backtrack, had no problems so far!
    cheers!
    Hello, Thanks!
    I tried with apt-get and I had the same problem
    I don't undestand why

    Any other solution/idea?
    Bye!

Similar Threads

  1. Booting Error -USB Drive Install -Looping Error After First Boot
    By Spinez in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 06-08-2012, 04:04 PM
  2. Replies: 0
    Last Post: 02-19-2011, 11:38 AM
  3. sudo aptitude install rar unrar
    By cafemigao in forum OLD Newbie Area
    Replies: 2
    Last Post: 07-08-2009, 06:10 PM
  4. Install Gnome + Aptitude in BT3?
    By ESC201 in forum OLD BackTrack 3 Final
    Replies: 7
    Last Post: 12-14-2008, 06:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •