Results 1 to 9 of 9

Thread: Intel Corporation WiFi Link 5100 WiFi 802.11a/b/g/n (Intel 5100 - iwlagn)

  1. #1
    Moderator g0tmi1k's Avatar
    Join Date
    Feb 2010
    Posts
    1,771

    Default Intel Corporation WiFi Link 5100 WiFi 802.11a/b/g/n (Intel 5100 - iwlagn)

    OS: BackTrack 5 R1 KDE 64bit
    Make & Model: Intel 5100 WiFi 802.11a/b/g/n
    Chipset: Intel 5100
    Driver: iwlagn
    Injection: Yes (Out of the box: No)

    Injection Method Source:
    Code:
    apt-get update 
    apt-get upgrade 
    
    prepare-kernel-sources 
    cd /usr/src/linux 
    cp -rf include/generated/* include/linux/
    
    cd /tmp
    wget http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2011-03-14.tar.bz2
    tar -jxf compat*
    cd compat-wireless*
    
    wget http://patches.aircrack-ng.org/mac80211.compat08082009.wl_frag+ack_v1.patch
    patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch
    
    wget http://patches.aircrack-ng.org/channel-negative-one-maxim.patch
    patch ./net/wireless/chan.c channel-negative-one-maxim.patch
    
    ./scripts/driver-select iwlagn
    make
    make install
    make unload
    
    reboot
    Code:
    root@root:~# ifconfig wlan0
    wlan0     Link encap:Ethernet  HWaddr 00:16:ea:d6:64:xx  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    root@root:~# iwconfig wlan0
    wlan0     IEEE 802.11abgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              
    root@root:~# lspci | grep -i Network
    02:00.0 Network controller: Intel Corporation WiFi Link 5100
    root@root:~# ls -l /sys/class/net/wlan0/device/driver
    lrwxrwxrwx 1 root root 0 2011-10-15 12:59 /sys/class/net/wlan0/device/driver -> ../../../../bus/pci/drivers/iwlagn
    root@root:~# lsmod | grep -i iwlagn
    iwlagn                232477  0 
    mac80211              277511  1 iwlagn
    cfg80211              165732  2 iwlagn,mac80211
    root@root:~# airmon-ng 
    
    
    Interface    Chipset        Driver
    
    wlan0        Intel 5100    iwlagn - [phy0]
    
    root@root:~# airmon-ng start wlan0 13
    
    
    Found 2 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!
    
    PID    Name
    3387    dhclient3
    3586    dhclient3
    Process with PID 3586 (dhclient3) is running on interface wlan0
    
    
    Interface    Chipset        Driver
    
    wlan0        Intel 5100    iwlagn - [phy0]
                    (monitor mode enabled on mon0)
    
    root@root:~# aireplay-ng -9 mon0
    13:04:52  Trying broadcast probe requests...
    13:04:54  No Answer...
    13:04:54  Found 1 AP 
    
    13:04:54  Trying directed probe requests...
    13:04:54  00:19:5B:E7:52:xx - channel: 13 - 'SSID'
    13:05:00   0/30:   0%
    
    root@root:~#
    Code:
    root@bt:~# aireplay-ng -9 mon0
    17:21:31  Trying broadcast probe requests...
    17:21:32  Injection is working!
    17:21:33  Found 1 APs
    17:21:33  Trying directed probe requests...
    
    17:21:33  00:19:5B:E7:52:xx - channel: 13 - 'SSID'
    17:21:33  Ping (min/avg/max): 2.357ms/60.632ms/153.159ms Power: -75.15
    17:21:33  25/30: 83%
    
    root@bt:~#
    Last edited by g0tmi1k; 10-20-2011 at 03:44 PM. Reason: Added kernel sources
    Have you...g0tmi1k?

  2. #2
    Just burned his ISO
    Join Date
    Sep 2011
    Posts
    2

    Default Re: Intel Corporation WiFi Link 5100 WiFi 802.11a/b/g/n (Intel 5100 - iwlagn)

    can you help me? I occured an error "wlagn - [phy0]SIOCSIFFLAGS: Unknown error 132" when i use command "airmon-ng start wlan0"

  3. #3
    Just burned his ISO
    Join Date
    Jan 2012
    Posts
    4

    Default Re: Intel Corporation WiFi Link 5100 WiFi 802.11a/b/g/n (Intel 5100 - iwlagn)

    Quote Originally Posted by dovanson View Post
    can you help me? I occured an error "wlagn - [phy0]SIOCSIFFLAGS: Unknown error 132" when i use command "airmon-ng start wlan0"
    Hey, maybe your adapter is not wlan0

    do airmon-ng

    and check what the name of your interface is.

    then you want to do the airmon-ng start "name of your wireless lan adapter"

  4. #4
    Just burned his ISO
    Join Date
    Feb 2012
    Posts
    1

    Default Re: Intel Corporation WiFi Link 5100 WiFi 802.11a/b/g/n (Intel 5100 - iwlagn)

    Quote Originally Posted by g0tmi1k View Post
    OS: BackTrack 5 R1 KDE 64bit
    Make & Model: Intel 5100 WiFi 802.11a/b/g/n
    Chipset: Intel 5100
    Driver: iwlagn
    Injection: Yes (Out of the box: No)

    Injection Method Source:
    Code:
    apt-get update 
    apt-get upgrade 
    
    prepare-kernel-sources 
    cd /usr/src/linux 
    cp -rf include/generated/* include/linux/
    
    cd /tmp
    wget http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2011-03-14.tar.bz2
    tar -jxf compat*
    cd compat-wireless*
    
    wget http://patches.aircrack-ng.org/mac80211.compat08082009.wl_frag+ack_v1.patch
    patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch
    
    wget http://patches.aircrack-ng.org/channel-negative-one-maxim.patch
    patch ./net/wireless/chan.c channel-negative-one-maxim.patch
    
    ./scripts/driver-select iwlagn
    make
    make install
    make unload
    
    reboot
    Code:
    root@root:~# ifconfig wlan0
    wlan0     Link encap:Ethernet  HWaddr 00:16:ea:d6:64:xx  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    root@root:~# iwconfig wlan0
    wlan0     IEEE 802.11abgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              
    root@root:~# lspci | grep -i Network
    02:00.0 Network controller: Intel Corporation WiFi Link 5100
    root@root:~# ls -l /sys/class/net/wlan0/device/driver
    lrwxrwxrwx 1 root root 0 2011-10-15 12:59 /sys/class/net/wlan0/device/driver -> ../../../../bus/pci/drivers/iwlagn
    root@root:~# lsmod | grep -i iwlagn
    iwlagn                232477  0 
    mac80211              277511  1 iwlagn
    cfg80211              165732  2 iwlagn,mac80211
    root@root:~# airmon-ng 
    
    
    Interface    Chipset        Driver
    
    wlan0        Intel 5100    iwlagn - [phy0]
    
    root@root:~# airmon-ng start wlan0 13
    
    
    Found 2 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!
    
    PID    Name
    3387    dhclient3
    3586    dhclient3
    Process with PID 3586 (dhclient3) is running on interface wlan0
    
    
    Interface    Chipset        Driver
    
    wlan0        Intel 5100    iwlagn - [phy0]
                    (monitor mode enabled on mon0)
    
    root@root:~# aireplay-ng -9 mon0
    13:04:52  Trying broadcast probe requests...
    13:04:54  No Answer...
    13:04:54  Found 1 AP 
    
    13:04:54  Trying directed probe requests...
    13:04:54  00:19:5B:E7:52:xx - channel: 13 - 'SSID'
    13:05:00   0/30:   0%
    
    root@root:~#
    Code:
    root@bt:~# aireplay-ng -9 mon0
    17:21:31  Trying broadcast probe requests...
    17:21:32  Injection is working!
    17:21:33  Found 1 APs
    17:21:33  Trying directed probe requests...
    
    17:21:33  00:19:5B:E7:52:xx - channel: 13 - 'SSID'
    17:21:33  Ping (min/avg/max): 2.357ms/60.632ms/153.159ms Power: -75.15
    17:21:33  25/30: 83%
    
    root@bt:~#
    how about this ?

    CC [M] /tmp/compat-wireless-2011-03-14/net/wireless/util.o
    /tmp/compat-wireless-2011-03-14/net/wireless/util.c: In function ‘cfg80211_change_iface’:
    /tmp/compat-wireless-2011-03-14/net/wireless/util.c:799: error: implicit declaration of function ‘br_port_exists’
    make[3]: *** [/tmp/compat-wireless-2011-03-14/net/wireless/util.o] Error 1
    make[2]: *** [/tmp/compat-wireless-2011-03-14/net/wireless] Error 2
    make[1]: *** [_module_/tmp/compat-wireless-2011-03-14] Error 2
    make[1]: Leaving directory `/usr/src/linux-source-2.6.39.4'
    make: *** [modules] Error 2


    AND


    CC [M] /tmp/compat-wireless-2011-03-14/net/wireless/util.o
    /tmp/compat-wireless-2011-03-14/net/wireless/util.c: In function ‘cfg80211_change_iface’:
    /tmp/compat-wireless-2011-03-14/net/wireless/util.c:799: error: implicit declaration of function ‘br_port_exists’
    make[3]: *** [/tmp/compat-wireless-2011-03-14/net/wireless/util.o] Error 1
    make[2]: *** [/tmp/compat-wireless-2011-03-14/net/wireless] Error 2
    make[1]: *** [_module_/tmp/compat-wireless-2011-03-14] Error 2
    make[1]: Leaving directory `/usr/src/linux-source-2.6.39.4'
    make: *** [modules] Error 2

    PLEASE HELP ME

  5. #5
    Just burned his ISO
    Join Date
    Feb 2012
    Posts
    1

    Default Re: Intel Corporation WiFi Link 5100 WiFi 802.11a/b/g/n (Intel 5100 - iwlagn)

    Can someone help me figure out how to do this, but with VmWare? I am a noob, sorry -- I have been trying to figure this out every day for a week now.

  6. #6
    Junior Member
    Join Date
    Dec 2011
    Posts
    30

    Default Riferimento: Intel Corporation WiFi Link 5100 WiFi 802.11a/b/g/n (Intel 5100 - iwlagn

    in vmware you can't use internal wifi cards!

  7. #7
    Just burned his ISO
    Join Date
    Mar 2012
    Posts
    1

    Default Re: Intel Corporation WiFi Link 5100 WiFi 802.11a/b/g/n (Intel 5100 - iwlagn)

    Quote Originally Posted by xchpsx View Post
    how about this ?

    CC [M] /tmp/compat-wireless-2011-03-14/net/wireless/util.o
    /tmp/compat-wireless-2011-03-14/net/wireless/util.c: In function ‘cfg80211_change_iface’:
    /tmp/compat-wireless-2011-03-14/net/wireless/util.c:799: error: implicit declaration of function ‘br_port_exists’
    make[3]: *** [/tmp/compat-wireless-2011-03-14/net/wireless/util.o] Error 1
    make[2]: *** [/tmp/compat-wireless-2011-03-14/net/wireless] Error 2
    make[1]: *** [_module_/tmp/compat-wireless-2011-03-14] Error 2
    make[1]: Leaving directory `/usr/src/linux-source-2.6.39.4'
    make: *** [modules] Error 2


    AND


    CC [M] /tmp/compat-wireless-2011-03-14/net/wireless/util.o
    /tmp/compat-wireless-2011-03-14/net/wireless/util.c: In function ‘cfg80211_change_iface’:
    /tmp/compat-wireless-2011-03-14/net/wireless/util.c:799: error: implicit declaration of function ‘br_port_exists’
    make[3]: *** [/tmp/compat-wireless-2011-03-14/net/wireless/util.o] Error 1
    make[2]: *** [/tmp/compat-wireless-2011-03-14/net/wireless] Error 2
    make[1]: *** [_module_/tmp/compat-wireless-2011-03-14] Error 2
    make[1]: Leaving directory `/usr/src/linux-source-2.6.39.4'
    make: *** [modules] Error 2

    PLEASE HELP ME
    I also encountered this error.
    I tried different versions of the drive but nothing changes.
    someone has solved?

  8. #8
    Just burned his ISO
    Join Date
    Mar 2012
    Posts
    1

    Default Re: Riferimento: Intel Corporation WiFi Link 5100 WiFi 802.11a/b/g/n (Intel 5100 - iw

    Hi!

    And what if I'm trying to use a USB bootable backtrack? Can I edit it in order to have de driver modified every time I use it?

    I'm using BT5 R2 (I don't know if it has already got the correct driver). And I have 1 general doubt: When I run Gerix, and try the inyection test, It tells me that inyection is running. But it doesn't seem to work, as it does not get any improvement in the performance of the rest of the "things" you do.

    I'm not very used to linux...

    Thanks in advance!

  9. #9
    Just burned his ISO
    Join Date
    Apr 2012
    Posts
    1

    Question Help

    I have an intel WiFi link 5100 AGN and i doesn't work with packet injection. I boot from a usb on Gnome 32bit backtrack 5r2.

    How do I exactly make it work. I don't really know what to do with these codes. Where do i put them?

Similar Threads

  1. Need help with Intel Wifi Link 5100 AGN
    By YellowSnow in forum OLD Newbie Area
    Replies: 6
    Last Post: 11-01-2009, 03:16 PM
  2. Backtrack 4 and the Intel WiFi Link 5100 (Wifi 802.11n)
    By Magic-Micky in forum OLD Newbie Area
    Replies: 3
    Last Post: 02-27-2009, 08:34 PM
  3. Intel WiFi Link 5100
    By got_milk? in forum OLD BT4beta Working Hardware
    Replies: 16
    Last Post: 02-22-2009, 05:31 PM
  4. Intel(R) wifi link 5100 on bt3
    By miox_24 in forum OLD BT3final Support
    Replies: 2
    Last Post: 02-20-2009, 06:08 AM
  5. intel wifi link 5100 agn
    By binded in forum OLD BackTrack 3 Final
    Replies: 6
    Last Post: 11-09-2008, 11:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •