Results 1 to 4 of 4

Thread: USB Wifi not working in VMWare (BackTrack5)

  1. #1
    Just burned his ISO
    Join Date
    Oct 2011
    Posts
    1

    Default USB Wifi not working in VMWare (BackTrack5)

    Okay I am a 100% (complete) newb when it comes to anything linux. I hope that you guys (and girls) can help with this problem I'm having. I have VMWare that I am using to run BackTrack5. I'm trying to use my wifi adapter (USB NETGEAR WNDA3100 V2) to connect, but when i use the command iwconfig it stays "no wireless extensions." On my actual machine I'm running Windows 7, and I checked to make sure the USB is on (in the settings) and the network is on also (in the settings). Please tell me how I can get this thing to work.

  2. #2
    Senior Member ShadowMaster's Avatar
    Join Date
    Jul 2011
    Location
    /root
    Posts
    189

    Default Re: USB Wifi not working in VMWare (BackTrack5)

    Did you click the little thingy on the bottom to connect it to the guest OS? I've been perusing the forums and a lot of people seem to be making that mistake.
    World Domination is such an ugly phrase. I prefer the term World Optimization.

  3. #3
    Just burned his ISO
    Join Date
    Mar 2011
    Posts
    5

    Default Re: USB Wifi not working in VMWare (BackTrack5)

    i also having same prob i have wireless usb modem i can connect it on win 7 and also able to use in backtrack using bridge connection using vmware but can't able to use in only backtrack any idea?

  4. #4
    Just burned his ISO
    Join Date
    Oct 2011
    Location
    San Diego, CA
    Posts
    21

    Default Re: USB Wifi not working in VMWare (BackTrack5)

    A quick search of your wireless adapter along with backtrack brought me to this post. Use that link if you're still having trouble with the adapter after following these steps (taken from the first page of the post I linking you to).

    The following devices with the atheros AR9170 chipset need the drivers updated to work correctly with BT4:
    Arcadyan - WN7512
    Atheros - 9170
    Atheros - TG121N
    AVM - FRITZ!WLAN USB Stick N
    AMV - FRITZ!WLAN USB Stick N 2.4
    Cace - Airpcap NX
    D-Link - DWA 160A1
    D-Link - DWA 160A2
    IO-Data - WNGDNUS2
    Netgear - WNDA3100
    Netgear - WN111 v2
    Planex - GWUS300
    Sphairon - Homelink 1202
    TP-Link - TL-WN821N v2
    Z-Com - UB81 BG
    Z-Com - UB82 ABG
    Zydas - ZD1221
    Zyxel - NWD271N
    ----
    Here is how to update the drivers:

    Download ar9170.fw, ar9170-1.fw, ar9170-2.fw and put them into /lib/firmware

    Download compat-wireless-2.6.32.3.tar.bz2

    Open a terminal and run:

    Code:
    tar -xf /root/compat-wireless-2.6.32.3.tar.bz2
    cd compat-wireless-2.6.32.3
    make
    make install
    make unload
    *If you get a "No such file or directory" error when you run make, run this command:

    Code:
    ln -s /usr/src/linux /lib/modules/2.6.30.9/build
    Open /etc/modprobe.d/blacklist with any text editor and add blacklist arusb_lnx to the list and save the file.

    then:

    Code:
    reboot
    In the future can you please either search these forums or use google before posting a thread, chances are that your problem has already been solved I don't mean to come off as an asshole but I'm just trying to give you some advice. Let me know if you're still having trouble with the adapter because it could also be a problem with VMWare.

Similar Threads

  1. wireless not working on vmware
    By storm1990 in forum BackTrack 5 Beginners Section
    Replies: 5
    Last Post: 05-13-2011, 04:32 AM
  2. USB Wifi not working
    By soto3330 in forum Beginners Forum
    Replies: 6
    Last Post: 06-20-2010, 07:18 AM
  3. Cant get wireless card working in VmWare
    By lokilindo in forum OLD Newbie Area
    Replies: 1
    Last Post: 01-04-2010, 04:30 AM
  4. Not sure if my WiFi is working...
    By Sunnz in forum OLD Newbie Area
    Replies: 4
    Last Post: 11-27-2008, 06:05 AM
  5. VMware + USBwlan adapter = working?
    By Unimatrix in forum OLD Newbie Area
    Replies: 2
    Last Post: 09-20-2008, 05:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •