Results 1 to 6 of 6

Thread: sqlmap update error

Hybrid View

  1. #1
    Just burned his ISO akast's Avatar
    Join Date
    Jan 2011
    Location
    广州
    Posts
    3

    Question sqlmap update error

    Code:
    Traceback (most recent call last):
      File "./sqlmap.py", line 17, in <module>
        from _sqlmap import main
      File "/pentest/database/sqlmap/_sqlmap.py", line 27, in <module>
        from lib.controller.controller import start
      File "/pentest/database/sqlmap/lib/controller/controller.py", line 13, in <module>
        from lib.controller.action import action
      File "/pentest/database/sqlmap/lib/controller/action.py", line 10, in <module>
        from lib.controller.handler import setHandler
      File "/pentest/database/sqlmap/lib/controller/handler.py", line 27, in <module>
        from plugins.dbms.mssqlserver import MSSQLServerMap
      File "/pentest/database/sqlmap/plugins/dbms/mssqlserver/__init__.py", line 14, in <module>
        from plugins.dbms.mssqlserver.enumeration import Enumeration
      File "/pentest/database/sqlmap/plugins/dbms/mssqlserver/enumeration.py", line 28, in <module>
        from plugins.generic.enumeration import Enumeration as GenericEnumeration
      File "/pentest/database/sqlmap/plugins/generic/enumeration.py", line 16, in <module>
        from lib.core.common import BigArray
    ImportError: cannot import name BigArray
    root@bt:/pentest/database/sqlmap#

  2. #2
    Just burned his ISO
    Join Date
    Jun 2010
    Posts
    5

    Default Re: sqlmap update error

    same problem. anybody know?

  3. #3
    Senior Member
    Join Date
    Jul 2011
    Posts
    236

    Default Re: sqlmap update error

    akast,

    I haven't seen that specific error with my distro of BT, but I think I might have the answer for you. The default copy of sqlmap that comes with BT5r1 has an "improper" svn listing. Grab yerself a copy of my update script and let me know if it works for ya...

    svn checkout http://backtrack-update.googlecode.com/svn/trunk/ backtrack-update

    Cheers!
    V/r,
    Snafu
    Pffbt..[quote]I made a discovery today. I found a computer. Wait a second, this is cool. It does what I want it to. If it makes a mistake, it's because I screwed it up. Not because it doesn't like me... Or feels threatened by me.. Or thinks I'm a smart ass.. [/quote]

  4. #4
    Just burned his ISO
    Join Date
    Nov 2011
    Posts
    1

    Default Re: sqlmap update error

    I get this error too.
    If you're just trying to run it, take a look at the documentation and get your commands from there.
    (hint: /pentest/database/sqlmap/doc)

  5. #5
    Just burned his ISO
    Join Date
    Apr 2012
    Posts
    6

    Default Re: sqlmap update error

    I'm running bt5r2 now so I'm not sure it's appropriate to post this here, but the problem seems to be extremely similar.

    I tried updating sqlmap and experienced failure and now the program won't even run. I removed it, reinstalled sqlmap from the file provided by the sqlmap project on source forge. Unfortunately this did not solve my problems.

    Code:
    root@bt:~/sqlmap# ./sqlmap.py --update
    
        sqlmap/0.9 - automatic SQL injection and database takeover tool
        http://sqlmap.sourceforge.net
    [*] starting at: 14:08:37
    
    [14:08:37] [INFO] updating sqlmap to latest development version from the subversion repository
    D	/root/sqlmap/txt/oracle-default-passwords.txt
    A	/root/sqlmap/txt/smalldict.txt
    A	/root/sqlmap/plugins/dbms/db2
    A	/root/sqlmap/plugins/dbms/db2/connector.py
    A	/root/sqlmap/plugins/dbms/db2/__init__.py
    A	/root/sqlmap/plugins/dbms/db2/takeover.py
    A	/root/sqlmap/plugins/dbms/db2/filesystem.py
    A	/root/sqlmap/plugins/dbms/db2/enumeration.py
    A	/root/sqlmap/plugins/dbms/db2/syntax.py
    A	/root/sqlmap/plugins/dbms/db2/fingerprint.py
    A	/root/sqlmap/_sqlmap.py
    D	/root/sqlmap/extra/xmlobject
    A	/root/sqlmap/extra/socks
    A	/root/sqlmap/extra/socks/LICENSE
    A	/root/sqlmap/extra/socks/__init__.py
    A	/root/sqlmap/extra/socks/socks.py
    A	/root/sqlmap/extra/beautifulsoup
    A	/root/sqlmap/extra/beautifulsoup/__init__.py
    A	/root/sqlmap/extra/beautifulsoup/beautifulsoup.py
    A	/root/sqlmap/extra/safe2bin
    A	/root/sqlmap/extra/safe2bin/safe2bin.py
    A	/root/sqlmap/extra/safe2bin/__init__.py
    A	/root/sqlmap/extra/safe2bin/README.txt
    A	/root/sqlmap/extra/shellcodeexec
    A	/root/sqlmap/extra/shellcodeexec/linux
    A	/root/sqlmap/extra/shellcodeexec/linux/shellcodeexec.x32
    A	/root/sqlmap/extra/shellcodeexec/linux/shellcodeexec.x64
    A	/root/sqlmap/extra/shellcodeexec/linux/shellcodeexec.c
    A	/root/sqlmap/extra/shellcodeexec/linux/Makefile
    A	/root/sqlmap/extra/shellcodeexec/windows
    A	/root/sqlmap/extra/shellcodeexec/windows/shellcodeexec.sln
    A	/root/sqlmap/extra/shellcodeexec/windows/shellcodeexec.x32.exe
    A	/root/sqlmap/extra/shellcodeexec/windows/shellcodeexec
    A	/root/sqlmap/extra/shellcodeexec/windows/shellcodeexec/shellcodeexec.c
    A	/root/sqlmap/extra/shellcodeexec/windows/shellcodeexec/shellcodeexec.vcproj
    A	/root/sqlmap/extra/shellcodeexec/windows/README
    A	/root/sqlmap/extra/shellcodeexec/README
    A	/root/sqlmap/extra/oset
    A	/root/sqlmap/extra/oset/LICENSE.txt
    A	/root/sqlmap/extra/oset/__init__.py
    A	/root/sqlmap/extra/oset/pyoset.py
    A	/root/sqlmap/extra/oset/_abc.py
    A	/root/sqlmap/extra/chardet
    A	/root/sqlmap/extra/chardet/langcyrillicmodel.py
    A	/root/sqlmap/extra/chardet/langhungarianmodel.py
    A	/root/sqlmap/extra/chardet/langhebrewmodel.py
    A	/root/sqlmap/extra/chardet/__init__.py
    A	/root/sqlmap/extra/chardet/big5prober.py
    A	/root/sqlmap/extra/chardet/latin1prober.py
    A	/root/sqlmap/extra/chardet/universaldetector.py
    A	/root/sqlmap/extra/chardet/jisfreq.py
    A	/root/sqlmap/extra/chardet/big5freq.py
    A	/root/sqlmap/extra/chardet/gb2312prober.py
    A	/root/sqlmap/extra/chardet/escsm.py
    A	/root/sqlmap/extra/chardet/chardistribution.py
    A	/root/sqlmap/extra/chardet/gb2312freq.py
    A	/root/sqlmap/extra/chardet/langgreekmodel.py
    A	/root/sqlmap/extra/chardet/charsetgroupprober.py
    A	/root/sqlmap/extra/chardet/mbcharsetprober.py
    A	/root/sqlmap/extra/chardet/escprober.py
    A	/root/sqlmap/extra/chardet/mbcssm.py
    A	/root/sqlmap/extra/chardet/hebrewprober.py
    A	/root/sqlmap/extra/chardet/sbcharsetprober.py
    A	/root/sqlmap/extra/chardet/codingstatemachine.py
    A	/root/sqlmap/extra/chardet/utf8prober.py
    A	/root/sqlmap/extra/chardet/euctwprober.py
    A	/root/sqlmap/extra/chardet/charsetprober.py
    A	/root/sqlmap/extra/chardet/euctwfreq.py
    A	/root/sqlmap/extra/chardet/jpcntx.py
    A	/root/sqlmap/extra/chardet/langthaimodel.py
    A	/root/sqlmap/extra/chardet/mbcsgroupprober.py
    A	/root/sqlmap/extra/chardet/constants.py
    A	/root/sqlmap/extra/chardet/test.py
    A	/root/sqlmap/extra/chardet/eucjpprober.py
    A	/root/sqlmap/extra/chardet/sbcsgroupprober.py
    A	/root/sqlmap/extra/chardet/sjisprober.py
    A	/root/sqlmap/extra/chardet/euckrprober.py
    A	/root/sqlmap/extra/chardet/langbulgarianmodel.py
    A	/root/sqlmap/extra/chardet/euckrfreq.py
    A	/root/sqlmap/doc/FAQ.pdf
    A	/root/sqlmap/doc/FAQ.html
    D	/root/sqlmap/lib/contrib
    D	/root/sqlmap/lib/takeover/upx.py
    A	/root/sqlmap/lib/utils/hashdb.py
    
    [14:10:19] [CRITICAL] unhandled exception in sqlmap/0.9, retry your run with the latest development version from the Subversion repository. If the exception persists, please send by e-mail to sqlmap-users@lists.sourceforge.net the following text and any information required to reproduce the bug. The developers will try to reproduce the bug, fix it accordingly and get back to you.
    sqlmap version: 0.9 (r3630)
    Python version: 2.6.5
    Operating system: posix
    Command line: ./sqlmap.py --update
    Technique: None
    Back-end DBMS: None (identified)
    Traceback (most recent call last):
      File "./sqlmap.py", line 74, in main
      File "/root/sqlmap/lib/core/option.py", line 1590, in init
        update()
      File "/root/sqlmap/lib/core/update.py", line 71, in update
        client.update(rootDir)
    ClientError: callback_get_login required
    [*] shutting down at: 14:10:19
    This is what I get when I try to run the update command. And this is what I get when I try to run sqlmap in general.

    Code:
    root@bt:~/sqlmap# ./sqlmap.py --help  
    Traceback (most recent call last):
      File "./sqlmap.py", line 17, in <module>
        from _sqlmap import main
      File "/root/sqlmap/_sqlmap.py", line 26, in <module>
        from lib.controller.controller import start
      File "/root/sqlmap/lib/controller/controller.py", line 12, in <module>
        from lib.controller.action import action
      File "/root/sqlmap/lib/controller/action.py", line 10, in <module>
        from lib.controller.handler import setHandler
      File "/root/sqlmap/lib/controller/handler.py", line 27, in <module>
        from plugins.dbms.mssqlserver import MSSQLServerMap
      File "/root/sqlmap/plugins/dbms/mssqlserver/__init__.py", line 13, in <module>
        from plugins.dbms.mssqlserver.enumeration import Enumeration
      File "/root/sqlmap/plugins/dbms/mssqlserver/enumeration.py", line 13, in <module>
        from lib.core.common import getLimitRange
    ImportError: cannot import name getLimitRange
    Please help me get my sqlmap back.

  6. #6
    Just burned his ISO
    Join Date
    Apr 2012
    Posts
    6

    Default Re: sqlmap update error

    Hey I finally got some free time and I was able to fix my sqlmap myself.
    Apparently removing the old directory, and doing a clean svn checkout will solve the problem

    Code:
      rm -rf sqlmap
      svn checkout https://svn.sqlmap.org/sqlmap/trunk/sqlmap sqlmap-dev
    So, far my sqlmap seems fully functional again.

Similar Threads

  1. SQLmap - UNION Injectable - error | help?
    By Eatme in forum BackTrack 5 General Topics
    Replies: 5
    Last Post: 09-12-2011, 01:35 AM
  2. BT5 Updating Sqlmap - authentication error
    By Quartercask in forum BackTrack 5 Beginners Section
    Replies: 4
    Last Post: 08-16-2011, 08:05 PM
  3. apt-get update error
    By xplode in forum BackTrack Bugs
    Replies: 1
    Last Post: 12-21-2010, 06:44 PM
  4. update error
    By munitech4u in forum OLD BackTrack 4 General Support
    Replies: 3
    Last Post: 10-18-2009, 04:06 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •