Results 1 to 6 of 6

Thread: damn conexant chip!

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    3

    Default damn conexant chip!

    Dear all, sorry for my bad english.
    I have a Fujitsu-Siemens Amilo D1845 laptop with this wireless card: Gemtek WL850FJx (Conexant)
    Chipset: Intersil Corporation ISL3886 Prism Javelin/Prism Xbow (rev 01)
    pciid: 1260:3886 (rev 01)
    I know I can use ndiswrapper to mount a widows driver once I have load a livedistro like ubuntu or knoppix but the problem is that Backtrack is not able to load at all. It crash with a kernel panic message when it try to install the wireless card. The message is very long with stack value etc. (I try to make a photo of the display but it is quite impossible)
    So my question is: is there a way to say at backtrack boot prompt to ignore the wireless installation?
    Ah! I cannot remove the wireless because it is integrate in the mainboard.
    Thanks

  2. #2
    Senior Member streaker69's Avatar
    Join Date
    Jan 2010
    Location
    Virginville, BlueBall, Bird In Hand, Intercourse, Paradise, PA
    Posts
    3,535

    Default

    Quote Originally Posted by morphic View Post
    Dear all, sorry for my bad english.
    I have a Fujitsu-Siemens Amilo D1845 laptop with this wireless card: Gemtek WL850FJx (Conexant)
    Chipset: Intersil Corporation ISL3886 Prism Javelin/Prism Xbow (rev 01)
    pciid: 1260:3886 (rev 01)
    I know I can use ndiswrapper to mount a widows driver once I have load a livedistro like ubuntu or knoppix but the problem is that Backtrack is not able to load at all. It crash with a kernel panic message when it try to install the wireless card. The message is very long with stack value etc. (I try to make a photo of the display but it is quite impossible)
    So my question is: is there a way to say at backtrack boot prompt to ignore the wireless installation?
    Ah! I cannot remove the wireless because it is integrate in the mainboard.
    Thanks
    Did you try going into the BIOS and disabling the Wireless card?
    A third party security audit is the IT equivalent of a colonoscopy. It's long, intrusive, very uncomfortable, and when it's done, you'll have seen things you really didn't want to see, and you'll never forget that you've had one.

  3. #3
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    disable it in the bios....or try

    boot: bt nohotplug disable almost all hardware autodetection in the case of hangups. Your hardware won't be detected at all, you'll have to use "pcimodules" command after logging into SLAX and you'll have to try to modprobe all needed modules from the list manually
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  4. #4
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    3

    Default

    Quote Originally Posted by shamanvirtuel View Post
    disable it in the bios....or try

    boot: bt nohotplug disable almost all hardware autodetection in the case of hangups. Your hardware won't be detected at all, you'll have to use "pcimodules" command after logging into SLAX and you'll have to try to modprobe all needed modules from the list manually
    I've tried the easy way (bios) but it seems no have options about wireless.
    The other solution sounds terrible for a linux newbie like me, but if I must put my lazy hands under the cap .... I'll try. If you can give me some hints about pcimodules and modprobe use ....... thanks

  5. #5
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    3

    Default kernel bug

    I have tried to understand better the error message. Here it is:

    Kernel bug at
    drivers/net/wireless/prism54/isl_388xx.c:232!

    invalid opcode : 0000 [#1]

    Modules linked in: "......... a long list of modules"
    CPU ........eax ...... all the register value .....
    stack image ...........
    kernel panic - notsyncing:fatal exception in interrupt

    so, I'm not a c programmer and I'm a linux newbie but with the option bt debug, can I say to the system: "please don't load/compile the isl_388xx.c driver"?
    Any idea are welcome ..... plz help me!

  6. #6
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Quote Originally Posted by morphic View Post
    Dear all, sorry for my bad english.
    I have a Fujitsu-Siemens Amilo D1845 laptop with this wireless card: Gemtek WL850FJx (Conexant)
    Chipset: Intersil Corporation ISL3886 Prism Javelin/Prism Xbow (rev 01)
    pciid: 1260:3886 (rev 01)
    I know I can use ndiswrapper to mount a widows driver once I have load a livedistro like ubuntu or knoppix but the problem is that Backtrack is not able to load at all.
    This is the same chipset as is used in the 3COM 3CRWE154G72 v1 which uses the prism54 driver so should it not be able to just use the built in prism54 drivers ? Forgive me if I am wrong on this, its just that I am pretty sure I recognise the chipset as being the same as my 3com card above.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •