Results 1 to 3 of 3

Thread: How to switch to MONITOR MODE? ( Wireless card BroadCom43227)

  1. #1
    Just burned his ISO
    Join Date
    Oct 2011
    Posts
    7

    Question How to switch to MONITOR MODE? ( Wireless card BroadCom43227)

    My wireless card finally work but i cant switch it to MONITOR MODE so i cant use airodump
    Driver are probably ok because i can connect to wifi without problem.


    ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr b8:70:f4:e6:60:38  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:16 
    
    eth1      Link encap:Ethernet  HWaddr cc:af:78:2b:be:02  
              inet addr:192.168.0.102  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::ceaf:78ff:fe2b:be02/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:7328 errors:0 dropped:0 overruns:0 frame:1426
              TX packets:5710 errors:23 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:8362166 (8.3 MB)  TX bytes:906079 (906.0 KB)
              Interrupt:17 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:91 errors:0 dropped:0 overruns:0 frame:0
              TX packets:91 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:6257 (6.2 KB)  TX bytes:6257 (6.2 KB)
    iwconfig
    Code:
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      IEEE 802.11bgn  ESSID:"dlink"  
              Mode:Managed  Frequency:2.427 GHz  Access Point: 1C:AF:F7:A8:FC:C0   
              Bit Rate=48 Mb/s   Tx-Power:24 dBm   
              Retry min limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Managementmode:All packets received
              Link Quality=5/5  Signal level=-15 dBm  Noise level=-86 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    airmon-ng
    Code:
    Interface	Chipset		Driver
    
    eth1		Broadcom		wl
    airmon-ng start eth1
    Code:
    Found 2 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!
    
    PID	Name
    2432	wpa_supplicant
    2448	dhclient
    
    Process with PID 2432 (wpa_supplicant) is running on interface eth1
    
    
    
    Interface	Chipset		Driver
    
    eth1		Broadcom		wl (monitor mode enabled)
    wl (monitor mode enabled) even if there is MONITOR MODE ENABLED in iwconfig is still MANAGED

    airodump-ng eth1

    Code:
    ioctl(SIOCSIWMODE) failed: Invalid argument
    
    ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
    ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead.  Make
    sure RFMON is enabled: run 'airmon-ng start eth1 <#>'
    Sysfs injection support was not found either.
    From bunch of topics I read It's because it isn't switched to monitor mode.

    I'll be glad for any help

  2. #2
    Good friend of the forums scottm99's Avatar
    Join Date
    Feb 2010
    Location
    underwater
    Posts
    371

    Default Re: How to switch to MONITOR MODE? ( Wireless card BroadCom43227)

    Based on my past experience, the broadcom chipset was flaky. Sometimes it would do monitor mode, & sometimes not (don't recall the one I was using, unfortunately). Have you checked the BT wiki & the hardware compatibility list forum?
    If I could figure out how to scuba dive & hack at the same time, there would be nothing I couldn't do...

  3. #3
    Just burned his ISO sasanet's Avatar
    Join Date
    Jun 2011
    Location
    EU
    Posts
    25

    Default Re: How to switch to MONITOR MODE? ( Wireless card BroadCom43227)

    Hy
    login as root and do this...
    download latest compat-wireless drivers:
    Code:
    wget http://linuxwireless.org/download/compat-wireless-2.6/compat-wireless-2011-10-12.tar.bz2tar
    tar xvf compat-wireless-2011-10-12.tar.bz2tar
    cd into extracted directory then run:
    Code:
    make && make install
    reboot and if it works

Similar Threads

  1. Airmon-ng not showing monitor mode on my wireless card
    By dreambig2212 in forum Beginners Forum
    Replies: 5
    Last Post: 04-23-2011, 08:32 PM
  2. Replies: 3
    Last Post: 07-06-2009, 05:38 AM
  3. Wireless Card Mode will not change from monitor to managed!!
    By RiseAbove in forum OLD Newbie Area
    Replies: 4
    Last Post: 03-12-2009, 12:09 AM
  4. How to switch to managed mode from monitor mode backtrack 3?
    By donjuanzx9 in forum OLD Newbie Area
    Replies: 8
    Last Post: 07-15-2008, 04:41 AM
  5. Replies: 0
    Last Post: 11-17-2007, 10:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •