For all ppl who have these Errors in Metasploit when using db_nmap.

[*] Nmap: 'nmap: /opt/framework/lib/libssl.so.0.9.8: no version information available (required by nmap)'[*] Nmap: 'nmap: /opt/framework/lib/libcrypto.so.0.9.8: no version information available (required by nmap)'
Here is the Fix:

cd /opt/framework/lib
sudo mv libcrypto.so.0.9.8 libcrypto.so.0.9.8.bak
sudo mv libssl.so.0.9.8 libssl.so.0.9.8.bak
sudo ln -s /usr/lib/libcrypto.so.0.9.8 ./
sudo ln -s /usr/lib/libssl.so.0.9.8 ./
Now the Error should be cleaned out =)

Note:

This will only work if you have access to non-stripped versions of libcrypto and libssl (openssl). You should also install nscd before...


Have a nice Day