Results 1 to 7 of 7

Thread: [WLAN] Can not change Frequency Channel

  1. #1
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    4

    Default [WLAN] Can not change Frequency Channel

    Hi there! First of all here is what i get.
    Code:
    eht0  IEEE 802.11b/g Mode:Managed Frequency:5.2 Ghz
          Access Point: Not-Asscociated Bit Rate:0 kb/s Tx-Power=31 dBm
          Sensitivity=20/200
          Retry limit:8 RTS thr: 2347 B Fragment thr: 2346 B
          Encryption key:off
          Link Quality:185 Signal leve:0 Nouse level:71
          Rx invalid nwid:0 Rx inavlid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0
    I googled and haven't found anything which could help me.

    I tryed

    Code:
    ifconfig eth0 down
    iwconfig eth0 channel 5
    ifconfig eth0 up
    iwconfig and got the same

    i also got the same when i tryed to change the freq with the freq command. nothing happend.

  2. #2
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Try changing to monitor mode first
    Code:
    ifconfig eth0 up
    iwconfig eth0 mode Monitor channel 5
    "\x74\x68\x65\x70\x72\x65\x7a\x39\x38";

  3. #3
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    4

    Default

    I changed the mode to monitor - nothing happend. I can't find any hotspot either... and... I dunno whats wrong. Maybe my card is not supported?

    MY Wlancard Intersil Corporation Intersil ISL3890 [Prism GT/PrismDuette]


    What I've done:
    Code:
    ifconfig eth0 up
    iwconfig eth0 mode Monitor channel 5
    iwconfig //looked up change. nothing happend.
    iwconfig eth0 freq 2.44G
    iwlist eth0 channel
    Current Frequency:5.2GHz (Channel 40) //looked up change. nothing happend.

  4. #4
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    What exactly are you trying to do?

    Are you using the HostAP drivers?
    "\x74\x68\x65\x70\x72\x65\x7a\x39\x38";

  5. #5
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    4

    Default

    I am sorry :-( I don't know where to look up the drivers in BackTrack2. Just booted the LiveCD and haven't made any changes.

    I am trying to change the Channel of the Card to 5 because i wanted to connect to my WLANRouter which is running on channel 5 too. I enabled Broadcasting mode at my router so i could find him. But when i try to scan for the Router i can't find it. And i have no clue how to connect to it because I can't change the damn channel and frequency.



    I just want to set up my Wlan to surf in the net ^^


    LINK to a Support Ticked, with the same problem:
    HA TE TE PE : / / lists4.opensuse.org/opensuse-mobile-de/2005-02/msg00276.html

  6. #6
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by DoradoVoller View Post
    I am sorry :-( I don't know where to look up the drivers in BackTrack2. Just booted the LiveCD and haven't made any changes.

    I am trying to change the Channel of the Card to 5 because i wanted to connect to my WLANRouter which is running on channel 5 too. I enabled Broadcasting mode at my router so i could find him. But when i try to scan for the Router i can't find it. And i have no clue how to connect to it because I can't change the damn channel and frequency.



    I just want to set up my Wlan to surf in the net ^^


    LINK to a Support Ticked, with the same problem:
    HA TE TE PE : / / lists4.opensuse.org/opensuse-mobile-de/2005-02/msg00276.html
    You need to learn the "iwconfig" command and how it works.
    Try
    Code:
    man iwconfig
    After that is correctly set, you need to use
    Code:
    dhcpcd (interface)
    to get an IP address.
    "\x74\x68\x65\x70\x72\x65\x7a\x39\x38";

  7. #7
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    4

    Default

    I don't need to learn it cause i already read about that here

    linuxcommand.org/man_pages/iwconfig8.html

    but thanks vor the man command

    I think I have a soloution for my problem. I need to install acerhk to activate my card first. But i am very sad about read(y)+ing the bug section that its not included in bt2 ^^

    Where can I get acerhk? I found a download link but i don't understand how to compile it into the kernel and load it ^^

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •