Results 1 to 2 of 2

Thread: running msfconsole from /pentest/exploits/framework3 is diff than running globally?

  1. #1
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    2

    Default running msfconsole from /pentest/exploits/framework3 is diff than running globally?

    Okay, so I have been doing some testing with Backtrack 5. So I have been reading that msf comes with postgresql installed and running. Now, when I run it globally(not from /pentest/exploits/framework3) it allows me to db_driver postgresql, but when I try to attach or create a new database with db_connect it tells me that postgresql is not running on port 5432.

    When I run /pentest/exploits/framework3/msfconsole and try to do a db_driver postgresql it says that I have to install postgresql. Why are these different? Has anyone run into this.

    What I also found out is that postgresql is running on 7175 and when I run msfgui and attach to the database on 7175 with armitage it will attach to the database.

    On previous testings of BT5 I went ahead and installed postgresql 8.4 and it worked fine however, armitage wouldn't connect to the database.

    Am I doing something wrong here?

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Posts
    126

    Default Re: running msfconsole from /pentest/exploits/framework3 is diff than running globall

    msf > msfupdate

    Updated to revision 13755

    root@bt:~# msfconsole


    MMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMM
    MMMMMMMMMMM MMMMMMMMMM
    MMMN$ vMMMM
    MMMNl MMMMM MMMMM JMMMM
    MMMNl MMMMMMMN NMMMMMMM JMMMM
    MMMNl MMMMMMMMMNmmmNMMMMMMMMM JMMMM
    MMMNI MMMMMMMMMMMMMMMMMMMMMMM jMMMM
    MMMNI MMMMMMMMMMMMMMMMMMMMMMM jMMMM
    MMMNI MMMMM MMMMMMM MMMMM jMMMM
    MMMNI MMMMM MMMMMMM MMMMM jMMMM
    MMMNI MMMNM MMMMMMM MMMMM jMMMM
    MMMNI WMMMM MMMMMMM MMMM# JMMMM
    MMMMR ?MMNM MMMMM .dMMMM
    MMMMNm `?MMM MMMM` dMMMMM
    MMMMMMN ?MM MM? NMMMMMN
    MMMMMMMMNe JMMMMMNMMM
    MMMMMMMMMMNm, eMMMMMNMMNMM
    MMMMNNMNMMMMMNx MMMMMMNMMNMMNM
    MMMMMMMMNMMNMMMMm+..+MMNMMNMNMMNMMNMM



    =[ metasploit v4.0.1-dev [core:4.0 api:1.0]
    + -- --=[ 735 exploits - 376 auxiliary - 82 post
    + -- --=[ 228 payloads - 27 encoders - 8 nops
    =[ svn r13755 updated today (2011.09.19)


    root@bt:~# cd /opt/framework/msf3/
    root@bt:/opt/framework/msf3# msfconsole

    msf auxiliary(msfcrawler) > set THREADS 24
    THREADS => 24
    msf auxiliary(msfcrawler) > set RPORT 80
    RPORT => 80
    msf auxiliary(msfcrawler) > set PATH /
    PATH => /
    msf auxiliary(msfcrawler) > run

    etc. armitage works perfectly. i do share similar concern/issue about postgresql.
    Last edited by clone; 09-19-2011 at 05:41 AM.

Similar Threads

  1. W3AF - Anyone ?? Running
    By furt1maggr3d10r in forum BackTrack 5 Beginners Section
    Replies: 9
    Last Post: 06-15-2011, 10:48 AM
  2. Replies: 8
    Last Post: 03-30-2009, 07:39 PM
  3. fan running @ max.
    By Xmaster in forum OLD Newbie Area
    Replies: 7
    Last Post: 01-10-2008, 06:31 PM
  4. Running from a usb
    By Little_Dice in forum OLD Newbie Area
    Replies: 5
    Last Post: 12-13-2007, 05:51 AM
  5. cannot get these running.
    By ace.3 in forum OLD Newbie Area
    Replies: 1
    Last Post: 12-01-2007, 12:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •