Hello!

I intend to enable the "high-power-function" of USB stick "ALFA realtek RTL 8187L (model: AWUS036H/ FCC ID: UO2AWUS036H) in a virtual machine (VMware). To acchieve this I use the following lines of code from here: http://www.aircrack-ng.org/doku.php?id=r8187

PHP Code:
ifconfig wlan0 down     
rmmod r8187 rtl8187 2
>/dev/null
wget http
://dl.aircrack-ng.org/drivers/rtl8187_linux_26.1010.zip
unzip rtl8187_linux_26.1010.zip
cd rtl8187_linux_26.1010.0622.2006
/
wget http://patches.aircrack-ng.org/rtl8187_2.6.27.patch
wget http://patches.aircrack-ng.org/rtl8187_2.6.32.patch
tar xzf drv.tar.gz
tar xzf stack
.tar.gz
patch 
-Np1 -i rtl8187_2.6.27.patch
patch 
-Np1 -i rtl8187_2.6.32.patch
make
make install 
1st problem:
without success resulting in the following error messages


PHP Code:
make -C beta-8187 all
make
[1]: Entering directory `/usr/src/rtl8187_linux_26.1010.0622.2006/beta-8187'
make -C /lib/modules/2.6.39.4/build M=/usr/src/rtl8187_linux_26.1010.0622.2006/beta-8187 modules
make[2]: Entering directory 
`/usr/src/linux-source-2.6.39.4'

[B]  WARNING: Symbol version dump /usr/src/linux-source-2.6.39.4/Module.symvers
           is missing; modules will have no dependencies and modversions.[/B]

  CC [M]  /usr/src/rtl8187_linux_26.1010.0622.2006/beta-8187/r8187_core.o
  CC [M]  /usr/src/rtl8187_linux_26.1010.0622.2006/beta-8187/r8180_93cx6.o
  CC [M]  /usr/src/rtl8187_linux_26.1010.0622.2006/beta-8187/r8180_wx.o
  CC [M]  /usr/src/rtl8187_linux_26.1010.0622.2006/beta-8187/r8180_rtl8225.o
  CC [M]  /usr/src/rtl8187_linux_26.1010.0622.2006/beta-8187/r8180_rtl8225z2.o
  LD [M]  /usr/src/rtl8187_linux_26.1010.0622.2006/beta-8187/r8187.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /usr/src/rtl8187_linux_26.1010.0622.2006/beta-8187/r8187.mod.o
  LD [M]  /usr/src/rtl8187_linux_26.1010.0622.2006/beta-8187/r8187.ko
make[2]: Leaving directory `/usr/src/linux-source-2.6.39.4'
make[1]: Leaving directory `/usr/src/rtl8187_linux_26.1010.0622.2006/beta-8187'
root@bt:/usr/src/rtl8187_linux_26.1010.0622.2006# sudo make install
install -d /lib/modules/2.6.39.4/kernel/drivers/net/wireless/rtl_ieee80211
install -d /lib/modules/2.6.39.4/kernel/drivers/net/wireless/rtl8187
install -m 644 ./ieee80211/*.ko /lib/modules/2.6.39.4/kernel/drivers/net/wireless/rtl_ieee80211
install -m 644 ./beta-8187/*.ko /lib/modules/2.6.39.4/kernel/drivers/net/wireless/rtl8187
depmod -ae
[B]WARNING: -e needs -E or -Froo[/B]t@bt:/usr/src/rtl8187_linux_26.1010.0622.2006# 
Who can help me to understand them and assist me in finding a executable/workable solution


2nd problem:

after execution of the last line the below error message appears and execution is stopped

WARNING: -e needs -E or -Froot@bt:/usr/src/rtl8187_linux_26.1010.0622.2006#
[/PHP]



many thanks in advance