I have slowly made progress in trying to install "basket" of all things. Apparently you have to slog through a ton of other installs first and copy-pasta files over to folders that didn't exist first. You know, I know its Linux based but it cannot be this difficult. I think I may be doing something the hard/wrong way because I am finally stumped and so are my friends:


-- Found Qt-Version 4.7.0 (using /usr/bin/qmake)
-- Found X11: /usr/lib/libX11.so
CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:565 (include):
include could not find load file:

/usr/share/kde4/apps/cmake/modules/KDELibsDependencies.cmake
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
CMakeLists.txt:4 (find_package)


CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:566 (include):
include could not find load file:

/usr/share/kde4/apps/cmake/modules/KDEPlatformProfile.cmake
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
CMakeLists.txt:4 (find_package)


CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:580 (macro_ensure_version):
MACRO_ENSURE_VERSION Macro invoked with incorrect arguments for macro
named: MACRO_ENSURE_VERSION
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
CMakeLists.txt:4 (find_package)


CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:595 (include):
include could not find load file:

/usr/share/kde4/apps/cmake/modules/KDELibs4ToolsTargets.cmake
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
CMakeLists.txt:4 (find_package)


CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:645 (include):
include could not find load file:

/usr/share/kde4/apps/cmake/modules/KDELibs4LibraryTargets.cmake
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
CMakeLists.txt:4 (find_package)


-- ERROR: unable to find the KDE 4 headers
-- ERROR: unable to find the KDE 4 core library
-- Didn't find the KDE4 kconfig_compiler preprocessor
-- Found automoc4: /usr/bin/automoc4
CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:1379 (message):
ERROR: the installed kdelibs version is too old, at least version 4.0.0 is
required
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
CMakeLists.txt:4 (find_package)


-- Configuring incomplete, errors occurred!

What in the name of Bob did I do?!