Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Error in metasploit after UPDATE !!

  1. #11
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    3

    Default Re: Error in metasploit after UPDATE !!

    I'm having the same problem. Metasploit won't run after a fresh install and update. However, after fiddling with it for a while I noticed that it launches fine if you run "msfconsole" from the "/pentest/" directory, and the error varies depending on what folder you're in. I'll post some screens to show what I mean.

    Code:
    root@backtrack5:~# msfconsole
    /opt/framework3/msf3/lib/msf/core/exploit/snmp.rb:2:in `require': no such file to load -- snmp (LoadError)
    	from /opt/framework3/msf3/lib/msf/core/exploit/snmp.rb:2:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/core/exploit/mixins.rb:47:in `require'
    	from /opt/framework3/msf3/lib/msf/core/exploit/mixins.rb:47:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/core/exploit.rb:217:in `require'
    	from /opt/framework3/msf3/lib/msf/core/exploit.rb:217:in `<class:Exploit>'
    	from /opt/framework3/msf3/lib/msf/core/exploit.rb:29:in `<module:Msf>'
    	from /opt/framework3/msf3/lib/msf/core/exploit.rb:4:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/core.rb:52:in `require'
    	from /opt/framework3/msf3/lib/msf/core.rb:52:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/ui/console/driver.rb:1:in `require'
    	from /opt/framework3/msf3/lib/msf/ui/console/driver.rb:1:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/ui/console.rb:10:in `require'
    	from /opt/framework3/msf3/lib/msf/ui/console.rb:10:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/ui.rb:10:in `require'
    	from /opt/framework3/msf3/lib/msf/ui.rb:10:in `<top (required)>'
    	from /opt/framework3/msf3/msfconsole:118:in `require'
    	from /opt/framework3/msf3/msfconsole:118:in `<main>'
    root@backtrack5:~# cd /
    root@backtrack5:/# msfconsole
    /opt/framework3/msf3/lib/rex/exploitation/jsobfu.rb:7:in `require': no such file to load -- rkelly (LoadError)
    	from /opt/framework3/msf3/lib/rex/exploitation/jsobfu.rb:7:in `<top (required)>'
    	from /opt/framework3/msf3/lib/rex/exploitation/heaplib.rb:3:in `require'
    	from /opt/framework3/msf3/lib/rex/exploitation/heaplib.rb:3:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/core/exploit/http/server.rb:4:in `require'
    	from /opt/framework3/msf3/lib/msf/core/exploit/http/server.rb:4:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/core/exploit/mixins.rb:39:in `require'
    	from /opt/framework3/msf3/lib/msf/core/exploit/mixins.rb:39:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/core/exploit.rb:217:in `require'
    	from /opt/framework3/msf3/lib/msf/core/exploit.rb:217:in `<class:Exploit>'
    	from /opt/framework3/msf3/lib/msf/core/exploit.rb:29:in `<module:Msf>'
    	from /opt/framework3/msf3/lib/msf/core/exploit.rb:4:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/core.rb:52:in `require'
    	from /opt/framework3/msf3/lib/msf/core.rb:52:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/ui/console/driver.rb:1:in `require'
    	from /opt/framework3/msf3/lib/msf/ui/console/driver.rb:1:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/ui/console.rb:10:in `require'
    	from /opt/framework3/msf3/lib/msf/ui/console.rb:10:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/ui.rb:10:in `require'
    	from /opt/framework3/msf3/lib/msf/ui.rb:10:in `<top (required)>'
    	from /opt/framework3/msf3/msfconsole:118:in `require'
    	from /opt/framework3/msf3/msfconsole:118:in `<main>'
    root@backtrack5:/# cd /pentest
    root@backtrack5:/pentest# msfconsole
    
    IIIIII    dTb.dTb        _.---._
      II     4'  v  'B   .'"".'/|`.""'.
      II     6.     .P  :  .' / |  `.  :
      II     'T;. .;P'  '.'  /  |    `.'
      II      'T; ;P'    `. /   |    .'
    IIIIII     'YvP'       `-.__|__.-'
    
    I love shells --egypt
    
    
           =[ metasploit v4.0.1-dev [core:4.0 api:1.0]
    + -- --=[ 730 exploits - 374 auxiliary - 81 post
    + -- --=[ 227 payloads - 27 encoders - 8 nops
           =[ svn r13720 updated today (2011.09.12)
    
    msf >
    Hope this helps.

    -Grey

  2. #12
    Just burned his ISO
    Join Date
    Mar 2011
    Posts
    11

    Default Re: Error in metasploit after UPDATE !!

    I will run with the method above, however there is one problem. If you run for instance db_nmap -help you will get the following:
    root@bt:/opt/framework/msf3# msfconsole

    IIIIII dTb.dTb _.---._
    II 4' v 'B .'"".'/|`.""'.
    II 6. .P : .' / | `. :
    II 'T;. .;P' '.' / | `.'
    II 'T; ;P' `. / | .'
    IIIIII 'YvP' `-.__|__.-'

    I love shells --egypt


    =[ metasploit v4.0.1-dev [core:4.0 api:1.0]
    + -- --=[ 730 exploits - 374 auxiliary - 81 post
    + -- --=[ 227 payloads - 27 encoders - 8 nops
    =[ svn r13720 updated today (2011.09.12)

    msf > db_nmap[*] Usage: db_nmap [nmap options]
    msf > db_nmap -help
    .
    .
    .[*] Nmap: SEE THE MAN PAGE (http://nmap.org/book/man.html) FOR MORE OPTIONS AND EXAMPLES
    [-] Error while running command db_nmap: data cannot be empty

    Call stack:
    /opt/framework/ruby/lib/ruby/gems/1.9.1/gems/nokogiri-1.4.3/lib/nokogiri/xml/sax/parser.rb:108:in `memory'
    /opt/framework/ruby/lib/ruby/gems/1.9.1/gems/nokogiri-1.4.3/lib/nokogiri/xml/sax/parser.rb:108:in `parse_memory'
    /opt/framework/ruby/lib/ruby/gems/1.9.1/gems/nokogiri-1.4.3/lib/nokogiri/xml/sax/parser.rb:83:in `parse'
    /opt/framework/msf3/lib/msf/core/db.rb:3897:in `import_nmap_noko_stream'
    /opt/framework/msf3/lib/msf/core/db.rb:3914:in `import_nmap_xml'
    /opt/framework/msf3/lib/msf/core/db.rb:3867:in `import_nmap_xml_file'
    /opt/framework/msf3/lib/msf/ui/console/command_dispatcher/db.rb:1614:in `cmd_db_nmap'
    /opt/framework/msf3/lib/rex/ui/text/dispatcher_shell.rb:380:in `run_command'
    /opt/framework/msf3/lib/rex/ui/text/dispatcher_shell.rb:342:in `block in run_single'
    /opt/framework/msf3/lib/rex/ui/text/dispatcher_shell.rb:336:in `each'
    /opt/framework/msf3/lib/rex/ui/text/dispatcher_shell.rb:336:in `run_single'
    /opt/framework/msf3/lib/rex/ui/text/shell.rb:199:in `run'
    /opt/framework/msf3/msfconsole:130:in `<main>'
    msf >
    I did not run
    ./msfconsole
    , instead I have used
    msfconsole
    If you run
    ./msfconsole
    than for any command you would get
    msf > db_nmap -help
    [-] Database not connected
    msf >

  3. #13
    Good friend of the forums zimmaro's Avatar
    Join Date
    Mar 2010
    Location
    milano
    Posts
    407

    Default Re: Error in metasploit after UPDATE !!

    hi,aboot
    can you try to switching ruby version in 1.8.7 (update-alternatives --config ruby) select 0
    launches Metasploit with msfconsole
    in my bt5r1 work fine! TRY! bye

  4. #14
    Just burned his ISO interstella's Avatar
    Join Date
    Aug 2011
    Location
    Germany
    Posts
    5

    Default AW: Error in metasploit after UPDATE !!

    Can confirm too, that
    Code:
    cd /pentest
    msfconsole
    working well.

    To start armitage just cd to /pentest too!!!

    Thx for this nice info.

  5. #15
    Just burned his ISO
    Join Date
    Apr 2011
    Posts
    4

    Default Re: Error in metasploit after UPDATE !!

    yes i can confirm, this was the only way i could load msfconsole. one should also try

    " cd /opt/framework/msf3 && msfconsole "

    this will fire it up in one shot

  6. #16
    Just burned his ISO
    Join Date
    Nov 2008
    Posts
    3

    Default

    the msfconsole that is in your path is the wrong one.
    if you "which msfconsole" you will see that you are running "/usr/local/bin/msfconsole" and that points to "/opt/framework/app/msfconsole/"
    you need to run "/opt/framework/msf3/msfconsole"
    so you need to change the link.
    "rm /usr/local/bin/msfconsole"
    "ln -s /opt/framework/msf3/msfconsole /usr/local/bin/msfconsole"

    BTW all the msf tool links are pointing to the wrong spots.

    while my fix helps , there is alot of other issues.
    Last edited by g0tmi1k; 09-16-2011 at 09:09 AM.

  7. #17
    Just burned his ISO
    Join Date
    Sep 2011
    Posts
    1

    Default Re: Error in metasploit after UPDATE !!

    I had this error and it's working today after doing a msupdate.

    I also did a apt-get dist-update

  8. #18
    Just burned his ISO
    Join Date
    Sep 2011
    Posts
    1

    Default Re: Error in metasploit after UPDATE !!

    Got it working again.

    Got the sollution from http://www.crack-wifi.com/forum/viewtopic.php?id=6618

    I did

    apt-get update && apt-get dist-upgrade

    then I did

    svn up /opt/framework/*

    Behold! metasploit launchers started wworking again!

    Hope this helps some of you as well

    Greatings from the n00b H4cker

  9. #19
    Just burned his ISO
    Join Date
    Sep 2011
    Posts
    1

    Default Re: Error in metasploit after UPDATE !!

    happend same here, but now works..

  10. #20
    Just burned his ISO
    Join Date
    Mar 2011
    Posts
    11

    Default Re: Error in metasploit after UPDATE !!

    Can anybody check if you get any errors after running
    db_nmap -help
    command.
    I have done
    apt-get update && apt-get dist-upgrade
    svn up /opt/framework/*
    Metasploit starts without errors, but nmap help shows
    [-] Error while running command db_nmap: data cannot be empty

    Call stack:
    /opt/framework/ruby/lib/ruby/gems/1.9.1/gems/nokogiri-1.4.3/lib/nokogiri/xml/sax/parser.rb:108:in `memory'
    /opt/framework/ruby/lib/ruby/gems/1.9.1/gems/nokogiri-1.4.3/lib/nokogiri/xml/sax/parser.rb:108:in `parse_memory'
    /opt/framework/ruby/lib/ruby/gems/1.9.1/gems/nokogiri-1.4.3/lib/nokogiri/xml/sax/parser.rb:83:in `parse'
    /opt/framework/msf3/lib/msf/core/db.rb:3897:in `import_nmap_noko_stream'
    /opt/framework/msf3/lib/msf/core/db.rb:3914:in `import_nmap_xml'
    /opt/framework/msf3/lib/msf/core/db.rb:3867:in `import_nmap_xml_file'
    /opt/framework/msf3/lib/msf/ui/console/command_dispatcher/db.rb:1614:in `cmd_db_nmap'
    /opt/framework/msf3/lib/rex/ui/text/dispatcher_shell.rb:380:in `run_command'
    /opt/framework/msf3/lib/rex/ui/text/dispatcher_shell.rb:342:in `block in run_single'
    /opt/framework/msf3/lib/rex/ui/text/dispatcher_shell.rb:336:in `each'
    /opt/framework/msf3/lib/rex/ui/text/dispatcher_shell.rb:336:in `run_single'
    /opt/framework/msf3/lib/rex/ui/text/shell.rb:199:in `run'
    /opt/framework/msf3/msfconsole:130:in `<main>'

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Metasploit Error after update
    By SajberKod in forum BackTrack 5 Bugs
    Replies: 11
    Last Post: 08-05-2011, 02:41 AM
  2. Replies: 1
    Last Post: 05-07-2011, 01:35 PM
  3. Ruby Gems Error after Metasploit Update
    By blakhal0 in forum BackTrack Bugs
    Replies: 7
    Last Post: 01-19-2011, 03:21 AM
  4. metasploit wont update:error
    By BigMac in forum OLD Newbie Area
    Replies: 7
    Last Post: 01-01-2010, 09:06 AM
  5. Svn Update Metasploit Error
    By fload in forum OLD Newbie Area
    Replies: 2
    Last Post: 02-27-2009, 09:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •