Hello.
Sorry for my english, it's not my native language.
I'm new to Linux and BT, and I not good at networking.

I need configure internet through VPN connection (L2TP) in Backtrack 5 R1 x64 (KDE, HDD installation).
I have BT and Win7 installed on one HDD (different partitions). In Win7 internet works fine, configuration takes 5 minutes.

This is information from my internet provider, about Ubuntu configuration (i translate it from Russian):
Code:
For Internet working through L2TP protocol - xl2tpd packet must be installed:

  sudo apt-get install xl2tpd

Then configure xl2tpd daemon.

Open file /etc/xl2tpd/xl2tpd.conf and add strings to the end:

  [global]
  access control = yes

  [lac vladlink]
  lns = LP.vladlink.lan
  redial = yes
  redial timeout = 1
  require chap = yes
  require authentication = no
  name = YOUR LOGIN
  ppp debug = no
  pppoptfile = /etc/ppp/options.l2tpd.vladlink
  require pap = no
  autodial = yes

Create file /etc/ppp/options.l2tpd.vladlink and fill it:

  name YOUR LOGIN
  remotename vladlink
  nodeflate
  nobsdcomp
  persist
  maxfail 0
  nopcomp
  noaccomp
  defaultroute
  replacedefaultroute

Open file /etc/ppp/chap-secrets and add:

  YOUR LOGIN * YOUR PASSWORD

Open file /etc/dhcp3/dhclient.conf and find string:

  option rfc3442-classless-static-routes code 128 = array of unsigned integer 8;

Replace 128 (or other value) to 249

  option rfc3442-classless-static-routes code 249 = array of unsigned integer 8;

Open file /etc/network/interfaces and add:

  auto eth0
  iface eth0 inet dhcp
  up /etc/init.d/xl2tpd restart

Restart computer.
So, i followed all those instructions, and that's what i get:

I can't use "sudo apt-get install xl2tpd" command, cause there is no internet connection.
So, i download xl2tpd-1.3.0.tar.gz, that contains cources from Windows, and install it with "make", "make install".
Next, i not find default configuration file in "/etc/xl2tpd/xl2tpd.conf", so i create new and just add required strings.
Next i create "/etc/ppp/options.l2tpd.vladlink", change "/etc/ppp/chap-secrets", "/etc/dhcp3/dhclient.conf" and "/etc/network/interfaces" and restart.
No internet...

This is result of traceroute command after all my witchcraft:
Code:
traceroute to google.com (74.125.232.19), 30 hops max, 60 byte packets
 1  172.27.73.1 (172.27.73.1)  0.391 ms  0.808 ms  0.796 ms
 2  po57-4ge-vlan4004.c6506.core.vladlink.net (109.126.0.145)  0.768 ms  0.766 ms  0.758 ms
 3  * * *
...
30  * * *
And output of some other commands:
ifconfig
Code:
eth0      Link encap:Ethernet  HWaddr 70:71:bc:ba:71:67  
          inet addr:172.27.73.20  Bcast:172.27.73.255  Mask:255.255.255.0
          inet6 addr: fe80::7271:bcff:feba:7167/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:68 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000 
          RX bytes:6320 (6.3 KB)  TX bytes:2556 (2.5 KB)
          Interrupt:46 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:40 errors:0 dropped:0 overruns:0 frame:0
          TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3993 (3.9 KB)  TX bytes:3993 (3.9 KB)
iwconfig
Code:
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
lspci
Code:
...
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
06:00.0 Ethernet controller: Atheros Communications AR8131 Gigabit Ethernet (rev c0)
...
And yet, when i type "xl2tpd" without any parameters in console - there is no feedback.

Thanks for reading. Any help is appreciated.