Im trying to install metasploit on my n900 and i followed these instructions to the letter but when i start metaploit i am faced with this error any ideas how to solve this or whats gone wrong ...

Code:
home/user/MyDocs # ruby1.8 /home/user/msf3/msfconsole -L
[-] ***
[-] * WARNING: No database support: LoadError no such file to load -- rubygems
[-] ***

 ____________ 
< metasploit >
 ------------ 
       \   ,__,
        \  (oo)____
           (__)    )\
              ||--|| *


       =[ metasploit v3.3.4-dev [core:3.3 api:1.0]
+ -- --=[ 492 exploits - 0 auxiliary
+ -- --=[ 192 payloads - 23 encoders - 8 nops

msf >
after reinstalling the ruby gems i am now faced with this error

Code:
 WARNING: No database support: LoadError no such file to load -- active_record
is this never ending now i have this error any one have any ideas at all ??

Code:
ARNING: No database support: RuntimeError ruby lib version (1.8.5) doesn't match executable version (1.8.7)
what am i missing ere

many thanks