Results 1 to 8 of 8

Thread: Why does my KDE often crash

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    1

    Default Why does my KDE often crash

    Hi All, I think someone would be able to help me with this...I'm using Backtrack5 x64 with KDE ,but sometimes when I minimize or maxmize a window I got this error:
    Code:
    X.Org X Server 1.7.6
    Release Date: 2010-03-17
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.24-28-server x86_64 Ubuntu
    Current Operating System: Linux Ettack 2.6.39.4 #1 SMP Wed Aug 17 21:42:30 EDT 2011 x86_64
    Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.39.4 root=UUID=64836b64-3862-4823-9329-a64dc9a6adde ro vga=773 text splash nomodeset vga=791
    Build Date: 08 March 2011  08:22:34AM
    xorg-server 2:1.7.6-2ubuntu7.6 (For technical support please see http://www.ubuntu.com/support) 
    Current version of pixman: 0.16.4
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 28 21:23:13 2011
    (==) Using config directory: "/usr/lib/X11/xorg.conf.d"
    (==) No Layout section.  Using the first Screen section.
    (==) No screen section available. Using defaults.
    (**) |-->Screen "Default Screen Section" (0)
    (**) |   |-->Monitor "<default monitor>"
    (==) No monitor specified for screen "Default Screen Section".
    	Using a default monitor configuration.
    (==) Automatically adding devices
    (==) Automatically enabling devices
    (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    	Entry deleted from font path.
    (==) FontPath set to:
    	/usr/share/fonts/X11/misc,
    	/usr/share/fonts/X11/Type1,
    	/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    	built-ins
    (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
    (II) The server relies on udev to provide the list of input devices.
    	If no devices become available, reconfigure udev or disable AutoAddDevices.
    (II) Loader magic: 0x7cb840
    (II) Module ABI versions:
    	X.Org ANSI C Emulation: 0.4
    	X.Org Video Driver: 6.0
    	X.Org XInput driver : 7.0
    	X.Org Server Extension : 2.0
    .....
    (II) intel(0): EDID vendor "LCD", prod id 8192
    (WW) intel(0): i830_uxa_prepare_access: bo map failed
    (WW) intel(0): i830_uxa_prepare_access: bo map failed
    
    Fatal server error:
    Failed to submit batchbuffer: Invalid argument
    
    
    Please consult the The X.Org Foundation support 
    	 at http://wiki.x.org
     for help. 
    Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    
    (II) Power Button: Close
    (II) UnloadModule: "evdev"
    (II) Power Button: Close
    (II) UnloadModule: "evdev"
    (II) Logitech USB Optical Mouse: Close
    (II) UnloadModule: "evdev"
    (II) AT Translated Set 2 keyboard: Close
    (II) UnloadModule: "evdev"
    (II) AIGLX: Suspending AIGLX clients for VT switch
     ddxSigGiveUp: Closing log

  2. #2
    Good friend of the forums scottm99's Avatar
    Join Date
    Feb 2010
    Location
    underwater
    Posts
    371

    Default Re: Why does my KDE often crash

    Some suggestions...first of all, what's the specs of the machine on which you're running BT5? Have you looked at the hardware compatibility list? Have you tried other BT5 versions, or tried on another machine?
    If I could figure out how to scuba dive & hack at the same time, there would be nothing I couldn't do...

  3. #3
    Just burned his ISO
    Join Date
    Apr 2010
    Posts
    4

    Default Re: Why does my KDE often crash

    I've been having a similar problem with xserver crashing.

    I am using Backtrack5 KDE 32.
    Going to try out R1 and see if I have the same problem.

    This is my xorg log file.

    HTML Code:
    http://pastebin.com/FMzyGyxp

  4. #4
    Just burned his ISO
    Join Date
    Mar 2011
    Location
    France
    Posts
    1

    Default Re : Why does my KDE often crash

    *sorry for my english*

    Hi, I've the same problem with BT5R1 KDE 32.
    When I have 2 or 3 running Konsoles and Konqueror, crash, problem submit batchbuffer .... fatal error .... server x mes couilles... and re-startx with all my konsoles closed (y)

  5. #5
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    1

    Default Re: Re : Why does my KDE often crash

    Quote Originally Posted by spacezinzin View Post
    *sorry for my english*

    Hi, I've the same problem with BT5R1 KDE 32.
    When I have 2 or 3 running Konsoles and Konqueror, crash, problem submit batchbuffer .... fatal error .... server x mes couilles... and re-startx with all my konsoles closed (y)
    I've been dealing with the same shit, ran BT 4 with KDE just fine, but as soon as I upgraded, it's been locking up on me when I minimize a window. typically
    firefox. And there's no pattern to it...sometimes 5 mins after startup, sometimes 2 hours. Running a 2 year old Sony VAIO.

  6. #6
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    24

    Default Re: Why does my KDE often crash

    First at all, KDE has been always buggy and picky with hardware, also we have lucid 10.04 with a old KDE version which has bugs, for example in the KDE knowledge base there is a bug with the ACPI in laptops, which is the one I experienced, blank screen after unplugging the power and switching composition (effects).
    They state the solution as restart X, so in my configuration I use the hotkeys CtRL ATL Backspace to kill X, then startx.
    Another solution turning off Effects before unplugging.
    Also there are issues with specific Graphic cards on KDE.

  7. #7
    Junior Member
    Join Date
    Mar 2012
    Location
    SauDi ArabIa
    Posts
    27

    Default Re: Why does my KDE often crash

    try reinstalling xorg

  8. #8
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    1

    Default Re: Why does my KDE often crash

    Quote Originally Posted by p0cTeam View Post
    try reinstalling xorg
    reinstalling xorg does not fix the problem

    it has to be related to intel xord driver
    https://launchpad.net/ubuntu/+source...rg-video-intel

Similar Threads

  1. Crash GUI
    By Fastpath in forum Discussioni Generali
    Replies: 10
    Last Post: 01-15-2010, 08:24 AM
  2. sbd connection crash
    By propercoil in forum OLD Newbie Area
    Replies: 0
    Last Post: 09-01-2009, 01:48 PM
  3. BT4 Vista Crash
    By sbolen28 in forum OLD Newbie Area
    Replies: 7
    Last Post: 06-20-2009, 10:26 PM
  4. BT3 aireplay-ng -9 crash
    By imported_ronin2307 in forum OLD Newbie Area
    Replies: 0
    Last Post: 04-21-2009, 08:50 PM
  5. Crash KDE???????????
    By phildep8 in forum OLD Newbie Area
    Replies: 1
    Last Post: 03-29-2009, 09:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •