Results 1 to 10 of 28

Thread: Problems with ALFA Network AWUS036NH and BT4

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    16

    Default Problems with ALFA Network AWUS036NH and BT4

    Hi,

    I've got a Alfa Networks AWUS036NH, which uses the RT3070 chipset. Backtrack4 Final shows it as an RT 2870 when I run lsusb.

    airmon-ng ra0 shows that it's an rt2500.

    I cannot get it working with Kismet or airedump-ng. I don't know if being detected as an rt2500 is the cause of the problem or not, but I don't have any idea where to start troubleshooting.

    I've got an AWUS036H on the way, in case I cannot get this new adapter to work.

    Any help would be appreciated.

    Thanks!

    EDIT: It looks like it works with kismet if I set it to use the 2870 chipset. Unfortunately it's extremely slow and doesn't really work all that well.
    Last edited by Charles; 01-24-2010 at 04:23 AM. Reason: Updated Post.

  2. #2
    Moderator S3M73X's Avatar
    Join Date
    Feb 2010
    Posts
    103

    Default Re: Problems with ALFA Network AWUS036NH and BT4

    nice post Charles.

    I have also such an adapter and just hat a short talk to pure_hate who also owns such a device.
    After searching the web i found out that the Ralink Chipset rt3070 is better supported on the latest kernel v2.6.31.

    And pure_hated said he got it to run using the wireless compat drivers and some special firmware like described in here -> TUTORIAL: Installing drivers RTL8187, r8187, RT2800usb on UBUNTU 8.10/9.04

    and pure_hate used the "rt2800" usb-wireless-device-drivers then to get the awus036nh running in a ubuntu-machine.

    did not try it yet but maybe i will. ;D

  3. #3
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    16

    Default Re: Problems with ALFA Network AWUS036NH and BT4

    Thanks for the info. I'll check that out.

  4. #4
    Just burned his ISO strasharo's Avatar
    Join Date
    Jan 2010
    Posts
    17

    Default Re: Problems with ALFA Network AWUS036NH and BT4

    You could also check this LINK, there's a detailed guide how to install the neccessary drivers for this card, please report back the results if you try it.

  5. #5
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    2

    Default Re: Problems with ALFA Network AWUS036NH and BT4

    PHP Code:
    "You could also check this LINK, there's a detailed guide how to install the neccessary drivers for this card, please report back the results if you try it." 
    i have the alfa 2w card and after about a week of trying, gave up on the injection. i tried this, and it said (in ubuntu, i couldn't get it to work at all with BT4) that the programs used in this tutorial, are new, and wont work for the job. and me being new, didn't know how to revert to old software

  6. #6
    Just burned his ISO strasharo's Avatar
    Join Date
    Jan 2010
    Posts
    17

    Default Re: Problems with ALFA Network AWUS036NH and BT4

    Quote Originally Posted by jamesc00ls0x View Post
    PHP Code:
    "You could also check this LINK, there's a detailed guide how to install the neccessary drivers for this card, please report back the results if you try it." 
    i have the alfa 2w card and after about a week of trying, gave up on the injection. i tried this, and it said (in ubuntu, i couldn't get it to work at all with BT4) that the programs used in this tutorial, are new, and wont work for the job. and me being new, didn't know how to revert to old software
    New instructions HERE

  7. #7
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    13

    Default Re: Problems with ALFA Network AWUS036NH and BT4

    I have a AWUS036NH and I use's the tutorial S3M73X linked to with only one issue; when you install the firmware instead of doing
    Code:
    /lib/firmware/$(uname -r)
    do

    Code:
    /lib/firmware/
    I'm running BT4 and the card works great.

  8. #8
    Good friend of the forums gunrunr's Avatar
    Join Date
    Jan 2010
    Location
    shining my spoon
    Posts
    265

    Default Re: Problems with ALFA Network AWUS036NH and BT4

    Ps if you searched the forums before buying that crappy Nh you would have seen all the posts with people complaining about it. For bandwidth in a pentesting environment is it really worth the hassle? I'm not streaming files I'm dumping packets so I'll keep referring people to the h version and f*** the nh

    Two cents
    Wielder of the spoon of doom
    Summercon, Toorcon, Defcon, Bsides, Derbycon, Shmoocon oh my
    Come hang out with hackers on twitter @gunrunr556

Similar Threads

  1. ALFA Networks AWUS036H
    By MassAppeal in forum HardWare Compatibility List
    Replies: 26
    Last Post: 05-01-2010, 04:46 AM
  2. sslstrip w/ My Wired-Wireless Network
    By MassAppeal in forum Beginners Forum
    Replies: 11
    Last Post: 02-11-2010, 05:56 AM
  3. AutoScan Network
    By Archangel-Amael in forum BackTrack Fixes
    Replies: 1
    Last Post: 01-20-2010, 10:27 PM
  4. network controller does not apear in lspci
    By leeyj4951 in forum Beginners Forum
    Replies: 4
    Last Post: 01-19-2010, 06:25 PM
  5. ISO Image ALFA-AWUS036H
    By MassAppeal in forum BackTrack Bugs
    Replies: 2
    Last Post: 01-17-2010, 10:52 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •