I have been scouring for hours, and I have had no success. I have a MSI Wind U100 which has a RTL8187SE wireless installed. I noticed that as I began practicing Penetration Tests, my results were never consistent while testing with airodump, SET tools and ettercap. I finally plugged in a wireless USB device and have been getting good, consistent results since.

My question is, is there a way that I can install a custom driver for RTL8187SE to support packet injection? I have tried to install custom drivers through other walk-through's that have had success on backtrack 3; however, when I try it on BT 5 I receive no successful results. EX of the failed compiled driver below.

make[1]: Entering directory `/usr/src/linux-source-2.6.39.4'

WARNING: Symbol version dump /usr/src/linux-source-2.6.39.4/Module.symvers
is missing; modules will have no dependencies and modversions.

CC [M] /root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.o
In file included from /root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/ieee80211.h:706,
from /root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180.h:44,
from /root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.c:67:
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/ieee80211_crypt.h:81: warning: ‘struct ieee80211_device’ declared inside parameter list
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/ieee80211_crypt.h:81: warning: its scope is only this definition or declaration, which is probably not what you want
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/ieee80211_crypt.h:84: warning: ‘struct ieee80211_device’ declared inside parameter list
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.c: In function ‘rtl8180_shutdown’:
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.c:203: error: ‘struct net_device’ has no member named ‘stop’
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.c: In function ‘rtl8180_init’:
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.c:4640: e’ has no member named ‘get_stats’
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.c: In fun’:
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.c:6027: e’ has no member named ‘open’
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.c:6028: e’ has no member named ‘stop’
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.c:6030: e’ has no member named ‘tx_timeout’
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.c:6032: e’ has no member named ‘do_ioctl’
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.c:6033: e’ has no member named ‘set_multicast_list’
/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_core.c:6034: e’ has no member named ‘set_mac_address’
make[2]: *** [/root/rtl8187se_linux-04/rtl8187se_coffee/rtl8185/r8180_
make[1]: *** [_module_/root/rtl8187se_linux-04/rtl8187se_coffee/rtl818
make[1]: Leaving directory `/usr/src/linux-source-2.6.39.4'
make: *** [modules] Error 2