Results 1 to 2 of 2

Thread: Yet another nvidia problem, how do i fix this?

  1. #1
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    6

    Default Yet another nvidia problem, how do i fix this?

    Hi!
    I've installed the BT 5 R1 KDE-32bit on to a usbstick using VMware Workstation becouse my dvd-burner is broken.
    I've been trying to get the nVidia drivers to work, but no luck at all. I'm using a Zotac Geforce GT 430 Zone-Edition

    I've been trying this:
    Code:
    prepare-kernel-sources
    cd /usr/src/linux
    cp -rf include/generated/* included/linux
    And disabled nouveau driver in grub and blacklisted vga16fb nvidiafb rivafb rivatv nouveau in /etc/modprobe.d/blacklist.conf

    I downloaded the latest nvidia driver from nVidia.com and installed it no problem.
    But after the reboot when i type startx i get this:



    I tried deleting the *.kcache files in /root/.kde/ but no luck.
    I've then deleted the /etc/X11/xorg.conf to get back in to graphics.

    How do I solve this so I can use the drivers?

  2. #2
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    6

    Default Re: Yet another nvidia problem, how do i fix this?

    Seems like I've solved my own problem, but for the ones that have the same problem here is what i did:

    Code:
    prepare-kernel-sources
    cd /usr/src/linux
    cp -rf include/generated/* included/linux
    Download the headers from apt-get for your kernel.
    To get the version:
    Code:
    uname -r
    Then:
    Code:
    apt-get update && apt-get install linux-headers-Your.Version
    Download the latest beta driver from nvidia.com
    Do this to get it executable:
    Code:
    chmod -x Your.Driver.sh
    Logout from X or do this before the startx-command and install the drivers.
    Code:
    sh filename.sh --kernel-source-path='/usr/src/linux'
    Make sure nvidia do the config before closing or do this command:
    Code:
    nvidia-xconfig
    Reboot.

    Before you do startx you have to manually config the X.
    So first you need to know your GPU.
    Do:
    Code:
    lspci
    And look for your card. Copy the numbers to the left where the text starts, and the exact name of your card.
    Mine was: 01.00.0 something, something nVidia Corporation GF108 [GeForce GT 430]

    So now let's add some settings and stuff in the config:
    Code:
    nano /etc/X11/xorg.conf
    Search for the: Section "Device"
    In identifier you put your card name inside the "".
    Add:
    Code:
    Option "BusType"    "PCIE"
    Option "DesktopSetup"    "horizontal"
    And next thing to do is to add that number we got before using lspci but you delete the unnecessary zeros.
    From 01.00.0 to 1.0.0 and put them like this:
    Code:
    BusID "PCI:1:0:0"
    My section looks like this:
    Code:
    Section "Device"
        Identifier     "nVidia Corporation GF108 [GeForce GT 430]"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        Option         "BusType"             "PCIE"
        Option         "DesktopSetup"        "horizontal"
        BusID          "PCI:1:0:0"
    EndSection
    Ctrl-o to save.

    Reboot if you want and there you go.
    This worked for me but I've tried alot of things before that so hopefully this will do it.

Similar Threads

  1. Resolution problem (NVidia)
    By Tenebrion9 in forum BackTrack 5 Beginners Section
    Replies: 0
    Last Post: 08-09-2011, 05:45 AM
  2. Nvidia Optimus problem
    By s0me0ne in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 07-17-2011, 02:48 PM
  3. Nvidia X-server Problem
    By ReaperX180X in forum Beginners Forum
    Replies: 2
    Last Post: 12-19-2010, 10:27 PM
  4. Nvidia problem
    By Lasperic in forum OLD Bt4beta Non-Working Hardware
    Replies: 6
    Last Post: 05-12-2009, 01:08 PM
  5. BT3 Nvidia Graphics Problem
    By seth_slade in forum OLD BT3beta General
    Replies: 2
    Last Post: 06-03-2008, 04:16 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •