Results 1 to 3 of 3

Thread: swap issue

  1. #1
    Member
    Join Date
    Apr 2007
    Posts
    163

    Default swap issue

    Hey there,

    i created a swap space and would like to get it running on startup. /etc/fstab line looks like this:

    Code:
    /dev/sda4 /mnt/sda4 swap noauto,defaults 0 0 # AutoUpdate
    when i try to get my swap space up and running, i do
    Code:
    swapon /dev/sda4
    and everything is fine. But when i restart B|T, swap has gone.

    then i found the line in rc.S:

    Code:
    # Enable swapping:
    /sbin/swapon -a
    changed it to

    Code:
    # Enable swapping:
    /sbin/swapon /dev/sda4
    but it's still not starting up automatically. dmesg says nothing about swap. Can anyone help me out with this? Where did i go wrong?
    The answer is 42.

  2. #2
    Member
    Join Date
    Jan 2007
    Posts
    242

    Default

    My swap line in fstab looks like:

    /dev/sda2 none swap sw 0 0
    Works here.

    From the swapon man page, about option -a:

    -a All devices marked as ``swap'' swap devices in /etc/fstab are
    made available, except for those with the ``noauto'' option.
    Devices that are already running as swap are silently skipped.
    Do you see your problem?

  3. #3
    Member
    Join Date
    Apr 2007
    Posts
    163

    Default

    i see, i see,
    changed my fstab line, now it works. Many thanks!
    The answer is 42.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •