Results 1 to 2 of 2

Thread: Metasploit causing problems

  1. #1
    Just burned their ISO
    Join Date
    Jul 2012
    Posts
    1

    Default Metasploit causing problems

    I am having problems with metasploit. When I try to remove it with either apt or synaptic, I get an error. I also cannot update the rest of backtrack because it gives an error. Not sure how to proceed. Here is what the error stuff says:

    Code:
    E: /var/cache/apt/archives/metasploit_4.4.0-bt2_i386.deb: subprocess new pre-removal script returned error exit status 127

    Code:
    root@bt:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    2 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up framework (4.0.0-bt1) ...
    chmod: cannot access `framework-32.run': No such file or directory
    /var/lib/dpkg/info/framework.postinst: line 11: ./framework-32.run: No such file or directory
    Building native extensions.  This could take a while...
    Successfully installed mysql-2.9.0
    1 gem installed
    Installing ri documentation for mysql-2.9.0...
    Installing RDoc documentation for mysql-2.9.0...
    ln: creating symbolic link `/pentest/exploits/framework': File exists
    dpkg: error processing framework (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of framework3:
     framework3 depends on framework; however:
      Package framework is not configured yet.
    dpkg: error processing framework3 (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
                              Errors were encountered while processing:
     framework
     framework3
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Thanks,
    JP

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: Metasploit causing problems

    Try:

    Code:
    apt-get -f autoremove
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

Similar Threads

  1. DB Problems in metasploit
    By Nariko in forum BackTrack 5 Beginners Section
    Replies: 3
    Last Post: 10-10-2011, 02:34 PM
  2. Metasploit Problems
    By chance in forum Beginners Forum
    Replies: 1
    Last Post: 12-18-2010, 08:29 AM
  3. ath5k causing problems?
    By 18436572 in forum Beginners Forum
    Replies: 1
    Last Post: 05-07-2010, 06:16 PM
  4. Raid 0 possibly causing problems with install?
    By paradigm in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 7
    Last Post: 12-02-2009, 12:58 AM
  5. macchanger causing problems (i think)
    By SlipDigby in forum OLD Newbie Area
    Replies: 7
    Last Post: 09-09-2008, 03:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •