While updating BT5 KDE 64 bit, there was an error updating Metasploit and it disappeared from my HDD.

My problem seems to be the same as these gentlemen right there:

http://www.backtrack-linux.org/forum...etasploit.html

so.... instead of re-installing BT5 or banging my head further on the framework3 package,I try this workaround:
svn co http://metasploit.com/svn/framework3/trunk/ metasploit

and it works, however when I try db_driver, it tells me "No active Driver"
I then try
gem install libpq-dev
gem install pg

to enable the postgresql driver, but to no avail.

Since it installed it into a different folder then the default framework3 directors, I suspect that it is due to "environment variables" being improperly set (whatever that means), as pointed out in these sites.

http://seclists.org/metasploit/2011/q2/100
THIS IS MY eye-Blog: No Active Driver when you type in db_driver or db_connect?

I am quite new to this, and I'm doing trial and error. Your help is much appreciated.