Hi,

up till yesterday I used BT5 or BT5 R1 (sorry, didnt check before the update). I decided to switch to BT5 R2 and installed it without any problems.
But now, when using kismet or airmon/airodump I see only a small fraction of the accesspoints I saw with the version I had installed before.

My card is a Alfa AWUS036NH (with a 9dbi antenna) which uses rt2800usb. The regulatory bin has been expanded to include a country HX which allows up to 35 db.
Kismet says upon initialisation: "Error: Source wlan0: channel get ioctl failed 22: invalid argument" whereas airodump shows me about 5 of the formerly seen 25 ap´s.

I start airmon-ng with
Code:
root@bt:~# iw reg set HX
root@bt:~# iwconfig wlan0 txpower 35
root@bt:~# airmon-ng start wlan0


Found 2 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID	Name
961	dhclient3
1543	dhclient3
Process with PID 1543 (dhclient3) is running on interface wlan0


Interface	Chipset		Driver

wlan0		Ralink RT2870/3070	rt2800usb - [phy0]
				(monitor mode enabled on mon0)

root@bt:~#
I kill PID 1543 before running any other commands.

Here is additional information:
Code:
root@bt:~# uname -a
Linux bt 3.2.6 #1 SMP Fri Feb 17 10:40:05 EST 2012 i686 GNU/Linux
root@bt:~# ifconfig 
eth0      Link encap:Ethernet  HWaddr 08:00:27:78:05:15  
          inet addr:10.0.2.15  Bcast:10.0.2.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fe78:515/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2710 (2.7 KB)  TX bytes:2383 (2.3 KB)
          Interrupt:10 Base address:0xd020 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:18 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1137 (1.1 KB)  TX bytes:1137 (1.1 KB)

mon0      Link encap:UNSPEC  HWaddr 00-C0-CA-58-10-52-30-30-00-00-00-00-00-00-00-00  
          UP BROADCAST NOTRAILERS RUNNING PROMISC ALLMULTI  MTU:1500  Metric:1
          RX packets:378 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:73076 (73.0 KB)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:c0:ca:58:10:52  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@bt:~# iwconfig 
lo        no wireless extensions.

mon0      IEEE 802.11bgn  Mode:Monitor  Frequency:2.437 GHz  Tx-Power=35 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          
wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=35 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          
eth0      no wireless extensions.

root@bt:~#
BT5 R2 is runing in VirtualBox 4.1.16 with the according Guest Additions installed. The Host is a ubuntu
Code:
kiesel@molukkke:~$ uname -a
Linux molukkke 3.0.0-20-generic #34-Ubuntu SMP Tue May 1 17:24:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
So if anybody could give me a hint what to do or google, the help would be greatly appreciated!
Let me know if you need any more information.

Thank you very much in advance!