Results 1 to 5 of 5

Thread: Problems to get ubertooth up and runing in VMware

  1. #1
    Junior Member
    Join Date
    Jan 2010
    Posts
    29

    Default Problems to get ubertooth up and runing in VMware

    Hi guy`s

    i am having some problems getting my ubertooth dongle up and running in VMware, (Verison of BT tried is 32&64 bit Both gnome and kde also BT4 R1) I know the dongle is working cause it starts fine on my "Normal" installed Backtrack, it seems like it recognizes the card but it wont comunicate with it, all packages are installed as far as i know, (Followed HarvestGardener How to.. Thanks by the way .-)) but when starting the Specan_ui i get the following error.

    root@bt:~/ubertooth-r238/host/specan_ui# python specan_ui.py
    Exception in thread Thread-1:
    Traceback (most recent call last):
    File "/usr/lib/python2.6/threading.py", line 532, in __bootstrap_inner
    self.run()
    File "specan_ui.py", line 43, in run
    for frame in frame_source:
    File "/root/ubertooth-r238/host/specan_ui/specan.py", line 46, in specan
    buffer = self._device.read(0x82, 64)
    File "/usr/local/lib/python2.6/dist-packages/usb/core.py", line 637, in read
    self.__get_timeout(timeout)
    File "/usr/local/lib/python2.6/dist-packages/usb/_debug.py", line 52, in do_trace
    return f(*args, **named_args)
    File "/usr/local/lib/python2.6/dist-packages/usb/backend/libusb10.py", line 493, in bulk_read
    timeout)
    File "/usr/local/lib/python2.6/dist-packages/usb/backend/libusb10.py", line 593, in __read
    timeout))
    File "/usr/local/lib/python2.6/dist-packages/usb/backend/libusb10.py", line 357, in _check
    raise USBError(_str_error[retval.value])
    USBError: Unknown error

    i have to say that i am far from experienced in this field, and i have tried to figure this out myself whit out any luck,
    i would really appriciate if some one could help me to solve this, and i will try to retur the favor the next time.

    best regards

    Cains

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Posts
    126

    Default Re: Problems to get ubertooth up and runing in VMware

    try this before going back to that thread. it contains alot less errors

    http://www.hackfromacave.com/article...tooth_bt5.html

  3. #3
    Junior Member
    Join Date
    Jan 2010
    Posts
    29

    Default Re: Problems to get ubertooth up and runing in VMware

    Thanks Clone, I have tried this and it results in exactly the same error, It looks like it cant communicate with the board, but it recognize it, I`ll see if i cant be the Python module (Libusb) that F"#¤ this up..

  4. #4
    Member
    Join Date
    Feb 2010
    Location
    Somewhere in the hell
    Posts
    91

    Default å›˛č¦†: Problems to get ubertooth up and runing in VMware

    @Cains,

    VirtualBox supports USB, you can try.

    Samiux

  5. #5
    Senior Member
    Join Date
    Jan 2010
    Posts
    126

    Default Re: å›˛č¦†: Problems to get ubertooth up and runing in VMware

    Quote Originally Posted by samiux View Post
    @Cains,

    VirtualBox supports USB, you can try.

    Samiux
    this problem has been reported a few times from what i've seen searching other forums re:ubertooth inside vmware. this may be a good idea,Samiux.

    i'm not running b|t inside a VM and still, there was much *undocumented* work to be done in any setup guide I have seen posted getting it all working properly. I'm not sure something like this should be held to a typical "noob-proof" standard either way. Successfully installing this, getting it to work inside wireshark and kismet are sort of scratching the surface. It's installed and works, but they still probably can't do much with it anyway.

    there is not much discussion/good solid information about LAP/PAN/piconet and bluetooth monitor mode enabled devices on here. or anywhere else. unless you REALLY search.

    just saying.

Similar Threads

  1. Installing the Ubertooth One on BT5
    By HarvestGardener in forum BackTrack 5 How-To's
    Replies: 8
    Last Post: 06-01-2011, 08:59 PM
  2. Replies: 4
    Last Post: 05-18-2011, 03:14 PM
  3. Replies: 2
    Last Post: 07-19-2010, 11:54 AM
  4. Runing before i can walk
    By F4LSE in forum OLD Wireless
    Replies: 7
    Last Post: 05-13-2008, 03:43 PM
  5. Replies: 4
    Last Post: 09-13-2007, 08:33 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •