Results 1 to 9 of 9

Thread: airmon-ng shows nothing

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    2

    Default airmon-ng shows nothing

    when I run the airmon-ng command in backtrack I get nothing under the Interface/Chipset/Driver headings, does that mean my laptops wifi adapter is not compatible? My wifi adapter is a Atheros AR9285 Wireless Network adapter. Do I need to purchase the Alfa AWUS036H? Running backtrack within virtualbox, noober here.

  2. #2
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    1

    Default Riferimento: airmon-ng shows nothing

    Same problem, but it seems that the answer lies in these forums... couldn't find it yet

  3. #3
    Just burned his ISO m111m's Avatar
    Join Date
    Aug 2011
    Posts
    2

    Default Re: airmon-ng shows nothing

    hello

    me too i use BackTrack in laptop and airmon-ng don show any Interface

  4. #4
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    6

    Default AW: airmon-ng shows nothing

    my laptop dont work with airmon-ng, i need to used airmon-zc (an experimental version of airmon-ng)

  5. #5
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    2

    Default Re: airmon-ng shows nothing

    I too am having issues. I have windows 7 on a hp pavillion DV7 and am using both netgears 111t and wn121t. i am getting nothing as well when i run airmon-ng. when i oped up the networking program under backtrack5 i only get wired connection default and it doesnt show any wireless. I had the devices connected but still nothing. do i need to install drivers or do some kind of activation?

  6. #6
    Just burned his ISO
    Join Date
    Oct 2011
    Posts
    6

    Default Re: airmon-ng shows nothing

    I am having this same issue... What did you do to get it to work???

    ~Diosa )O(

  7. #7
    Just burned his ISO
    Join Date
    Nov 2011
    Posts
    3

    Default Re: airmon-ng shows nothing

    Noob here as well (1st post. but i hope it resolves your issue or leads you to the right direction)

    1st-confirm that your chipset/internal wifi adap is compatible with your current version of Backtrack/injection< if your unable to inject you might aswell get a usb ( Alfa AWUS036H )
    2nd- If it is.... Check your vmware settings and make sure it detects your wireless card
    : From my understanding Vmware the internal wifi card is always seen as a wired connection, therefore it would not work, but I may be incorrect < Someone please jump in and correct this if so

  8. #8
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: airmon-ng shows nothing

    Quote Originally Posted by tr4ckfi3nd View Post
    2nd- If it is.... Check your vmware settings and make sure it detects your wireless card
    : From my understanding Vmware the internal wifi card is always seen as a wired connection, therefore it would not work, but I may be incorrect < Someone please jump in and correct this if so
    That pretty much sums up why it isn't working for most of the previous posters. Also, the FAQ clearly states that, and quoting:
    Quote Originally Posted by FAQ
    Any virtualisation software can only use USB wireless network cards as physical devices, all other types of wireless card are seen as virtual ethernet devices and can only be seen as a wireless device by the host and not by the guest operating system. So if you want to run BackTrack in VMWare or Virtualbox and have full wireless capabilities, make sure you are using a USB device.
    Last edited by Snayler; 11-13-2011 at 03:50 PM.

  9. #9
    Just burned his ISO
    Join Date
    Oct 2012
    Posts
    4

    Default Re: airmon-ng shows nothing

    Quote Originally Posted by romdawg View Post
    when I run the airmon-ng command in backtrack I get nothing under the Interface/Chipset/Driver headings, does that mean my laptops wifi adapter is not compatible? My wifi adapter is a Atheros AR9285 Wireless Network adapter. Do I need to purchase the Alfa AWUS036H? Running backtrack within virtualbox, noober here.
    Yep seems to be the prob. that VM doesn't support it. I've been using BT5R3 about 2 weeks from bootable USB and everthing works like a charm, it's actually pretty fast and responsive. Today I downloaded Virtualbox so I can practice more comfortably from Win7 'cos I got sick os switching between OS's escpecially Win7 has to load up its dreadful start up each time. Must say that Virtual Machine is way inferior to USB Boot in every way, but then again you can take snapshots (restore points) in VM so thats handy , but I am still keeping my USB Boot for sure. So down to you problem. I am able to connect to the internet in VM but it doesn't show up as wireless but wired o:O connection, and when I run airmon-ng it's empty compared to when ran in usb boot mode which worked fine and was able to inject also.

Similar Threads

  1. Wireless works but airmon-ng shows no interfaces. Help me out here!
    By dividebyzero in forum BackTrack 5 Beginners Section
    Replies: 2
    Last Post: 08-29-2011, 12:55 PM
  2. Replies: 4
    Last Post: 09-06-2010, 07:48 PM
  3. xor file never shows up
    By LT72884 in forum OLD Wireless
    Replies: 2
    Last Post: 11-06-2008, 04:14 PM
  4. Hacker TV Shows and Video
    By .lonewolf in forum OLD Pentesting
    Replies: 10
    Last Post: 05-14-2008, 12:40 PM
  5. the first ARP (never shows up)
    By trevelyn in forum OLD Newbie Area
    Replies: 14
    Last Post: 02-01-2008, 09:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •