Results 1 to 5 of 5

Thread: Metasploit svn update errors

Hybrid View

  1. #1
    Junior Member
    Join Date
    Jun 2010
    Posts
    28

    Default Metasploit svn update errors

    Hi

    Have just installed BT5, really liking the Gnome version BTW

    I have updated Metasploit with svn up and get the following errors
    Code:
    svn: /opt/framework3/lib/libssl.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
    svn: /opt/framework3/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
    The update still seems to work ok but how can I resolve the errors

    Any help appreciated
    Thanks
    Mark
    There's no place like ~/

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: Metasploit svn update errors

    Try purging framework3 and installing it again.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  3. #3
    Junior Member
    Join Date
    Jun 2010
    Posts
    28

    Default Re: Metasploit svn update errors

    Thanks for that but seems like it is a bug

    http://dev.metasploit.com/redmine/issues/4433
    There's no place like ~/

  4. #4
    Good friend of the forums scottm99's Avatar
    Join Date
    Feb 2010
    Location
    underwater
    Posts
    371

    Default Re: Metasploit svn update errors

    I asked about this issue on the metasploit mailing list not long ago. One of the MSF developers responded to me saying this is occurring because of a recently recompiled version of libcrypto & libssl which strip debugging & version symbols. It's safe to ignore the error. The MSF developer went on to say that a bug report has been filed in the framework tracker to get this fixed in the next release.

    That doesn't really answer your question, but the MSF developers are aware of the problem & will be fixing it.
    If I could figure out how to scuba dive & hack at the same time, there would be nothing I couldn't do...

  5. #5
    Junior Member
    Join Date
    Jun 2010
    Posts
    28

    Default Re: Metasploit svn update errors

    Quote Originally Posted by scottm99 View Post
    I asked about this issue on the metasploit mailing list not long ago. One of the MSF developers responded to me saying this is occurring because of a recently recompiled version of libcrypto & libssl which strip debugging & version symbols. It's safe to ignore the error. The MSF developer went on to say that a bug report has been filed in the framework tracker to get this fixed in the next release.

    That doesn't really answer your question, but the MSF developers are aware of the problem & will be fixing it.
    Thanks for the info but I already found out it was a bug and posted back but as my posts are still moderated even after being a member for a year has not appeared yet and will probably disappear as several have in the past... ho hum
    There's no place like ~/

Similar Threads

  1. metasploit ruby errors?
    By beelzebufo in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 11-01-2011, 05:02 PM
  2. Metasploit errors
    By bk5115545 in forum BackTrack 5 Beginners Section
    Replies: 4
    Last Post: 06-08-2011, 10:23 AM
  3. Replies: 1
    Last Post: 05-07-2011, 01:35 PM
  4. metasploit vbs to .doc errors
    By pentest09 in forum Beginners Forum
    Replies: 3
    Last Post: 09-28-2010, 11:55 PM
  5. Replies: 2
    Last Post: 05-08-2010, 12:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •