Results 1 to 4 of 4

Thread: HP dv8000 - BT5 - KDE - nVidia drive problem

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    2

    Question HP dv8000 - BT5 - KDE - nVidia driver problem

    Hello group,

    I have an HP dv8000 / dv8235nr laptop(http://h10025.www1.hp.com/ewfrf/wc/d...roduct=1843762) trying to run BT5 32bit KDE. I am doing a full install to the HD. This machine is dedicated to BT5/Testing. When I boot off the live CD, I notice that the screen resolution is the max (1440 x 900) and works fine. However, if I do a HD install, the max resolution I can get is 1024x768. So, I tried the Gnome version and I got the same result. When I searched these forums and google, I found out that I needed to download and install the nVidia drivers. The display adapter in this laptop is a NVIDIA GeForce Go 7400.

    So my first attempt, I installed KDE and downloaded the drivers from nVidia. I followed these instructions.(http://www.backtrack-linux.org/forum...deo-cards.html) I ended up getting the driver installed after a couple other steps not mentioned in the article (had to do with prepare-kernel-sources). when I would start X, the system would get through the first three symbols and hang on the fourth. I could never get into X again. I have reinstalled BT532bKDE at least 14 times trying all the different combinations and tips from other searches and I still can not get it to work. If I install Gnome, I can get it to work fine but I prefer KDE.

    I have tried the following command but all failed:
    apt-get install nvidia-driver
    apt-get install nvidia-drivers

    I am at a loss. I am not sure what to do next. I have searched the forums for hours and hours trying everything I can find with no success.



    I have tried the following articles:

    http://www.backtrack-linux.org/forum...glx-error.html

    http://www.backtrack-linux.org/forum...t-upgrade.html

    http://www.backtrack-linux.org/forum...tallation.html

    http://www.backtrack-linux.org/forum...wont-work.html
    Last edited by d1g1tal; 07-19-2011 at 08:57 PM. Reason: bad spelling

  2. #2
    Just burned his ISO
    Join Date
    Jul 2011
    Location
    Jakarta
    Posts
    5

    Lightbulb Re: HP dv8000 - BT5 - KDE - nVidia drive problem

    1. Prepare the kernel source to install the driver with a terminal code:

    Code:
    apt-get install linux-source-2.6.38
    Code:
    prepare-kernel-source
    Code:
    cd /usr/src/linux
    Code:
    cp -rf include/generated/* include/linux/
    2. NVidia driver installation file can be downloaded at:

    http://www.nvidia.com/object/unix.html

    Then save it to /root

    3. Change the file permissions on the installation of nvidia drivers with the command:

    Code:
    chmod +x [file_name]
    4. Turn off the kernel Nouveau by opening the file
    Code:
    nano /boot/grub/grub.cfg
    then enter the parameters of your BackTrack boot options:
    Code:
    nouveau.modeset=0
    5. Reboot

    6. Do not start X [startx], run the installation file before X starts.

    7. Then type this command in the CLI:
    Code:
    ./[driver_installer]. run --kernel-source-path='/usr/src/linux'
    8. Follow the installation instructions.

    9. reboot

    10. Your nVidia you already to use, and your BackTrack can play Compiz.

    Reply if this not work for you. Sorry for my bad English

  3. #3
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    2

    Default

    alfa47,

    Thank you for your reply. I first reinstalled BT5 to make sure I was starting from the beginning. Then I followed your instructions exactly, step by step. My result is the same. I end up at the X screen with a "loading..." and 4 symbols. The first three are white and the last one is red. The system just hangs there. I do notice that when I start X, I see a big nVidia logo flash on the screen very fast. I do not know what to do from here. Are there any files I can check for errors?

    d1g1tal

    I replied to this message once but I don't see it here. In a nutshell, I reinstalled BT5 and followed your directions exactly but I had the same result. Is there anything I can check for errors to give me more information on whats going on?

    BTW, your English is perfect! Thanx for your help.

    Edit:

    Ok, I tried these instructions (http://www.backtrack-linux.org/forum...ia-driver.html) and it seemed to get a little further. This time, I got the start sound where I did not get that before. It still sits there on the "loading..." screen with the 4 Asian symbols. Can someone tell me what those mean? The system is stuck on the last symbol. Are there any logs I can check to see what is happening?

    thanx
    Last edited by sickness; 07-26-2011 at 11:32 AM.

  4. #4
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: HP dv8000 - BT5 - KDE - nVidia drive problem

    Wiki:Basic_Usage#X_wont_start.21

    Might help regarding your startx issue.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

Similar Threads

  1. NVIDIA driver problem
    By noniboy in forum Beginners Forum
    Replies: 1
    Last Post: 12-20-2010, 12:20 PM
  2. Nvidia X-server Problem
    By ReaperX180X in forum Beginners Forum
    Replies: 2
    Last Post: 12-19-2010, 10:27 PM
  3. HP Pavilion dv8000
    By dvlchd3 in forum OLD BackTrack 4 Working Hardware
    Replies: 3
    Last Post: 11-01-2009, 01:29 PM
  4. Nvidia problem
    By Lasperic in forum OLD Bt4beta Non-Working Hardware
    Replies: 6
    Last Post: 05-12-2009, 01:08 PM
  5. BT3 Nvidia Graphics Problem
    By seth_slade in forum OLD BT3beta General
    Replies: 2
    Last Post: 06-03-2008, 04:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •