I'm trying to install flash player but since I'm a super newbie in both linux and backtrack I failed.
I tried to download it by apturl by the link(apt:adobe-flashplugin?channel=$distro-partner) they porvided but it says "The channel '-partner' is not known"(don't know what it says actually)
I tried the .rpm by alien, but again failed.
Then I found this topic:
Backtrack 5 - How to get flash player working on Gnome / KDE x64
I did it half way(not sure I did it correct, since I didn't get any response from the rm commands), then I realized that adobe has stopped supporting the square and the link redirects to the flash player 11 beta. I tried to install it with the commands in the topic (tar xvfz and mv -f) but then again I couldn't use it in firefox.

Can anyone help me?

I think we need a new how to for installing it.
Thanks