Results 1 to 5 of 5

Thread: BT5 Updating Sqlmap - authentication error

  1. #1
    Just burned his ISO
    Join Date
    Dec 2010
    Posts
    23

    Default BT5 Updating Sqlmap - authentication error

    Hi all,

    I've seen several people raising this issue, but so far none of the suggested solutions have resolved it for me, so I'm opening this thread in the hope of getting this resolved. Any help would be much appreciated.

    Sqlmap on BT5 produced an error so I removed it, deleted the sqlmap folder and reinstalled it. Whenever I run an update, via either svn up or the excellent script by sickness (0.6) it starts to update then provides the following error:

    svn: OPTIONS of 'https://svn.sqlmap.org/sqlmap': authorization failed: Could not authenticate to server: rejected Digest challenge (https://svn.sqlmap.org)
    [>] Failed to update SQLmap.


    If I then try and run sqlmap.py I get the following error, that I can only clear if I remove and reinstall (and don't attempt to update it):

    Traceback (most recent call last):
    File "./sqlmap.py", line 27, in <module>
    from lib.controller.controller import start
    File "/pentest/database/sqlmap/lib/controller/controller.py", line 13, in <module>
    from lib.controller.action import action
    File "/pentest/database/sqlmap/lib/controller/action.py", line 10, in <module>
    from lib.controller.handler import setHandler
    File "/pentest/database/sqlmap/lib/controller/handler.py", line 27, in <module>
    from plugins.dbms.mssqlserver import MSSQLServerMap
    File "/pentest/database/sqlmap/plugins/dbms/mssqlserver/__init__.py", line 14, in <module>
    from plugins.dbms.mssqlserver.enumeration import Enumeration
    File "/pentest/database/sqlmap/plugins/dbms/mssqlserver/enumeration.py", line 28, in <module>
    from plugins.generic.enumeration import Enumeration as GenericEnumeration
    File "/pentest/database/sqlmap/plugins/generic/enumeration.py", line 34, in <module>
    from lib.core.common import singleTimeWarnMessage
    ImportError: cannot import name singleTimeWarnMessage


    Again, any help would be appreciated and sorry if this is 'yet another thread' but I can't find a solution so far.

    Regards

  2. #2
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    1

    Default Re: BT5 Updating Sqlmap - authentication error

    Great post! It's very nicẹ Thank you so much for your post

  3. #3
    Senior Member
    Join Date
    Jan 2010
    Posts
    126

    Default Re: BT5 Updating Sqlmap - authentication error

    I did not look at other solutions suggested in other threads, but I was able to replicate your problem and easily fix it on my own local system. I had not yet used sickness' v 0.6 script revision and had not noticed this error. i updated the script (from v0.4) and encountered exactly the same result you have posted. i did not attempt using svn, so i am not in any way ungratefully suggesting it is a problem within the script; as you already tried it both ways. i also did not check if sickness' script at v0.6 attempts to update to some higher version number than sqlmap 0.9.

    that being said...an easy fix. download the tar.gz of sqlmap 0.9 from http://sqlmap.sourceforge.net
    tar -zxvf it onto the desktop. copy the sqlmap folder into correct pentest dirs and overwrite/merge the files.

    voila. works again

    sqlmap/0.9 - automatic SQL injection and database takeover tool
    http://sqlmap.sourceforge.net

    Usage: python ./sqlmap.py [options]

    Options:
    --version show program's version number and exit
    -h, --help show this help message and exit
    -v VERBOSE Verbosity level: 0-6 (default 1)

    Target:
    At least one of these options has to be specified to set the source to
    get target urls from.

    -d DIRECT Direct connection to the database
    -u URL, --url=URL Target url
    -l LIST Parse targets from Burp or WebScarab proxy logs
    -r REQUESTFILE Load HTTP request from a file
    -g GOOGLEDORK Process Google dork results as target urls
    -c CONFIGFILE Load options from a configuration INI file

    etc. hope this helps you.

  4. #4
    Just burned his ISO
    Join Date
    Dec 2010
    Posts
    23

    Default Re: BT5 Updating Sqlmap - authentication error

    Thanks for the update.

    I've 'worked around' it in that I can put a fresh install on and use it. However I'd like to be able to update it every few days, and can't as any attempt results in the authentication realm error and a corrupt sqlmap.

  5. #5
    Just burned his ISO
    Join Date
    Jul 2011
    Location
    Nottinghamshire, UK
    Posts
    2

    Default Re: BT5 Updating Sqlmap - authentication error

    I had the same issue. I removed the BT5 version on sqlmap and downloaded the 0.9 from sourceforge.

    Issue the command
    HTML Code:
    python sqlmap.py --update
    updates without issue.

Similar Threads

  1. Bad password error when validating authentication in WICD
    By AlfaNinja in forum BackTrack 5 Beginners Section
    Replies: 6
    Last Post: 09-22-2012, 02:35 AM
  2. Error Updating Msf
    By billyONair in forum Beginners Forum
    Replies: 0
    Last Post: 03-21-2011, 11:50 PM
  3. Error updating kernel 2.6.34
    By StasNep in forum Beginners Forum
    Replies: 10
    Last Post: 10-18-2010, 03:09 AM
  4. updating MSF3 from repository SVN error fix
    By dustyboner in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 0
    Last Post: 11-23-2009, 12:46 PM
  5. bug - updating kdelibs creates error!!!
    By thont in forum OLD BT3beta Software related issues
    Replies: 2
    Last Post: 05-27-2008, 09:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •