Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Repository issue? apt-get update fails

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    2

    Default Repository issue? apt-get update fails

    I'm getting a bunch of weird errors with 64.repository.backtrack-linux.org, all.repository..., and source.repository...

    apt-get update fails, goes through and Ign a bunch of URLs and then the last few lines say "failed to fetch http://64.repository..."

    nslookup resolves the backtrack-url.org hostname just fine and I can browse the site. Any thoughts?

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: Repository issue? apt-get update fails

    Everything works here:

    Code:
    root@bt:~# apt-get update
    Hit http://source.repository.backtrack-linux.org revolution Release.gpg                   
    Ign http://source.repository.backtrack-linux.org/ revolution/main Translation-en_US        
    Hit http://64.repository.backtrack-linux.org revolution Release.gpg                        
    Ign http://64.repository.backtrack-linux.org/ revolution/main Translation-en_US            
    Hit http://all.repository.backtrack-linux.org revolution Release.gpg                       
    Ign http://all.repository.backtrack-linux.org/ revolution/main Translation-en_US           
    Hit http://ppa.launchpad.net lucid Release                           
    Ign http://source.repository.backtrack-linux.org/ revolution/microverse Translation-en_US  
    Ign http://source.repository.backtrack-linux.org/ revolution/non-free Translation-en_US    
    Ign http://source.repository.backtrack-linux.org/ revolution/testing Translation-en_US
    Hit http://source.repository.backtrack-linux.org revolution Release                        
    Ign http://64.repository.backtrack-linux.org/ revolution/microverse Translation-en_US      
    Ign http://64.repository.backtrack-linux.org/ revolution/non-free Translation-en_US
    Ign http://64.repository.backtrack-linux.org/ revolution/testing Translation-en_US
    Hit http://64.repository.backtrack-linux.org revolution Release      
    Ign http://all.repository.backtrack-linux.org/ revolution/microverse Translation-en_US
    Ign http://all.repository.backtrack-linux.org/ revolution/non-free Translation-en_US
    Ign http://all.repository.backtrack-linux.org/ revolution/testing Translation-en_US
    Hit http://all.repository.backtrack-linux.org revolution Release
    Hit http://ppa.launchpad.net lucid/main Packages                                           
    Hit http://source.repository.backtrack-linux.org revolution/main Packages
    Hit http://64.repository.backtrack-linux.org revolution/main Packages
    Hit http://all.repository.backtrack-linux.org revolution/main Packages
    Hit http://source.repository.backtrack-linux.org revolution/microverse Packages
    Hit http://source.repository.backtrack-linux.org revolution/non-free Packages
    Hit http://source.repository.backtrack-linux.org revolution/testing Packages
    Hit http://64.repository.backtrack-linux.org revolution/microverse Packages
    Hit http://64.repository.backtrack-linux.org revolution/non-free Packages
    Hit http://64.repository.backtrack-linux.org revolution/testing Packages
    Hit http://all.repository.backtrack-linux.org revolution/microverse Packages
    Hit http://all.repository.backtrack-linux.org revolution/non-free Packages
    Hit http://all.repository.backtrack-linux.org revolution/testing Packages
    Reading package lists... Done
    root@bt:~#
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  3. #3
    Member shadowzero's Avatar
    Join Date
    Jun 2011
    Location
    ${HOME}
    Posts
    94

    Default Re: Repository issue? apt-get update fails

    I've encountered this when the environment variable http_proxy is incorrectly set. Do you have it set by any chance, and if so, what is it?

  4. #4
    Just burned his ISO
    Join Date
    May 2011
    Posts
    1

    Default Re: Repository issue? apt-get update fails

    I am having the same issue. Whereas previously I was perfectly able to do an apt-get update and an apt-get upgrade I cannot now seem to get any response.

    • BT 5
    • GNOME
    • 32 Bit
    • Dual-boot with Win 7


    The error I see on scree is:

    Code:
    root@bt:~# apt-get update
    Get:1 http://source.repository.backtrack-linux.org revolution Release.gpg [197B]
    Get:2 http://all.repository.backtrack-linux.org revolution Release.gpg [197B] 
    Get:3 http://32.repository.backtrack-linux.org revolution Release.gpg [197B]  
    Ign http://32.repository.backtrack-linux.org/ revolution/main Translation-en_US
    Ign http://all.repository.backtrack-linux.org/ revolution/main Translation-en_US
    Ign http://source.repository.backtrack-linux.org/ revolution/main Translation-en_US
    Ign http://32.repository.backtrack-linux.org/ revolution/microverse Translation-en_US
    Ign http://all.repository.backtrack-linux.org/ revolution/microverse Translation-en_US
    Ign http://source.repository.backtrack-linux.org/ revolution/microverse Translation-en_US
    Ign http://32.repository.backtrack-linux.org/ revolution/non-free Translation-en_US
    Ign http://all.repository.backtrack-linux.org/ revolution/non-free Translation-en_US
    Ign http://source.repository.backtrack-linux.org/ revolution/non-free Translation-en_US
    Ign http://32.repository.backtrack-linux.org/ revolution/testing Translation-en_US
    Get:4 http://32.repository.backtrack-linux.org revolution Release [5,041B]
    Err http://32.repository.backtrack-linux.org revolution Release               
      
    Ign http://all.repository.backtrack-linux.org/ revolution/testing Translation-en_US
    Get:5 http://all.repository.backtrack-linux.org revolution Release [13.5kB]
    Ign http://source.repository.backtrack-linux.org/ revolution/testing Translation-en_US
    Get:6 http://source.repository.backtrack-linux.org revolution Release [13.5kB]
    Err http://all.repository.backtrack-linux.org revolution Release
      
    Err http://source.repository.backtrack-linux.org revolution Release
      
    Fetched 594B in 1s (453B/s)
    Reading package lists... Done
    W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://32.repository.backtrack-linux.org revolution Release: The following signatures were invalid: BADSIG AB6DA34B475A6B7F BackTrack Repository Admin <emgent@backtrack-linux.org>
    
    W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://all.repository.backtrack-linux.org revolution Release: The following signatures were invalid: BADSIG AB6DA34B475A6B7F BackTrack Repository Admin <emgent@backtrack-linux.org>
    
    W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://source.repository.backtrack-linux.org revolution Release: The following signatures were invalid: BADSIG AB6DA34B475A6B7F BackTrack Repository Admin <emgent@backtrack-linux.org>
    
    W: Failed to fetch http://source.repository.backtrack-linux.org/dists/revolution/Release  
    
    W: Failed to fetch http://all.repository.backtrack-linux.org/dists/revolution/Release  
    
    W: Failed to fetch http://32.repository.backtrack-linux.org/dists/revolution/Release  
    
    W: Some index files failed to download, they have been ignored, or old ones used instead.
    root@bt:~#
    Can anyone help me understand why this is happening?

    Thanks!

  5. #5
    Just burned his ISO
    Join Date
    Jun 2012
    Posts
    2

    Default Re: Repository issue? apt-get update fails

    I just got the error today.

    W: GPG error: http://all.repository.backtrack-linux.org revolution Release: The following signatures were invalid: BADSIG AB6DA34B475A6B7F BackTrack Repository Admin <emgent@backtrack-linux.org>

    Tried http://www.ubuntugeek.com/how-to-fix...or-badsig.html but no joy.

    Please advise.

  6. #6
    Good friend of the forums scottm99's Avatar
    Join Date
    Feb 2010
    Location
    underwater
    Posts
    371

    Default Re: Repository issue? apt-get update fails

    I just did an apt-get update & apt-get upgrade...no problems for me.
    If I could figure out how to scuba dive & hack at the same time, there would be nothing I couldn't do...

  7. #7
    Just burned his ISO
    Join Date
    Jun 2012
    Posts
    2

    Default Re: Repository issue? apt-get update fails

    I'm still having problem on update. Do I need to import new key to work? If so, how can I accomplish?

  8. #8
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Repository issue? apt-get update fails

    See if you are behind a proxy...If so, you need to modify the apt....

  9. #9
    Just burned their ISO
    Join Date
    Aug 2011
    Posts
    2

    Default Re: Repository issue? apt-get update fails

    Quote Originally Posted by maverik35 View Post
    See if you are behind a proxy...If so, you need to modify the apt....
    sorry i had to bump this old thread but im having a similar problem where i cant update or upgrade my BT..
    Code:
    root@bt:~# apt-get upgrade
    Reading package lists... Error!
    E: Dynamic MMap ran out of room. Please increase the size of APT::Cache-Limit. Current value: 25165824. (man 5 apt.conf)
    E: Error occurred while processing libmp3splt-ogg (NewVersion1)
    E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-i386_Packages
    W: Unable to munmap
    E: The package lists or status file could not be parsed or opened.
    and also i cannot open synaptic package manager or update manager.. what had happen actually?

    here is my SS:
    Screenshot-Untitled Window.jpg

    Screenshot-Untitled Window-1.jpg

    thanx in advance.

  10. #10
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Repository issue? apt-get update fails

    Quote Originally Posted by xxxlisxxx View Post
    sorry i had to bump this old thread but im having a similar problem where i cant update or upgrade my BT..
    Code:
    root@bt:~# apt-get upgrade
    Reading package lists... Error!
    E: Dynamic MMap ran out of room. Please increase the size of APT::Cache-Limit. Current value: 25165824. (man 5 apt.conf)
    E: Error occurred while processing libmp3splt-ogg (NewVersion1)
    E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-i386_Packages
    W: Unable to munmap
    E: The package lists or status file could not be parsed or opened.
    and also i cannot open synaptic package manager or update manager.. what had happen actually?

    here is my SS:
    Screenshot-Untitled Window.jpg

    Screenshot-Untitled Window-1.jpg

    thanx in advance.
    Clean up your folder /var/cache/apt/archives: aptitude clean
    and then aptitude autoclean..

    This will wipe all .deb packages dowloaded and installed in your system. IT will keep growing so you need to clean it every once in a while. Use aptitude instead of apt-get..It is more powerfull.

    Then: aptitude update

    Hope it helps..

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 5
    Last Post: 05-22-2011, 05:27 AM
  2. Kernel update fails
    By MDDeff in forum Beginners Forum
    Replies: 2
    Last Post: 06-07-2010, 09:19 AM
  3. apt-get update fails
    By newbieal in forum Beginners Forum
    Replies: 2
    Last Post: 05-14-2010, 03:37 AM
  4. Replies: 18
    Last Post: 01-26-2010, 06:09 PM
  5. BT3 and Parallels IV Update issue
    By _wishi_ in forum OLD Newbie Area
    Replies: 0
    Last Post: 12-04-2008, 11:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •