Results 1 to 2 of 2

Thread: kismet - no go. prism2 card. (2511 plus ext2)

  1. #1
    Junior Member
    Join Date
    May 2007
    Posts
    37

    Default kismet - no go. prism2 card. (2511 plus ext2)

    i recently bought myself a senao 2511 plus ext2 card and i can use it but only with the newest version of airoscript.

    if i try to use the Wlassistant (kde program) and i select wlan0 then do a refresh it says Nothing found.
    if i try to run kismet with the start-kismet script i select wlan0 and then get a long error however i managed to memorize this line:

    WARNING: wifi0 appears to not accept the Madwifi-NG controls. Will attempt to configure it as a standard Madwifi-old interface. If you are using madwifi-ng, be sure to set the source interface to the wifiX control interface, NOT athX

    i know this isnt an athX card. I have all my hostap_cs loaded.
    I added the orinoco, orinoco_cs to the blacklist file and like i said airoscript works but kismet and the wlassistant dont.

    my iwconfig looks like this:

    Code:
    lo        no wireless extensions.
    
    wifi0     IEEE 802.11b  ESSID:"test"  Nickname:""
              Mode:Monitor  Frequency:2.457 GHz  Access Point: Not-Associated
              Bit Rate:11 Mb/s   Sensitivity=1/3
              Retry limit:8   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
    
    wlan0     IEEE 802.11b  ESSID:"test"  Nickname:""
              Mode:Monitor  Frequency:2.457 GHz  Access Point: Not-Associated
              Bit Rate:11 Mb/s   Sensitivity=1/3
              Retry limit:8   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=0/70  Signal level=-73 dBm  Noise level=-73 dBm
              Rx invalid nwid:0  Rx invalid crypt:176  Rx invalid frag:0
              Tx excessive retries:24  Invalid misc:370721   Missed beacon:0
    
    eth0      IEEE 802.11g  ESSID:"TwoCows"
              Mode:Managed  Frequency:2.437 GHz  Access Point: 00:15:E9:42:9C:0C
              Bit Rate:54 Mb/s   Tx-Power:15 dBm
              Retry limit:15   RTS thr:off   Fragment thr:off
              Encryption key:6666-6666-66   Security mode:open
              Power Management:off
              Link Quality=61/100  Signal level=-73 dBm  Noise level=-77 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:2497   Missed beacon:0
    i also edited my /etc/pcmcia/config file and changed every word that says orinoco to hostap


    any help is greatly appreciated!

  2. #2
    Senior Member PrairieFire's Avatar
    Join Date
    Apr 2007
    Posts
    705

    Default

    Have you tried to do it manually then start kismet?

    This method works for mine:

    Code:
    pccardctl eject
    rmmod orinoco_cs
    rmmod orinoco
    rmmod hermes
    modprobe hostap_cs
    pccardctl insert
    then
    Code:
    start-kismet-ng
    also
    source=hostap,wlan0,Prism2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •