Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Problem with apt-get upgrade

  1. #11
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    10

    Default Re: Problem with apt-get upgrade

    Quote Originally Posted by KMDave View Post
    Code:
    ps -ef | grep postgres
    kill -9 <processnumber>
    Code:
    postgres  1080     1  0 Jul11 ?        00:00:00 /opt/framework3/postgresql/bin/postgres -D /opt/framework3/postgresql/data -p 7175
    postgres  1089  1080  0 Jul11 ?        00:00:15 postgres: writer process                                                          
    postgres  1090  1080  0 Jul11 ?        00:00:11 postgres: wal writer process                                                      
    postgres  1091  1080  0 Jul11 ?        00:00:02 postgres: autovacuum launcher process                                             
    postgres  1092  1080  0 Jul11 ?        00:00:01 postgres: stats collector process                                                 
    root     12742 12717  0 20:05 pts/0    00:00:00 grep --color=auto postgres
    this is what i get with the
    Code:
    ps -ef | grep postgres
    how do i know which number to kill?

  2. #12
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    10

    Default Re: Problem with apt-get upgrade

    ok nvm i manged to figure out how to kill the postgres process and it seems to have fixed the problem with apt-get upgrade. thx for the help.

    However i am still getting this shit in the terminal every time i install something which even though seems harmless is really annoying me.

    Setting up framework3 (3.7.2-bt0) ...
    chmod: cannot access `framework-32.bin': No such file or directory
    /var/lib/dpkg/info/framework3.postinst: line 11: ./framework-32.bin: No such file or directory
    cp: cannot stat `mysql-2.8.1': No such file or directory
    Building native extensions. This could take a while...
    Successfully installed mysql-2.8.1
    1 gem installed
    Installing ri documentation for mysql-2.8.1...
    Installing RDoc documentation for mysql-2.8.1...
    cp: cannot create directory `/opt/framework3/ruby/lib/ruby/gems/1.9.1/gems/': No such file or directory
    mv: cannot move `/usr/src/IMPORTANT-README' to `/pentest/exploits/framework3/': Not a directory
    dpkg: error processing framework3 (--configure):
    subprocess installed post-installation script returned error exit status 1
    Setting up libgimp2.0 (2.6.8-2ubuntu1.3) ...

    Setting up gimp-data (2.6.8-2ubuntu1.3) ...
    Setting up libbabl-0.0-0 (0.0.22-1build1) ...

    Setting up libgegl-0.0-0 (0.0.22-0ubuntu4) ...

    Setting up gimp (2.6.8-2ubuntu1.3) ...

    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    Processing triggers for menu ...
    Errors were encountered while processing:
    framework3
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  3. #13
    Just burned his ISO
    Join Date
    May 2011
    Posts
    2

    Default Re: Problem with apt-get upgrade

    hey guys, I followed your advices but still the same problem. Here is what I did:

    Code:
    apt-get purge framework3
    Code:
    rm -rf /opt/framework3/
    making sure I killed postgres
    Code:
    root@bt:~# ps -ef | postgres
    No command 'postgres' found, did you mean:
     Command 'postgrey' from package 'postgrey' (universe)
    postgres: command not found
    Code:
     apt-get autoclean
    then install framework3 (without restaring BT5)
    Code:
    root@bt:~# apt-get install framework3
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libdmraid1.0.0.rc16 sqlite python-pyicu libdebian-installer4 cryptsetup
      libecryptfs0 reiserfsprogs rdate bogl-bterm ettercap-gtk ecryptfs-utils
      libdebconfclient0 dmraid ettercap-common
    Use 'apt-get autoremove' to remove them.
    The following NEW packages will be installed:
      framework3
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 145MB of archives.
    After this operation, 0B of additional disk space will be used.
    Get:1 http://32.repository.backtrack-linux.org/ revolution/testing framework3 3.7.2-bt0 [145MB]
    Fetched 145MB in 2min 34s (943kB/s)                                            
    Selecting previously deselected package framework3.
    (Reading database ... 221605 files and directories currently installed.)
    Unpacking framework3 (from .../framework3_3.7.2-bt0_i386.deb) ...
    /etc/init.d/framework-postgres: line 6: /opt/framework3/postgresql/scripts/ctl.sh: No such file or directory
    /etc/init.d/framework-postgres: line 6: exec: /opt/framework3/postgresql/scripts/ctl.sh: cannot execute: No such file or directory
    Processing triggers for desktop-file-utils ...
    Processing triggers for python-gmenu ...
    Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
    Processing triggers for python-support ...
    Setting up framework3 (3.7.2-bt0) ...
    There has been an error.
    Error running su postgres -c '"/opt/framework3/postgresql/bin/psql"  -c "ALTER USER postgres PASSWORD '\''330a02ac'\''" ' : psql.bin: could not connect to server: Connection refused
    	Is the server running on host "localhost" and accepting
    	TCP/IP connections on port 7175?
    could not connect to server: Connection refused
    	Is the server running on host "localhost" and accepting
    	TCP/IP connections on port 7175?
    cp: cannot create directory `/opt/framework3/ruby/lib/ruby/gems/1.9.1/gems/': No such file or directory
    Building native extensions.  This could take a while...
    Successfully installed mysql-2.8.1
    1 gem installed
    Installing ri documentation for mysql-2.8.1...
    Installing RDoc documentation for mysql-2.8.1...
    cp: cannot create directory `/opt/framework3/ruby/lib/ruby/gems/1.9.1/gems/': No such file or directory
    mv: cannot move `/usr/src/IMPORTANT-README' to `/pentest/exploits/framework3/': Not a directory
    dpkg: error processing framework3 (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     framework3
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    and ends with same error as SkyZD

  4. #14
    Just burned his ISO StupidCrows's Avatar
    Join Date
    May 2011
    Location
    A dark basement somewhere
    Posts
    8

    Default Re: Problem with apt-get upgrade

    Quote Originally Posted by SkyZD View Post
    ok nvm i manged to figure out how to kill the postgres process and it seems to have fixed the problem with apt-get upgrade. thx for the help.

    However i am still getting this shit in the terminal every time i install something which even though seems harmless is really annoying me.
    try
    Code:
    dpkg -i –force-overwrite framework3
    apt-get -f install

  5. #15
    Senior Member cgelici's Avatar
    Join Date
    Feb 2010
    Location
    /root
    Posts
    121

    Default Re: Problem with apt-get upgrade

    try
    Code:
    reinstall backtrack

  6. #16
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    1

    Default Re: Problem with apt-get upgrade

    I'm having the same issue. I've tried all the suggested workarounds in this thread, along with reinstalling BackTrack.

  7. #17
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    2

    Default Re: Problem with apt-get upgrade

    This worked for me:

    1) After a fresh install of BT5 KDE 32, first prevent apt-get to upgrade framework3:
    Code:
    echo "framework3 hold" |dpkg --set-selections
    2) Then upgrade everything else:
    Code:
    apt-get update && apt-get dist-upgrade
    3) At last, upgrade metasploit3:
    Code:
    msfupdate
    Hope this helps.

  8. #18
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    2

    Default Re: Problem with apt-get upgrade

    Replied to thread already, didn't appear, here it is again.

    This worked for me:

    1) After a fresh installation of BT5 KDE 32Bit, prevent apt to update metasploit by:
    Code:
    echo "framework3 hold" | dpkg --set-selections
    2) Upgrade all packages except metasploit
    Code:
    apt-get update && apt-get dist-upgrade
    3) Update metasploit
    Code:
    msfupdate
    Hope this helps.

  9. #19
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    10

    Default Re: Problem with apt-get upgrade

    Quote Originally Posted by StupidCrows View Post
    try
    Code:
    dpkg -i –force-overwrite framework3
    apt-get -f install
    Heres output from
    Code:
    dpkg -i –force-overwrite framework3
    dpkg: error processing –force-overwrite (--install):
    cannot access archive: No such file or directory
    dpkg: error processing framework3 (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    –force-overwrite
    framework3

    and
    Code:
    apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    libterm-readline-gnu-perl libdmraid1.0.0.rc16 sqlite python-pyicu
    libdebian-installer4 cryptsetup libecryptfs0 reiserfsprogs rdate bogl-bterm
    ettercap-gtk ecryptfs-utils libdebconfclient0 dmraid linux-source-2.6.38
    ettercap-common
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
    1 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Setting up framework3 (3.7.2-bt0) ...
    chmod: cannot access `framework-32.bin': No such file or directory
    /var/lib/dpkg/info/framework3.postinst: line 11: ./framework-32.bin: No such file or directory
    cp: cannot stat `mysql-2.8.1': No such file or directory
    Building native extensions. This could take a while...
    Successfully installed mysql-2.8.1
    1 gem installed
    Installing ri documentation for mysql-2.8.1...
    Installing RDoc documentation for mysql-2.8.1...
    cp: cannot create directory `/opt/framework3/ruby/lib/ruby/gems/1.9.1/gems/': No such file or directory
    mv: cannot move `/usr/src/IMPORTANT-README' to `/pentest/exploits/framework3/': Not a directory
    dpkg: error processing framework3 (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    framework3
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  10. #20
    Just burned his ISO
    Join Date
    Jun 2009
    Location
    Lebanon
    Posts
    6

    Default Same Problem Here

    same problem!!! tried everything didn't work!!

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. SET upgrade problem
    By t0b1as in forum BackTrack 5 Beginners Section
    Replies: 4
    Last Post: 02-10-2012, 11:45 AM
  2. problem with openvas after upgrade
    By l1nu$ in forum Beginners Forum
    Replies: 17
    Last Post: 04-10-2011, 04:33 PM
  3. Upgrade problem
    By YairNava in forum Beginners Forum
    Replies: 1
    Last Post: 10-02-2010, 02:17 AM
  4. Another 2.6.34 upgrade problem...
    By RawShark in forum Beginners Forum
    Replies: 1
    Last Post: 08-01-2010, 07:32 AM
  5. Replies: 0
    Last Post: 11-17-2009, 09:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •