Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Problem with apt-get upgrade

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    3

    Default Problem with apt-get upgrade

    Here is the problem and how to solve it......

    Code:
    apt-get upgrade
    Reading package lists... Done                                                                                                                                     
    Building dependency tree                                                                                                                                          
    Reading state information... Done                                                                                                                                 
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up framework3 (3.7.2-bt0) ...
    chmod: cannot access `framework-32.bin': No such file or directory
    /var/lib/dpkg/info/framework3.postinst: line 11: ./framework-32.bin: No such file or directory
    cp: cannot stat `mysql-2.8.1': No such file or directory
    Building native extensions.  This could take a while...
    Successfully installed mysql-2.8.1
    1 gem installed
    Installing ri documentation for mysql-2.8.1...
    Installing RDoc documentation for mysql-2.8.1...
    cp: cannot create directory `/opt/framework3/ruby/lib/ruby/gems/1.9.1/gems/': No such file or directory
    mv: cannot move `/usr/src/IMPORTANT-README' to `/pentest/exploits/framework3/': Not a directory
    dpkg: error processing framework3 (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     framework3
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  2. #2
    Senior Member cgelici's Avatar
    Join Date
    Feb 2010
    Location
    /root
    Posts
    121

    Default Re: Problem with apt-get upgrade

    Try removing/purging and re-installing framework3...

  3. #3
    Junior Member M00kaw's Avatar
    Join Date
    Oct 2010
    Location
    127.0.0.1
    Posts
    47

    Default Re: Problem with apt-get upgrade

    Remember to rm -rf all /framework3 folders.
    Find them with : locate framework3

  4. #4
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    10

    Default Re: Problem with apt-get upgrade

    didn't work for me ;(


    'Did you purge all framework3 and the folders ?'

    Yes
    Last edited by SkyZD; 07-11-2011 at 05:07 PM.

  5. #5
    Junior Member M00kaw's Avatar
    Join Date
    Oct 2010
    Location
    127.0.0.1
    Posts
    47

    Default Re: Problem with apt-get upgrade

    SkyZD - what didn't work ?

    Did you purge all framework3 and the folders ?

  6. #6
    Just burned his ISO
    Join Date
    May 2011
    Posts
    2

    Default Re: Problem with apt-get upgrade (and framework3)

    Hello
    I have the same problem.. I purged framework3, located framework3 files/folders and removed them (rm -rf). Some files though where 'located' even after their removal:

    Code:
    root@bt:~# locate framework3
    /opt/framework3
    /pentest/exploits/framework3
    /usr/share/applications/backtrack-framework3-armitage.desktop
    /usr/share/applications/backtrack-framework3-msfcli.desktop
    /usr/share/applications/backtrack-framework3-msfconsole.desktop
    /usr/share/applications/backtrack-framework3-msfencode.desktop
    /usr/share/applications/backtrack-framework3-msfpayload.desktop
    /usr/share/applications/backtrack-framework3-msfupdate.desktop
    /var/lib/dpkg/info/framework3.changelog
    /var/lib/dpkg/info/framework3.copyright
    /var/lib/dpkg/info/framework3.list
    /var/lib/dpkg/info/framework3.postinst
    /var/lib/dpkg/info/framework3.preinst

    then I restarted BT5 and then reinstalled framework3 and here is the output:
    Code:
    root@bt:~# apt-get install framework3
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libdmraid1.0.0.rc16 sqlite python-pyicu libdebian-installer4 cryptsetup libecryptfs0 reiserfsprogs rdate bogl-bterm ettercap-gtk ecryptfs-utils
      libdebconfclient0 dmraid ettercap-common
    Use 'apt-get autoremove' to remove them.
    The following NEW packages will be installed:
      framework3
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B/145MB of archives.
    After this operation, 0B of additional disk space will be used.
    Selecting previously deselected package framework3.
    (Reading database ... 218018 files and directories currently installed.)
    Unpacking framework3 (from .../framework3_3.7.2-bt0_i386.deb) ...
    /opt/framework3/postgresql/scripts/ctl.sh : postgresql not running
    Processing triggers for desktop-file-utils ...
    Processing triggers for python-gmenu ...
    Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
    Processing triggers for python-support ...
    Setting up framework3 (3.7.2-bt0) ...
    There has been an error.
    Error running su postgres -c '"/opt/framework3/postgresql/bin/psql"  -c "ALTER USER postgres PASSWORD '\''cb2e0aea'\''" ' : psql.bin: could not connect to server: Connection refused
    	Is the server running on host "localhost" and accepting
    	TCP/IP connections on port 7175?
    could not connect to server: Connection refused
    	Is the server running on host "localhost" and accepting
    	TCP/IP connections on port 7175?
    cp: cannot create directory `/opt/framework3/ruby/lib/ruby/gems/1.9.1/gems/': No such file or directory
    Building native extensions.  This could take a while...
    Successfully installed mysql-2.8.1
    1 gem installed
    Installing ri documentation for mysql-2.8.1...
    Installing RDoc documentation for mysql-2.8.1...
    cp: cannot create directory `/opt/framework3/ruby/lib/ruby/gems/1.9.1/gems/': No such file or directory
    mv: cannot move `/usr/src/IMPORTANT-README' to `/pentest/exploits/framework3/': Not a directory
    dpkg: error processing framework3 (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     framework3
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    any ideas?

  7. #7
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    10

    Default Re: Problem with apt-get upgrade

    Quote Originally Posted by M00kaw View Post
    SkyZD - what didn't work ?

    Did you purge all framework3 and the folders ?
    Yeah... i managed to get rid of all the folders np. when i used locate framework3 some extra files were still showing up but when i went to delete them they weren't actually there.

  8. #8
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: Problem with apt-get upgrade

    Kill the postgres process.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  9. #9
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    10

    Default Re: Problem with apt-get upgrade

    Quote Originally Posted by sickness View Post
    Kill the postgres process.
    sorry could you explain how do i do that?....i went into system manager/processes and it wasn't there... will restarting after after uninstalling help?

  10. #10
    Moderator KMDave's Avatar
    Join Date
    Jan 2010
    Posts
    2,281

    Default Re: Problem with apt-get upgrade

    Code:
    ps -ef | grep postgres
    kill -9 <processnumber>
    Tiocfaidh ár lá

Page 1 of 3 123 LastLast

Similar Threads

  1. SET upgrade problem
    By t0b1as in forum BackTrack 5 Beginners Section
    Replies: 4
    Last Post: 02-10-2012, 11:45 AM
  2. problem with openvas after upgrade
    By l1nu$ in forum Beginners Forum
    Replies: 17
    Last Post: 04-10-2011, 04:33 PM
  3. Upgrade problem
    By YairNava in forum Beginners Forum
    Replies: 1
    Last Post: 10-02-2010, 02:17 AM
  4. Another 2.6.34 upgrade problem...
    By RawShark in forum Beginners Forum
    Replies: 1
    Last Post: 08-01-2010, 07:32 AM
  5. Replies: 0
    Last Post: 11-17-2009, 09:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •