Results 1 to 10 of 15

Thread: Error for wireless request "Set Mode" (8B06)

Hybrid View

  1. #1
    Junior Member
    Join Date
    Jun 2006
    Posts
    75

    Talking Error for wireless request "Set Mode" (8B06)

    Just finished getting the wep key from aircrack but I keep seeing this error when I try to use the key.

    I have tried the following commands:

    # iwconfig ath0 mode managed key 40:EF:CC:26:34
    Error for wireless request "Set Mode" (8B06) :
    SET failed on device ath0 ; Invalid argument.

    Then I tried destroying the ath0 thinking that might be the problem:
    # wlanconfig ath0 destroy

    # iwconfig wifi0 mode managed key 40:EF:CC:26:34
    Error for wireless request "Set Mode" (8B06) :
    SET failed on device wifi0 ; Invalid argument.

    Same issue.

    # iwconfig
    lo no wireless extensions.

    wifi0 no wireless extensions.

    eth0 no wireless extensions.

    I searched google but everyone claims its a driver issue and I know thats not the reason because I am able to connect to OPN ap's without a problem. I searched this forum but this question has not been answered.

    Any ideas?

  2. #2
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by andyem View Post
    # iwconfig ath0 mode managed key 40:EF:CC:26:34
    Remove the :'s and try again. Also, try without setting the mode.
    "\x74\x68\x65\x70\x72\x65\x7a\x39\x38";

  3. #3
    Junior Member
    Join Date
    Jun 2006
    Posts
    75

    Default

    Quote Originally Posted by theprez98 View Post
    Remove the :'s and try again. Also, try without setting the mode.
    # iwconfig wifi0 key 40EFCC2634
    Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wifi0 ; Invalid argument.

    it produced the encode error.

    I even get similar results with:

    # iwconfig wifi0 mode managed key 40EFCC2634
    Error for wireless request "Set Mode" (8B06) :
    SET failed on device wifi0 ; Invalid argument.

    Then I tried to enable mon mode and run it off of ath0 but:

    # airmon-ng start wifi0


    Interface Chipset Driver

    wifi0 Atheros madwifi-ng
    ath0 Atheros madwifi-ng VAP (parent: wifi0) (monitor mode enabled)

    # iwconfig ath0 mode managed key 40EFCC2634
    Error for wireless request "Set Mode" (8B06) :
    SET failed on device ath0 ; Invalid argument.

    THIS WORKED: # iwconfig ath0 key 40EFCC2634

  4. #4
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by andyem View Post
    THIS WORKED: # iwconfig ath0 key 40EFCC2634
    There you go.
    "\x74\x68\x65\x70\x72\x65\x7a\x39\x38";

  5. #5
    Junior Member
    Join Date
    Jun 2006
    Posts
    75

    Default

    Quote Originally Posted by theprez98 View Post
    There you go.
    Thx for the help. I really wanted to post the results because I hate when threads go unfinished especially when its exactly the same problem I have

  6. #6
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by andyem View Post
    Thx for the help. I really wanted to post the results because I hate when threads go unfinished especially when its exactly the same problem I have
    Believe me, we appreciate that. Someone else will inevitably come along with the same problem. If we can educate users enough to use the search feature (yes, its a long process to get there), then someone will find your thread and learn something new without having to post a new thread.
    "\x74\x68\x65\x70\x72\x65\x7a\x39\x38";

  7. #7
    Just burned his ISO
    Join Date
    Sep 2007
    Posts
    1

    Default

    Hi Sorry for my poor english.
    I've just started to use Back|track 2.0, and i need a lot of practice

    Actually i have a problem similar, and i can't change the mode of my card (ath0) to managed.

    I do :
    (airmon-ng only show wifi0)
    airmon-ng start wifi0
    iwconfig ath0 mode managed

    And i get the same error : Error for wireless request "Set Mode" (8B06) :
    SET failed on device ath0 ; Invalid argument.

    My card is SCMWCBT-G.

    Thanks !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •