Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Wicd fails to get IP from wifi router - Unable to connect to Wifi

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    1

    Default Wicd fails to get IP from wifi router - Unable to connect to Wifi

    Hello,

    I am new to backtrack and have been setting it up over the last couple days. I am running it on a HP dv6t laptop and everything is working except for my wifi. I have tried connecting to my home network (WEP encryption) using Wicd. It appears to be working but then Wicd says "Connection failed: Unable to get IP address".

    I have read some other threads and at least one other person had this same problem, but no one knew a fix. Some said it was a problem with dhclient.

    I have a Alfa AWUS036H adapter and neither the Alfa or my laptops internal wifi card would connect. The Ethernet (eth0) connection works perfectly with my router and obtains an IP just fine. I have never had a problem connecting to my router with wifi in Windows.

    I hope there is a simple fix for this. Please clearly explain what I need to do or if I need to provide more info because I am relatively new to Linux.

    Thanks.

  2. #2
    Just burned his ISO
    Join Date
    Apr 2011
    Posts
    6

    Default Re: Wicd fails to get IP from wifi router - Unable to connect to Wifi

    listen when he say you cant connect this wifi have encryption or something like that you need to put the right password in password field, but there is something that writes wpa1/2 (passphrase) if you have a wep then you need to put there a WEP (passphrase). Sorry for my english and if this don't work then i can't help you

  3. #3
    Just burned his ISO
    Join Date
    May 2011
    Location
    Italy
    Posts
    7

    Default Riferimento: Wicd fails to get IP from wifi router - Unable to connect to Wifi

    I have this issue too.
    It happens both with WEP and OPEN APs. I'm using an rtl8187 wifi card and a zd1211rw and both have issues in getting an IP address.
    This is what I have observed:
    AP are quite far but signal reaches them without problems (I checked on the routers).
    Signal seems not to be a problem since I tried to inject on my WEP router and it worked fine (despite some little slowdowns).
    WPA, WEP handshakes seems to work fine, but wicd freezes at the dhcpcd step.
    I tried to set a static IP address on my client but it didn't work.
    In some cases AP gives me an IP address but connection doesn't work: I can't even access the router conf page.
    I tried to connect using rtl8187 windows drivers and connection worked.

    It seems to be something weird about wicd or dhcpcd client: I'll try to use a different wifi manager (but I don't believe that will change much) and as soon as I'll have some spare time I'm going to see what's going on with DHCP requests with wireshark.
    I'll try to see if my old bt4-r2 works too.

    Any suggestion is welcome!

  4. #4
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    2

    Default Re: Wicd fails to get IP from wifi router - Unable to connect to Wifi

    I had this issue too, putting the ip manually works for me.

  5. #5
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    7

    Default Re: Wicd fails to get IP from wifi router - Unable to connect to Wifi

    Open wicd click on properties of the network you are trying to connect to , tick static IPs then just put a unused ip address in put the netmask in and default gateway address in and not forgetting Passphrase click ok then try connecting .

  6. #6
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    1

    Default Re: Wicd fails to get IP from wifi router - Unable to connect to Wifi

    I had the same problem which I now fixed.
    As already mentioned above, in wicd under properties I changed the option WEP (Passphrase) to WEP (Hex [0-9/A-F]).
    Simple fix

  7. #7
    Just burned his ISO
    Join Date
    Nov 2011
    Posts
    3

    Default Re: Wicd fails to get IP from wifi router - Unable to connect to Wifi

    Bumping an old thread up.

    I also have this issue

    What I have tried
    1. Tried setting up a static ip addy through wicd (backtrack4/5)
    2. Tried all 3 options within wep security settings ( which it is)

    It authenticates then gets stuck on the next stage which is obtaining ip address

    The issue does not fall with the passwords, because I've tested them on Windows network connections and they connect and obtain and ip addy no problem.

    Please steer me towards the right direction.

    Thanks

  8. #8
    Just burned his ISO
    Join Date
    Nov 2011
    Posts
    4

    Default Re: Wicd fails to get IP from wifi router - Unable to connect to Wifi

    my lecturer sorted this issue out for me today.

    open yr root

    then ifconfig wlan0 up

    logged straight onto the wifi network

  9. #9
    Just burned his ISO
    Join Date
    Oct 2011
    Location
    SE Asia
    Posts
    3

    Default Re: Wicd fails to get IP from wifi router - Unable to connect to Wifi

    Hi all,
    I have this same issue. I have my own router with WEP (for aircrack-ng tutorial purposes) and after I get the key and enter it, same as listed above.
    no ip address. I have changed the WEP key options and the others give me "Bad password"

  10. #10
    Junior Member
    Join Date
    Mar 2010
    Location
    Italy
    Posts
    41

    Default Re: Wicd fails to get IP from wifi router - Unable to connect to Wifi

    From terminal:
    Code:
    dpkg-reconfigure wicd
    update-rc.d wicd defaults
    reboot
    Code:
    apt-get upgrade

Page 1 of 3 123 LastLast

Similar Threads

  1. Wicd ,dhclient fails to get IP from wifi router.
    By rooski in forum BackTrack 5 General Topics
    Replies: 3
    Last Post: 07-10-2011, 10:11 AM
  2. Replies: 11
    Last Post: 01-17-2011, 03:39 AM
  3. wicd wouldnt connect to wifi
    By ownergolan in forum Beginners Forum
    Replies: 4
    Last Post: 06-24-2010, 02:19 PM
  4. AWUS036H - Unable to connect when wifi is below -65dbm
    By Dishwasher in forum Beginners Forum
    Replies: 8
    Last Post: 03-26-2010, 11:38 AM
  5. Unable to connect in wifi
    By fredconcours in forum OLD Newbie Area
    Replies: 1
    Last Post: 09-26-2009, 07:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •