Page 1 of 2 12 LastLast
Results 1 to 10 of 22

Thread: Black screen after startx

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Apr 2011
    Posts
    1

    Default Black screen after startx

    Hello, I'm new in Backtrack.
    I installed BackTrack 5 but when I run it, I'm in console mode. And when I write "startx", my screen become black. Then I can do nothing. I have an asus and my graphic card is an Intel HD graphics.Could you help me please ? Thank you !

  2. #2
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    1

    Default Re: Black screen after startx

    I had a similar problem after I installed backtrack 5 to hard-disk. The temporary fix that I found was if I started up, logged in, and started x before turning on the screen it would show what it should be showing at that point not black. The longterm fix was to install ATI Catalyst drivers (My card is an ATI radeon 5750) which immediately fixed the problem (and gave me 3d acceleration).

  3. #3
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    3

    Default Re: Black screen after startx

    I had this exact same problem, when your on the boot options, press tab on the option you want and add acpi=off to the boot options then hit enter. You will encounter another problem when you type startx to get into the GUI, It'll do the exact same thing; Black screen, no response.

  4. #4
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    1

    Default Respuesta: Black screen after startx

    Hi, i had the same issue, i have an acer aspire with intel hd, you can solve the problem when doing this

    When you are in grub, select the os to boot, ubuntu 2.4.6 i think, and the press e
    you will be able to edit the boot configuration, where you see text splash nomodeset change it to text splash i915.modeset=1 and then press ctrl+x to boot, you should boot without problems

    After that, edit the file /boot/grub.cfg and do the same thing

    Hope it helps

  5. #5
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    1

    Default Re: Black screen after startx

    Wow, I have the exact same problem when I execute the "startx" command.

    At first, the GUI actually loaded but this doesn't work all of the time. I booted it at least 4 times before I get a black screen after executing "startx"

    I've tried it on several computers and for some the GUI doesn't start in the first place...

    I've re-installed it on my USB three times already...

  6. #6
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    2

    Default Re: Black screen after startx

    Here's a little tutorial to fix this (NOTE: Make sure your numlock or your caps lock key lights are flashing. If one/both are during the black screen, continue with the steps below.)


    1. Boot in to backtrack terminal (Just turn on the computer).
    2. Log in to root.
    3. type in "vim /etc/default/grub" (no quotes)
    4. find a line that looks similar to this: GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791"
    5. Move your cursor on top of the last quote on that line and press the letter 'i' on your keyboard (this turns vim in to inserting mode)
    6. Add a space between vga=791 and the quote then type in i915.modeset=1 (The new line should look like this: GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791 i915.modeset=1")
    7. Hit escape on your keyboard and type in ':x' (with out the quotes.. Just hit the keys) and press enter. This will close the editor.
    8. In your console type in 'update-grub' (no quotes)
    9. Wait
    10. Restart
    11. ????
    12. Log in to root, and type in startx... Profit.

  7. #7
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    1

    Default Re: Black screen after startx

    Quote Originally Posted by pros599 View Post
    Here's a little tutorial to fix this (NOTE: Make sure your numlock or your caps lock key lights are flashing. If one/both are during the black screen, continue with the steps below.)


    1. Boot in to backtrack terminal (Just turn on the computer).
    2. Log in to root.
    3. type in "vim /etc/default/grub" (no quotes)
    4. find a line that looks similar to this: GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791"
    5. Move your cursor on top of the last quote on that line and press the letter 'i' on your keyboard (this turns vim in to inserting mode)
    6. Add a space between vga=791 and the quote then type in i915.modeset=1 (The new line should look like this: GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791 i915.modeset=1")
    7. Hit escape on your keyboard and type in ':x' (with out the quotes.. Just hit the keys) and press enter. This will close the editor.
    8. In your console type in 'update-grub' (no quotes)
    9. Wait
    10. Restart
    11. ????
    12. Log in to root, and type in startx... Profit.

    very good tutorial pros, but i still have a problem, i can't "update-grub" because backtrack 5 is not installed on my machine, i am booting from live cd? oh............. how it can be happened to me? still have another sugestion guys? please help me......

  8. #8
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    1

    Default Re: Black screen after startx

    Quote Originally Posted by pros599 View Post
    Here's a little tutorial to fix this (NOTE: Make sure your numlock or your caps lock key lights are flashing. If one/both are during the black screen, continue with the steps below.)


    1. Boot in to backtrack terminal (Just turn on the computer).
    2. Log in to root.
    3. type in "vim /etc/default/grub" (no quotes)
    4. find a line that looks similar to this: GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791"
    5. Move your cursor on top of the last quote on that line and press the letter 'i' on your keyboard (this turns vim in to inserting mode)
    6. Add a space between vga=791 and the quote then type in i915.modeset=1 (The new line should look like this: GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791 i915.modeset=1")
    7. Hit escape on your keyboard and type in ':x' (with out the quotes.. Just hit the keys) and press enter. This will close the editor.
    8. In your console type in 'update-grub' (no quotes)
    9. Wait
    10. Restart
    11. ????
    12. Log in to root, and type in startx... Profit.
    I have BT-KDE-64 installed on a pen drive. I'm booting this on an HP Probook 4510s notebook. I boot into Backtrack Text.

    I followed the instructions but when I type update-grub I get: "/usr/sbin/srub-probe: error: cannot find a device for / (is /dev mounted?).

    Thanks for any help in sorting this out.

  9. #9
    Just burned his ISO
    Join Date
    Sep 2012
    Posts
    1

    Default Re: Black screen after startx

    Quote Originally Posted by pros599 View Post
    Here's a little tutorial to fix this (NOTE: Make sure your numlock or your caps lock key lights are flashing. If one/both are during the black screen, continue with the steps below.)


    1. Boot in to backtrack terminal (Just turn on the computer).
    2. Log in to root.
    3. type in "vim /etc/default/grub" (no quotes)
    4. find a line that looks similar to this: GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791"
    5. Move your cursor on top of the last quote on that line and press the letter 'i' on your keyboard (this turns vim in to inserting mode)
    6. Add a space between vga=791 and the quote then type in i915.modeset=1 (The new line should look like this: GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791 i915.modeset=1")
    7. Hit escape on your keyboard and type in ':x' (with out the quotes.. Just hit the keys) and press enter. This will close the editor.
    8. In your console type in 'update-grub' (no quotes)
    9. Wait
    10. Restart
    11. ????
    12. Log in to root, and type in startx... Profit.
    It worked on my DELL EATITUDE E5410 - Thank u so much !

  10. #10
    Just burned their ISO
    Join Date
    Feb 2013
    Posts
    2

    Talking Re: Black screen after startx

    Quote Originally Posted by pros599 View Post
    Here's a little tutorial to fix this (NOTE: Make sure your numlock or your caps lock key lights are flashing. If one/both are during the black screen, continue with the steps below.)


    1. Boot in to backtrack terminal (Just turn on the computer).
    2. Log in to root.
    3. type in "vim /etc/default/grub" (no quotes)
    4. find a line that looks similar to this: GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791"
    5. Move your cursor on top of the last quote on that line and press the letter 'i' on your keyboard (this turns vim in to inserting mode)
    6. Add a space between vga=791 and the quote then type in i915.modeset=1 (The new line should look like this: GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791 i915.modeset=1")
    7. Hit escape on your keyboard and type in ':x' (with out the quotes.. Just hit the keys) and press enter. This will close the editor.
    8. In your console type in 'update-grub' (no quotes)
    9. Wait
    10. Restart
    11. ????
    12. Log in to root, and type in startx... Profit.
    Thanks! it worked for me too, although root password seemed to change after but probably something I did. Im running a Toshiba Sat pro\win xp\AMD64x2\ AMD Radeon X1250

Page 1 of 2 12 LastLast

Similar Threads

  1. HP DV7 - ATI HD 5650 startx issue (Black screen)
    By mbooma in forum BackTrack 5 Bugs
    Replies: 18
    Last Post: 12-22-2011, 10:32 AM
  2. Black screen and LED flashing at startx
    By PoloB in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 06-27-2011, 04:53 PM
  3. Black Screen after startx
    By nprosper in forum BackTrack 5 Beginners Section
    Replies: 2
    Last Post: 06-16-2011, 05:00 AM
  4. Replies: 5
    Last Post: 01-20-2011, 02:53 AM
  5. Screen goes black after writing startx
    By xaerg in forum OLD LiveCD Support
    Replies: 5
    Last Post: 01-11-2008, 06:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •