Results 1 to 8 of 8

Thread: no screens found

  1. #1
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    4

    Default no screens found

    Hi!
    After I start x server(startx), it give me this error:

    (EE) No devices detected.
    Fatal server error:
    no screens found

    Here is my xorg.conf file

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 270.41.19  (buildmeister@swio-display-x86-rhel47-07.nvidia.com)  Mon May 16 23:52:12 PDT 2011
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    I'm using Backtrack 5 Kde 64x with nvidia geforce gt 525m

    Can someone help me configure xorg file?

  2. #2
    Moderator KMDave's Avatar
    Join Date
    Jan 2010
    Posts
    2,281

    Default Re: no screens found

    Just try to move the xorg.conf away and see if you can start it then.
    Tiocfaidh ár lá

  3. #3
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    4

    Default Re: no screens found

    Yes, its working if I remove it, I can start x server. But I can't change resolution to 1366x768. Its only alows me to change it to 1024x768 and 800x600.

    Is there any other way to fix this problem?

  4. #4
    Junior Member
    Join Date
    Jul 2008
    Posts
    44

    Default Re: no screens found

    Check the forums i beleive there are some fixes implemented.

    after having a net connection
    type in console

    prepare-kernel-sources

    cd /usr/src/linux
    cp -rf include/generated/* include/linux/


    chmod +x nvidiafilename (you got it from www.nvidia.com > driver download and select yours )

    log out and run the following command (before you startx)

    sh nvidiafilename

    i tried it on hdd installation for bt5|64bit and it works well
    regards

  5. #5
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    4

    Default Re: no screens found

    That didn't solve the problem. Still getting no screens error.

    I'm using driver - NVIDIA Accelerated Graphics Driver for Linux-x86_64 275.09.07
    PC:
    Dell inspiron n5110
    Processor: Intel® Quad Core™ i7-2630QM Processor 2.0
    RAM: 4 GB
    Video card: nVIDIA GeForce GT 525M

    Another interesting thing is that when I load Backtrack from CD to install it, it won't show me even a console mode screen(where I need to write user, password and startx), what i get is just a black screen. For loading startx to install Backtrack I used this code:
    Code:
    cd /root/.kde/
    find . -type f -iname "*.kcache" -delete
    After this code startx starts normally and resolution can be set to 1366x768. After I install Backtrack on hdd I can't change the resolution. After installing nvidia drivers I'm getting no screens found error.

    I tried all methods that I could find and non of them worked. I would appreciate it if you could post link to solution.

  6. #6
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    4

    Default Re: no screens found

    Didn't help, still getting no screen error.

    Another interesting thing is that, that when i load DVD to install BackTrack, it won't boot even cli. So i have to use this code:
    Code:
    cd /root/.kde/
    find . -type f -iname "*.kcache" -delete
    After I startx I can change screen to normal resolution(1366x768).
    After installing BackTrack on HDD I only have 1024x768 and 800x600.

    I tried all solutions that I could find, and non of them worked. Can you please post link to that solutions?

    P.S.
    Maybe this information will help
    I have laptop with:
    Processor - Intel® Core™ i7-2630QM 2.00GHz
    RAM -4GB
    Video card - nvidia geforce gt 525m
    Driver that I install - NVIDIA-Linux-x86_64-275.09.07.run

  7. #7
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    2

    Default Re: no screens found

    Having the same issue, I own the same laptop!.

    My thoughts are that it runs dual video cards, ****ing IntelHD3000 POS with the Nvidia 525m..
    Ballsed if i can work out why the screen res works off the live CD and not after install..

  8. #8
    Just burned his ISO
    Join Date
    Feb 2011
    Location
    Kletonia
    Posts
    1

    Default Re: no screens found

    For me it worked just reinstalling the Nvidia drivers!! sh Nvidia_bla_bla.run and everything runs smoothly

Similar Threads

  1. BT4 Problem Acer, WIMD devices not found/No screens found
    By Mahatna in forum Beginners Forum
    Replies: 0
    Last Post: 02-17-2011, 03:44 PM
  2. BT4: no screens found
    By Paroxysme in forum Beginners Forum
    Replies: 0
    Last Post: 09-18-2010, 10:26 AM
  3. No Screens Found
    By Emergent in forum OLD BT3beta Software related issues
    Replies: 0
    Last Post: 01-20-2008, 12:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •