Hello,

i have a problem which annoys me a lot. When i try to connect to a WEP w-lan using WICD Network manager it runs trough every step and hangs at Obtaining ip address. After like 1 min i get an error "Could not get IP address". Since i tried to fix this issue since like 4 hours i found a lot of threads where people experience the same problem.

i found a way to connect over the command-line - i tried it and it worked once

Code:
ifconfig wlan0 essid NETWORKNAME key 1122334455
ifconfig wlan0 up
dhclient wlan0
it worked at the first time but after 5 minutes the connection was lost and i was not able to reconnect using the same technique.


When i perform this command now the output is the following one:

Code:
root@bt:~# iwconfig wlan0 essid homebase key 2890854901
root@bt:~# ifconfig wlan0 up
root@bt:~# dhclient wlan0
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/48:5d:60:d2:bc:e2
Sending on   LPF/wlan0/48:5d:60:d2:bc:e2
Sending on   Socket/fallback
DHCPREQUEST of 192.168.1.18 on wlan0 to 255.255.255.255 port 67
DHCPREQUEST of 192.168.1.18 on wlan0 to 255.255.255.255 port 67
DHCPREQUEST of 192.168.1.18 on wlan0 to 255.255.255.255 port 67
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
No DHCPOFFERS received.
Trying recorded lease 192.168.1.18
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

--- 192.168.1.1 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

No working leases in persistent database - sleeping.
root@bt:~# 

root@bt:~# iwconfig wlan1 essid homebase key 2890854901
root@bt:~# ifconfig wlan1 up
root@bt:~# dhclient wlan1
There is already a pid file /var/run/dhclient.pid with pid 15586
killed old client process, removed PID file                                                                                   
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.                                                                              
All rights reserved.                                                                                                          
For info, please visit https://www.isc.org/software/dhcp/                                                                     
                                                                                                                              
Listening on LPF/wlan1/00:11:33:33:77:55                                                                                      
Sending on   LPF/wlan1/00:11:33:33:77:55
Sending on   Socket/fallback                                                                                                  
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 2
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
Please help me with this annoying problem