Results 1 to 4 of 4

Thread: My Fixes for metasploit db_driver and pcaprub loading

  1. #1
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    1

    Default My Fixes for metasploit db_driver and pcaprub loading

    Here are some quick solutions that worked for my setup of backtrack 5 gnome 64bit

    1. To get the database to load with available db_drivers, just start metasploit msfconsole from the terminal or run from the backtrack menu if you are root.
    2. When you try to run an auxillary module or scanner you receive an error about pcaprub not being loaded.

    My solution

    Compile the pcap module from the /msf3/external folder:

    1. ruby extconf.rb && make
    sudo make install

    2. cd /usr/local/lib/site_ruby/1.9.2/x86_64-linux
    cp pcaprub.so /opt/framework3/ruby/lib/ruby/site_ruby/1.9.1/x86_64-linux

  2. #2
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    1

    Default Re: My Fixes for metasploit db_driver and pcaprub loading

    Quote Originally Posted by 3vi1john View Post
    Here are some quick solutions that worked for my setup of backtrack 5 gnome 64bit

    1. To get the database to load with available db_drivers, just start metasploit msfconsole from the terminal or run from the backtrack menu if you are root.
    2. When you try to run an auxillary module or scanner you receive an error about pcaprub not being loaded.

    My solution

    Compile the pcap module from the /msf3/external folder:

    1. ruby extconf.rb && make
    sudo make install

    2. cd /usr/local/lib/site_ruby/1.9.2/x86_64-linux
    cp pcaprub.so /opt/framework3/ruby/lib/ruby/site_ruby/1.9.1/x86_64-linux
    This worked flawlessly. Thank you so much. I knew it was something simple like this, but I probs wouldn't have figured it out. I'm on 32bit BT5 running in 64bit Linuxmint Host on VMware Player. The x86_64-linux folder was /usr/local/lib/site_ruby/1.9.2/i486-linux and /opt/framework3/ruby/lib/ruby/site_ruby/1.9.1/i686-linux/ respectively.

  3. #3
    Good friend of the forums scottm99's Avatar
    Join Date
    Feb 2010
    Location
    underwater
    Posts
    371

    Default Re: My Fixes for metasploit db_driver and pcaprub loading

    I can confirm that this works also on an install of 32-bit BT5 virtual machine, using gnome. As I posted in another thread, the 4.0 version of the framework is available & will hopefully resolve this & other issues.
    If I could figure out how to scuba dive & hack at the same time, there would be nothing I couldn't do...

  4. #4
    Just burned his ISO
    Join Date
    May 2010
    Posts
    6

    Default Re: My Fixes for metasploit db_driver and pcaprub loading

    Still a valid fix on the latest rev

Similar Threads

  1. Metasploit pcaprub fix in BT5
    By scottm99 in forum BackTrack 5 Beginners Section
    Replies: 6
    Last Post: 07-18-2011, 05:29 PM
  2. Replies: 1
    Last Post: 05-07-2011, 01:35 PM
  3. Replies: 1
    Last Post: 04-18-2010, 06:37 PM
  4. metasploit , db_driver: command not found
    By Justs in forum Beginners Forum
    Replies: 2
    Last Post: 03-30-2010, 03:44 AM
  5. Problem loading db_sqlite3, calling db_driver
    By kazalku in forum OLD Latest Public Release - BackTrack4 Beta
    Replies: 11
    Last Post: 06-21-2009, 06:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •