Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Metasploit Error after update

  1. #1
    Just burned his ISO
    Join Date
    May 2011
    Posts
    14

    Exclamation Metasploit Error after update

    Hi guys! Five times I reinstall backtrack 5 and i enough of that!
    So here is problem.....
    BackTrack works ok. Updates appeared! I install all of them(including metasploit)

    Now when my system boots up, first thing after startx is text that appears at my monitor! There is written:

    Code:
    FATAL: bogus data in lock file "postmaster.pid": ""
    /opt/framework3/postgresql/scripts.ctl.sh : postgresql could not be started
    And then, start up splash screen loads...(Normally!)
    After that i open metasploit and get angry!

    Before it loads it says:

    Code:
    [-] Failed to connect to the database: could not connect to server: Connection refused
            Is the server running on host "127.0.0.1" and accepting
            TCP/IP connections on port 7175?
     {"adapter"=>"postgresql", "database"=>"msf3", "username"=>"msf3", "password"=>"6a794a78", "host"=>"127.0.0.1", "port"=>7175, "pool"=>75, "timeout"=>5} ["/opt/framework3/msf3/lib/active_record/connection_adapters/postgresql_adapter.rb:968:in `initialize'", "/opt/framework3/msf3/lib/active_record/connection_adapters/postgresql_adapter.rb:968:in `new'", "/opt/framework3/msf3/lib/active_record/connection_adapters/postgresql_adapter.rb:968:in `connect'", "/opt/framework3/msf3/lib/active_record/connection_adapters/postgresql_adapter.rb:217:in `initialize'", "/opt/framework3/msf3/lib/active_record/connection_adapters/postgresql_adapter.rb:37:in `new'", "/opt/framework3/msf3/lib/active_record/connection_adapters/postgresql_adapter.rb:37:in `postgresql_connection'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:223:in `new_connection'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:245:in `checkout_new_connection'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:188:in `block (2 levels) in checkout'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:184:in `loop'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:184:in `block in checkout'", "/opt/framework3/ruby/lib/ruby/1.9.1/monitor.rb:201:in `mon_synchronize'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:183:in `checkout'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:98:in `connection'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:326:in `retrieve_connection'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_specification.rb:123:in `retrieve_connection'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_specification.rb:115:in `connection'", "/opt/framework3/msf3/lib/active_record/base.rb:1271:in `columns'", "/opt/framework3/msf3/lib/active_record/base.rb:1284:in `column_names'", "/opt/framework3/msf3/lib/active_record/base.rb:1297:in `column_methods_hash'", "/opt/framework3/msf3/lib/active_record/base.rb:1986:in `block in all_attributes_exists?'", "/opt/framework3/msf3/lib/active_record/base.rb:1986:in `each'", "/opt/framework3/msf3/lib/active_record/base.rb:1986:in `all?'", "/opt/framework3/msf3/lib/active_record/base.rb:1986:in `all_attributes_exists?'", "/opt/framework3/msf3/lib/active_record/base.rb:1842:in `method_missing'", "/opt/framework3/msf3/lib/msf/core/model/workspace.rb:29:in `default'", "/opt/framework3/msf3/lib/msf/core/db.rb:188:in `default_workspace'", "/opt/framework3/msf3/lib/msf/core/db_manager.rb:166:in `connect'", "/opt/framework3/msf3/lib/msf/ui/console/driver.rb:181:in `initialize'", "/opt/framework3/msf3/msfconsole:130:in `new'", "/opt/framework3/msf3/msfconsole:130:in `<main>'"]

    Any help? Suggestions?

  2. #2
    Good friend of the forums scottm99's Avatar
    Join Date
    Feb 2010
    Location
    underwater
    Posts
    371

    Default Re: Metasploit Error after update

    Which version of BT5 are you using? Is it a vm image? I'm using the 32-bit BT5 gnome image, and ran msfupdate earlier today with no problems. Was google any help?

    Once you get postgresql starting ok, try running db_connect –y /opt/framework3/config/database.yml at an msf> prompt. This will connect you to the built-in postgresql instance.
    If I could figure out how to scuba dive & hack at the same time, there would be nothing I couldn't do...

  3. #3
    Senior Member
    Join Date
    Jan 2011
    Location
    over the under
    Posts
    197

    Default Re: Metasploit Error after update

    I can verify this for gnome 64 bit installed to hard drive.

    Code:
    :/opt/framework3/msf3# svn up
    U    lib/rapid7/nexpose.rb
    Updated to revision 12884.
    Code:
    :/opt/framework3/msf3# msfconsole
    [-] Failed to connect to the database: could not connect to server: Connection refused
    	Is the server running on host "127.0.0.1" and accepting
    	TCP/IP connections on port 7175?
     {"adapter"=>"postgresql", "database"=>"msf3", "username"=>"msf3", "password"=>"*********", "host"=>"127.0.0.1", "port"=>7175, "pool"=>75, "timeout"=>5} ["/opt/framework3/msf3/lib/active_record/connection_adapters/postgresql_adapter.rb:968:in `initialize'", "/opt/framework3/msf3/lib/active_record/connection_adapters/postgresql_adapter.rb:968:in `new'", "/opt/framework3/msf3/lib/active_record/connection_adapters/postgresql_adapter.rb:968:in `connect'", "/opt/framework3/msf3/lib/active_record/connection_adapters/postgresql_adapter.rb:217:in `initialize'", "/opt/framework3/msf3/lib/active_record/connection_adapters/postgresql_adapter.rb:37:in `new'", "/opt/framework3/msf3/lib/active_record/connection_adapters/postgresql_adapter.rb:37:in `postgresql_connection'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:223:in `new_connection'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:245:in `checkout_new_connection'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:188:in `block (2 levels) in checkout'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:184:in `loop'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:184:in `block in checkout'", "/opt/framework3/ruby/lib/ruby/1.9.1/monitor.rb:201:in `mon_synchronize'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:183:in `checkout'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:98:in `connection'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_pool.rb:326:in `retrieve_connection'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_specification.rb:123:in `retrieve_connection'", "/opt/framework3/msf3/lib/active_record/connection_adapters/abstract/connection_specification.rb:115:in `connection'", "/opt/framework3/msf3/lib/active_record/base.rb:1271:in `columns'", "/opt/framework3/msf3/lib/active_record/base.rb:1284:in `column_names'", "/opt/framework3/msf3/lib/active_record/base.rb:1297:in `column_methods_hash'", "/opt/framework3/msf3/lib/active_record/base.rb:1986:in `block in all_attributes_exists?'", "/opt/framework3/msf3/lib/active_record/base.rb:1986:in `each'", "/opt/framework3/msf3/lib/active_record/base.rb:1986:in `all?'", "/opt/framework3/msf3/lib/active_record/base.rb:1986:in `all_attributes_exists?'", "/opt/framework3/msf3/lib/active_record/base.rb:1842:in `method_missing'", "/opt/framework3/msf3/lib/msf/core/model/workspace.rb:29:in `default'", "/opt/framework3/msf3/lib/msf/core/db.rb:188:in `default_workspace'", "/opt/framework3/msf3/lib/msf/core/db_manager.rb:166:in `connect'", "/opt/framework3/msf3/lib/msf/ui/console/driver.rb:181:in `initialize'", "/opt/framework3/msf3/msfconsole:130:in `new'", "/opt/framework3/msf3/msfconsole:130:in `<main>'"]
    
                    _                  _       _ _
                   | |                | |     (_) |
     _ __ ___   ___| |_ __ _ ___ _ __ | | ___  _| |_
    | '_ ` _ \ / _ \ __/ _` / __| '_ \| |/ _ \| | __|
    | | | | | |  __/ || (_| \__ \ |_) | | (_) | | |_
    |_| |_| |_|\___|\__\__,_|___/ .__/|_|\___/|_|\__|
                                | |
                                |_|
    
    
           =[ metasploit v3.8.0-dev [core:3.8 api:1.0]
    + -- --=[ 694 exploits - 358 auxiliary - 47 post
    + -- --=[ 223 payloads - 27 encoders - 8 nops
           =[ svn r12884 updated today (2011.06.08)
    
    msf > db_status[*] postgresql selected, no connection
    msf >

  4. #4
    Just burned his ISO
    Join Date
    May 2011
    Posts
    14

    Default Re: Metasploit Error after update

    I am running BackTrack5 32bit KDE. I love BT5, and really need metasploit :/
    Any ideas?

  5. #5
    Good friend of the forums scottm99's Avatar
    Join Date
    Feb 2010
    Location
    underwater
    Posts
    371

    Default Re: Metasploit Error after update

    My svn rev is 12883, and it's working ok.
    If I could figure out how to scuba dive & hack at the same time, there would be nothing I couldn't do...

  6. #6
    Senior Member
    Join Date
    Jan 2011
    Location
    over the under
    Posts
    197

    Default Re: Metasploit Error after update

    12883 was also working fine for me, 12884 killed it

  7. #7
    Just burned his ISO
    Join Date
    May 2011
    Posts
    14

    Default Re: Metasploit Error after update

    I am in rev 12901 right now. Rev 12883 really make me angry. Rev 12883 was working fine! Help please!

  8. #8
    Just burned his ISO
    Join Date
    Dec 2010
    Posts
    2

    Default 回覆: Metasploit Error after update

    me too.
    Metasploit after update
    Error
    Failed to connect to the database: could not connect to server: Connection refused
    Is the server running on host "127.0.0.1" and accepting
    TCP/IP connections on port 7175?

  9. #9
    Just burned his ISO mcurran's Avatar
    Join Date
    Aug 2010
    Location
    Abington - MA
    Posts
    9

    Default Re: Metasploit Error after update

    Maybe try restarting the framework-postgres service in /etc/init.d/? - This usually gets me around that error. I also configure all my postgresql instances' usernames and passwords to be the same, which will require running psql in their native installed directories and also editing the properties.ini file accordingly in the framwork directory under /opt/. So for instance, if I want to change the password for postgres user under the framework3's postgres instance, I'll navigate to /opt/framework3/postgresql/bin/ and then run "su postgres -c psql template1" enter the password given in the properties.ini file, and then run "ALTER USER postgres WITH PASSWORD 'newpassword'; \q

  10. #10
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    6

    Default Re : Metasploit Error after update


Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 05-07-2011, 01:35 PM
  2. Ruby Gems Error after Metasploit Update
    By blakhal0 in forum BackTrack Bugs
    Replies: 7
    Last Post: 01-19-2011, 03:21 AM
  3. metasploit wont update:error
    By BigMac in forum OLD Newbie Area
    Replies: 7
    Last Post: 01-01-2010, 09:06 AM
  4. Svn Update Metasploit Error
    By fload in forum OLD Newbie Area
    Replies: 2
    Last Post: 02-27-2009, 09:47 PM
  5. metasploit -msfupdate error - svn : PROFIND request error
    By aisketui in forum OLD BT3beta Software related issues
    Replies: 2
    Last Post: 02-11-2009, 03:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •