Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Install BT2 on a usb stick (full install) -> kernel panic

  1. #1
    Just burned his ISO
    Join Date
    May 2007
    Posts
    24

    Default Install BT2 on a usb stick (full install) -> kernel panic

    Hi,

    I'm trying to install bt2 on an 4 GB USB Stick and get the well known kernel panic . I allready tried the hints within this howto:

    forums.remote-exploit.org/showthread.php?t=6868

    However I still get a kernel panic

    Maybe somebody could figure out what I did wrong:

    1. boot bt in a VM
    2. partition the usb stick (1 primary ext3 partition with boot flag 3500M, 1 swap partition 500M)
    3. mkfs.ext3 /dev/sda1 to get a file system
    4. mount sda1 and the cd
    4. start the installer and perform a full install
    5. chroot to sda1 and go to the kernel files
    6. make menuconfig -> Device Drivers -> USB support:
    - * EHCI ..
    - * OHCI ..
    - * UHCI ..
    7. make
    8. make install
    9. boot to the USB Stick -> kenel panic

    Thanks!
    ## proud to be a nerd ##


    We no longer allow links in sigs --pureh@te

  2. #2
    Just burned his ISO
    Join Date
    May 2007
    Posts
    24

    Default

    Hi,

    no idea on this?

    Thanks
    ## proud to be a nerd ##


    We no longer allow links in sigs --pureh@te

  3. #3
    Just burned his ISO
    Join Date
    May 2007
    Posts
    24

    Default

    Ok still no reply. Did anybody manage to get a full installation running on a usb stick?

    Any help would be appreciated!
    ## proud to be a nerd ##


    We no longer allow links in sigs --pureh@te

  4. #4
    Junior Member
    Join Date
    Aug 2006
    Posts
    29

    Default

    no have tried severyl times to get it working but still no luck

  5. #5
    Just burned his ISO
    Join Date
    May 2007
    Posts
    24

    Default

    Thanks for your reply. At least I'm not the only person who didn't get it running...
    ## proud to be a nerd ##


    We no longer allow links in sigs --pureh@te

  6. #6
    Junior Member
    Join Date
    Aug 2006
    Posts
    29

    Default

    that can´t be...

    Nobody have ever got a full install working on a usb stick??

  7. #7
    Junior Member
    Join Date
    May 2007
    Posts
    60

    Default

    I've installed it many times on a 1GB USB stick. I have Windows XP (and Vista) and I use MagicISO or UltraISO.

    You probably have Linux so this probably wont be helpful to you.

    Also, I've read somewhere that the version of VM matters a lot. I think the latest version (6?) is the one to have. Not sure, but I would definitley do a search for the VM version you need.

    All I got.

  8. #8
    Just burned his ISO
    Join Date
    Nov 2006
    Posts
    17

    Default

    bound, I am trying to install BT to USB from Windows, please provide the steps you used.

    thanks!

  9. #9
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    lol you want to do a real install from windows ..........you can't do a real install in fat32...............only a live.......

    BT IS INTENDED TO BE LIVE WHY DO YOU WANT IT REAL ?
    i got a 160go usb live multipartition install with a swap part, a changes part and a data part
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  10. #10
    Just burned his ISO
    Join Date
    Jun 2007
    Posts
    6

    Default

    I am ahaving the same problems on my USB Stick

    RAMDISK:Couldnt find valid RAM disk image starting at 0.
    VFS: Cannot open root device "803" or unknown-block(8,3)
    Please append a correct "root=" boot option.


    even tried shamanvirtuels guide but I am having problems with the liloconfig

    click ok when done close installer window

    we now need to update the kernel boot parameters in order boot bt on the key and to activate permanent changes so we will need to rebuild the mbr





    liloconfig

    Expert

    Begin with new one


    Shall i reboot so that it boots on my new usb device first before running liloconfig If i do that i get the same error as before.


    RAMDISK:Couldnt find valid RAM disk image starting at 0.
    VFS: Cannot open root device "803" or unknown-block(8,3)
    Please append a correct "root=" boot option.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •