Hi I've read this http://www.backtrack-linux.org/forum...85-driver.html thread. I was trying all methods. I've got VMware 7.0 and BackTrack 5. I've got integrated Atheros AR9825. I was also trying these methods in BackTrack3. I even made USB Live with BackTrack 3, didn't help. In BackTrack 5 i got this warning:
Code:
root@bt:~/compat-wireless-2.6.32.3# make
./scripts/gen-compat-autoconf.sh config.mk > include/linux/compat_autoconf.h
make -C /lib/modules/2.6.38/build M=/root/compat-wireless-2.6.32.3 modules
make[1]: Entering directory `/usr/src/linux-source-2.6.38'

  WARNING: Symbol version dump /usr/src/linux-source-2.6.38/Module.symvers
           is missing; modules will have no dependencies and modversions.

  CC [M]  /root/compat-wireless-2.6.32.3/drivers/net/wireless/ath/main.o
  CC [M]  /root/compat-wireless-2.6.32.3/drivers/net/wireless/ath/regd.o
In file included from /root/compat-wireless-2.6.32.3/include/net/cfg80211.h:13,
                 from /root/compat-wireless-2.6.32.3/drivers/net/wireless/ath/regd.c:19:
include/linux/netdevice.h:849: error: field ‘pm_qos_req’ has incomplete type
In file included from /root/compat-wireless-2.6.32.3/drivers/net/wireless/ath/regd.c:20:
/root/compat-wireless-2.6.32.3/include/net/mac80211.h:1481: warning: ‘struct dev_addr_list’ declared inside parameter list
/root/compat-wireless-2.6.32.3/include/net/mac80211.h:1481: warning: its scope is only this definition or declaration, which is probably not what you want
make[4]: *** [/root/compat-wireless-2.6.32.3/drivers/net/wireless/ath/regd.o] Error 1
make[3]: *** [/root/compat-wireless-2.6.32.3/drivers/net/wireless/ath] Error 2
make[2]: *** [/root/compat-wireless-2.6.32.3/drivers/net/wireless] Error 2
make[1]: *** [_module_/root/compat-wireless-2.6.32.3] Error 2
make[1]: Leaving directory `/usr/src/linux-source-2.6.38'
make: *** [modules] Error 2
Now Im downloading BackTrack 4 R2 and ive got hope that Live DVD will be working...
Do you know any solutions to my problem?