Hello, i'm a new here and just installed Backtrack 5 because i Love those Dragon art lolz.. My impression for this distribution is quite good and Backtrack 5 is way much better than backtrack 4.

There's something bugging me about Python package in Backtrack, since it based on ubuntu which is most of it software depend on Python2.7 ( Please correct me if i'm wrong ). And i saw there are about 4 Python version inside backtrack 5. Is there any better way to split this package? I saw this split package causing the "incompatibility" with upstream ( ubuntu 10.04 ).

Maybe we can take a look Archlinux way to split this python so user will not face any break package. If i see the library i guess it's gonna be a lot of work to do. But Maybe it can be done for next release i guess.

That's just my 2cents,