Results 1 to 10 of 11

Thread: Sweet thread about ipw2200 packet injection and monitor mode

Threaded View

  1. #1
    Just burned his ISO DementiaPraecox's Avatar
    Join Date
    Feb 2011
    Posts
    9

    Default Sweet thread about ipw2200 packet injection and monitor mode

    So here I am again asking cliched quetions about topic that appeared so many times in forums.

    Seriously: Is there any way to use Intel/Pro Wireless 2200 BG on BackTrack 5??

    As far as I know BackTrack 2 was last system that supported this card (why?).
    And yes, I read many artices that deal with this problem but found nothing worked for me.

    Only thing that worked was downloading firmware (why is it absent on BT5?), so I managed to turn card on and connect tos. APBut I can't inject packets or even turn it to monitor mode (not counting 'iwconfig' that does nothing at all 'cause as soon as I execute 'airodump-ng' card change back to "managed" mode and stop listening).

    1) airmon-ng constanly shows: 'ERROR while getting interface flags: No such device' but in dmesg everything's ok (no errors or other stuff)
    2) rmmod and modprobe aren't help
    3) rtap_iface in iwconfig shows: 'no wireless extensions', and I can't change its parameters. When trying 'ifconfig rtap0 up' system lock up. Doing this 'echo 1 > sys/bus/.../rtap_iface' also doesn't help
    4) this combination of 'rtap0 eth1' and vice versa does nothing
    5) airdriver-ng detects card but 'reload' parameter returns something about drivers not found in some non-existent directory
    6) and that injection patch in 'pentest/aircrack/' I can't get it to work: Some HUNK:failed errors
    7) downloading linux-headers and linux-source isn't helping

    And one question off topic: I tried rt73 card on bt5.iso installed on laptop and downloadable vmware version and executing 'locate rt73' on both threw slightly different results. On vmware *.ko files were in /lib/... directory AND also in 'linux-source' directory, but on laptop were only in /lib/... though I used 'apt-get install' to I-hope-install linux-source on laptop. Why is that??

    I have Dell D610.
    Could some linux-pro (or someone who REALLY knows what's going on) explain why I can't get this card to work and tell me what should I do to set everything properly?

    I'll be very grateful. Thanks to everyone who seriously want to help me.

    FIRMWARE 3.1 IS PRESENT. CARD WORKS WITH CONNECING TO AP's. AIRMON AND AND MONITOR MODE AREN'T WORKING. MANUAL SETTING TO MONITOR LASTS AS FAR AS EXECUTING ANYTHING FROM AIRCRACK SET.

    Sorry for my english.
    Last edited by DementiaPraecox; 06-14-2011 at 04:48 PM.

Similar Threads

  1. ipw2200+monitor mode+packet injection
    By Crowİ in forum Angolo dei Newbie
    Replies: 1
    Last Post: 09-03-2009, 04:35 PM
  2. ipw2200 and monitor mode
    By Crowİ in forum OLD Newbie Area
    Replies: 5
    Last Post: 03-03-2009, 01:40 PM
  3. IPW2200 Packet injection
    By Wilson08 in forum OLD Newbie Area
    Replies: 3
    Last Post: 12-29-2008, 07:52 PM
  4. Replies: 5
    Last Post: 10-09-2008, 11:33 AM
  5. Injection test: in manged mode or in monitor mode?
    By john99 in forum OLD Newbie Area
    Replies: 2
    Last Post: 05-02-2008, 11:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •