Results 1 to 4 of 4

Thread: WARNING: Symbol version dump /usr/src/linux-source-2.6.38/Module.symvers

  1. #1
    Just burned his ISO
    Join Date
    May 2011
    Posts
    2

    Default WARNING: Symbol version dump /usr/src/linux-source-2.6.38/Module.symvers

    I'm trying to build drivers following this guide:
    http://www.aircrack-ng.org/doku.php?id=rt2570

    However when running "make" I get this error:
    # make
    make[1]: Entering directory `/usr/src/linux-source-2.6.38'

    WARNING: Symbol version dump /usr/src/linux-source-2.6.38/Module.symvers
    is missing; modules will have no dependencies and modversions.

    Building modules, stage 2.
    MODPOST 0 modules
    make[1]: Leaving directory `/usr/src/linux-source-2.6.38'
    rt2570.ko failed to build!
    make: *** [module] Error 1
    What am I missing? I have already installed the linux-source following this guide: http://www.backtrack-linux.org/forum...ivers-etc.html

    Searching this forum, and google I see others having similar problems, but no solution?

  2. #2
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    1

    Default Re: WARNING: Symbol version dump /usr/src/linux-source-2.6.38/Module.symvers

    I'm getting the same warning, anyone know how to fix this issue? Had it after installing the 64bit ISO to a Vmware 7.1 virtual machine. Followed the instructions mentioned to prepare sources but installing the Vmware tools failed with a compiler error after complaining about this missing source.

  3. #3
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    1

    Default Re: WARNING: Symbol version dump /usr/src/linux-source-2.6.38/Module.symvers

    I'm running into the same issue when trying to install a gobi 2000. I found the below link and it fixed my problem. good luck.

    http://www.linuxquestions.org/questi...399#post962399

    d33v30

  4. #4
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    3

    Default Re: WARNING: Symbol version dump /usr/src/linux-source-2.6.38/Module.symvers

    I'm trying to install cisco vpn client according this manual to and get this error:
    Making module
    make -C /lib/modules/2.6.38/build SUBDIRS=/usr/src/vpnclient modules
    make[1]: Entering directory `/usr/src/linux-source-2.6.38'

    WARNING: Symbol version dump /usr/src/linux-source-2.6.38/Module.symvers
    is missing; modules will have no dependencies and modversions.

    CC [M] /usr/src/vpnclient/linuxcniapi.o
    In file included from /usr/src/vpnclient/Cniapi.h:15,
    from /usr/src/vpnclient/linuxcniapi.c:30:
    /usr/src/vpnclient/GenDefs.h:113: error: conflicting types for ‘uintptr_t’
    include/linux/types.h:44: note: previous declaration of ‘uintptr_t’ was here
    make[2]: *** [/usr/src/vpnclient/linuxcniapi.o] Error 1
    make[1]: *** [_module_/usr/src/vpnclient] Error 2
    make[1]: Leaving directory `/usr/src/linux-source-2.6.38'
    make: *** [default] Error 2
    Failed to make module "cisco_ipsec.ko".

Similar Threads

  1. Atheros 5001 Module.symvers
    By hugo117 in forum Suporte Hardware
    Replies: 4
    Last Post: 01-03-2011, 06:08 AM
  2. how to check linux version in bt4
    By ammadeyy in forum OLD Newbie Area
    Replies: 1
    Last Post: 12-22-2009, 06:49 AM
  3. Com on air and missing module - Module.symvers
    By imported_ASTRAPI in forum OLD BackTrack 4 General Support
    Replies: 2
    Last Post: 11-21-2009, 06:02 AM
  4. ATI DRIVER precompiled kernel module version mismatched
    By phil128 in forum OLD BT3beta NON-WORKING HARDWARE
    Replies: 1
    Last Post: 02-19-2008, 03:03 AM
  5. Version of NDISwapper & Linux
    By msaltz in forum OLD Newbie Area
    Replies: 3
    Last Post: 08-26-2007, 11:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •